summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2002-10-02 04:48:41 +0000
committerRyan Phillips <rphillips@gentoo.org>2002-10-02 04:48:41 +0000
commit4feb0674cfbee4f1ddd4679d8062188bf6f3f571 (patch)
treedfb643809713aa83526c97ace29641819b64c729 /net-fs/openafs
parentFixed HOMEPAGE variable (diff)
downloadgentoo-2-4feb0674cfbee4f1ddd4679d8062188bf6f3f571.tar.gz
gentoo-2-4feb0674cfbee4f1ddd4679d8062188bf6f3f571.tar.bz2
gentoo-2-4feb0674cfbee4f1ddd4679d8062188bf6f3f571.zip
Submitted Patch. Hopefully fixes #7775 for good.
Diffstat (limited to 'net-fs/openafs')
-rw-r--r--net-fs/openafs/ChangeLog9
-rw-r--r--net-fs/openafs/files/digest-openafs-1.2.6-r11
-rw-r--r--net-fs/openafs/files/openafs-1.2.6.patch44
-rw-r--r--net-fs/openafs/openafs-1.2.6-r1.ebuild101
-rw-r--r--net-fs/openafs/openafs-1.2.6.ebuild1
5 files changed, 155 insertions, 1 deletions
diff --git a/net-fs/openafs/ChangeLog b/net-fs/openafs/ChangeLog
index 3021926de075..12911d8fdf7f 100644
--- a/net-fs/openafs/ChangeLog
+++ b/net-fs/openafs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-fs/openafs
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/ChangeLog,v 1.8 2002/09/16 05:03:31 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/openafs/ChangeLog,v 1.9 2002/10/02 04:48:41 rphillips Exp $
+
+*openafs-1.2.6-r1 (1 Oct 2002)
+
+ 1 Oct 2002; Ryan Phillips <rphillips@gentoo.org> openafs-1.2.6-r1.ebuild:
+
+ Thanks to everyone involved, especially conteb @ alum.rpi.edu for submitting
+ the patch. Hopefully bug #7775 can be laid to rest.
*openafs-1.2.6 (03 Aug 2002)
diff --git a/net-fs/openafs/files/digest-openafs-1.2.6-r1 b/net-fs/openafs/files/digest-openafs-1.2.6-r1
new file mode 100644
index 000000000000..b00313ecd518
--- /dev/null
+++ b/net-fs/openafs/files/digest-openafs-1.2.6-r1
@@ -0,0 +1 @@
+MD5 c97e19c398d169538c4d852a6304722a openafs-1.2.6-src.tar.bz2 10229773
diff --git a/net-fs/openafs/files/openafs-1.2.6.patch b/net-fs/openafs/files/openafs-1.2.6.patch
new file mode 100644
index 000000000000..3af94908bd18
--- /dev/null
+++ b/net-fs/openafs/files/openafs-1.2.6.patch
@@ -0,0 +1,44 @@
+--- openafs-1.2.6/src/pinstall/install.c Fri Oct 12 23:21:46 2001
++++ src/pinstall/install.c Tue Oct 1 18:11:55 2002
+@@ -169,6 +169,10 @@
+ "cp", 0, 0, 0,
+ };
+
++ static char *empty[] = {
++ 0,
++ };
++
+ /*
+ * first, copy the `iname' to the `oname'
+ */
+@@ -180,7 +184,7 @@
+ case 0: /* child */
+ copy[1] = iname;
+ copy[2] = oname;
+- execve("/bin/cp", copy, (char **)0);
++ execve("/bin/cp", copy, empty);
+ perror("/bin/cp");
+ exit(1);
+
+@@ -277,7 +281,11 @@
+ static char *copy[] = {
+ "cp", 0, 0, 0,
+ };
+-
++
++static char *empty[] = {
++ 0,
++ };
++
+ /*
+ * first, copy the `iname' to the `oname'
+ */
+@@ -289,7 +297,7 @@
+ case 0: /* child */
+ copy[1] = iname;
+ copy[2] = oname;
+- execve("/bin/cp", copy, 0);
++ execve("/bin/cp", copy, empty);
+ perror("/bin/cp");
+ exit(1);
+
diff --git a/net-fs/openafs/openafs-1.2.6-r1.ebuild b/net-fs/openafs/openafs-1.2.6-r1.ebuild
new file mode 100644
index 000000000000..4d5b7599b27b
--- /dev/null
+++ b/net-fs/openafs/openafs-1.2.6-r1.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# /home/cvsroot/gentoo-x86/net-fs/openafs/openafs-1.2.5.ebuild,v 1.0 2002/07/10 09:52:39 pm Exp
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="The AFS 3 distributed file system targets the issues critical to
+distributed computing environments. AFS performs exceptionally well,
+both within small, local work groups of machines and across wide-area
+configurations in support of large, collaborative efforts. AFS provides
+an architecture geared towards system management, along with the tools
+to perform important management tasks. For a user, AFS is a familiar yet
+extensive UNIX environment for accessing files easily and quickly."
+
+SRC_URI="http://openafs.org/dl/openafs/${PV}/${P}-src.tar.bz2"
+HOMEPAGE="http://www.openafs.org/"
+
+SLOT="0"
+LICENSE="IPL-1"
+KEYWORDS="x86 -ppc -sparc -sparc64"
+SANDBOX_DISABLED="1"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ >=sys-libs/pam-0.75"
+
+ARCH=i386_linux24
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/src/config
+ cp Makefile.i386_linux24.in Makefile.i386_linux24.in.old
+ sed -e "s|/usr/lib/libncurses.so|-lncurses|g" \
+ Makefile.i386_linux24.in.old > Makefile.i386_linux24.in
+ rm Makefile.i386_linux24.in.old
+}
+
+src_compile() {
+ patch -p0 < ${FILESDIR}/openafs-1.2.6.patch
+
+ ./configure \
+ --with-afs-sysname=i386_linux24 \
+ --enable-transarc-paths || die
+ make || die
+ make dest || die
+}
+
+src_install () {
+
+
+ # Client
+
+ cd ${S}/${ARCH}/dest/root.client/usr/vice
+
+ insinto /etc/afs/modload
+ doins etc/modload/*
+ insinto /etc/afs/C
+ doins etc/C/*
+
+ insinto /etc/afs
+ doins ${FILESDIR}/{ThisCell,CellServDB}
+ doins etc/afs.conf
+
+ dodir /afs
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/afs.rc.rc6 afs
+
+ dosbin etc/afsd
+
+ # Client Bin
+ cd ${S}/${ARCH}/dest
+ exeinto /usr/afsws/bin
+ doexe bin/*
+
+ exeinto /etc/afs/afsws
+ doexe etc/*
+
+ cp -a include lib ${D}/usr/afsws
+ dosym /usr/afsws/lib/afs/libtermlib.a /usr/afsws/lib/afs/libnull.a
+
+ # Server
+ cd ${S}/${ARCH}/dest/root.server/usr/afs
+ exeinto /usr/afs/bin
+ doexe bin/*
+
+ dodir /usr/vice
+ dosym /etc/afs /usr/vice/etc
+ dosym /etc/afs/afsws /usr/afsws/etc
+
+ dodoc ${FILESDIR}/README
+
+ dodir /etc/env.d
+ echo 'CONFIG_PROTECT_MASK="/etc/afs"' >> ${D}/etc/env.d/01${PN}
+}
+
+pkg_postinst () {
+ echo ">>> UPDATE CellServDB and ThisCell to your needs !!"
+ echo ">>> FOLLOW THE INSTRUCTIONS IN AFS QUICK BEGINNINGS"
+ echo ">>> PAGE >45 TO DO INITIAL SERVER SETUP" fi
+}
diff --git a/net-fs/openafs/openafs-1.2.6.ebuild b/net-fs/openafs/openafs-1.2.6.ebuild
index 1938621cf701..377b560c8f03 100644
--- a/net-fs/openafs/openafs-1.2.6.ebuild
+++ b/net-fs/openafs/openafs-1.2.6.ebuild
@@ -36,6 +36,7 @@ src_unpack() {
}
src_compile() {
+ export HOSTNAME=""
./configure \
--with-afs-sysname=i386_linux24 \
--enable-transarc-paths || die