summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Phillips <rphillips@gentoo.org>2003-10-20 05:31:43 +0000
committerRyan Phillips <rphillips@gentoo.org>2003-10-20 05:31:43 +0000
commit08d508ec474347966cc9993facc67ba89a73ede2 (patch)
treef810f9a3504e8d4ffa4dcd9a8cebc48f0dbf48fe /net-fs/openafs
parentRemoved some files (diff)
downloadgentoo-2-08d508ec474347966cc9993facc67ba89a73ede2.tar.gz
gentoo-2-08d508ec474347966cc9993facc67ba89a73ede2.tar.bz2
gentoo-2-08d508ec474347966cc9993facc67ba89a73ede2.zip
removed some files
Diffstat (limited to 'net-fs/openafs')
-rw-r--r--net-fs/openafs/files/afs.rc220
-rw-r--r--net-fs/openafs/files/kaserver-patch.diff65
-rw-r--r--net-fs/openafs/files/openafs-1.2.5-sunrpc-overflow.patch54
-rw-r--r--net-fs/openafs/files/openafs-1.2.8.patch48
4 files changed, 0 insertions, 387 deletions
diff --git a/net-fs/openafs/files/afs.rc b/net-fs/openafs/files/afs.rc
deleted file mode 100644
index 55585cc66af5..000000000000
--- a/net-fs/openafs/files/afs.rc
+++ /dev/null
@@ -1,220 +0,0 @@
-#! /bin/sh
-#RCUPDATE:3 4:77:This line is required for script management
-
-# Copyright 2000, International Business Machines Corporation and others.
-# All Rights Reserved.
-#
-# This software has been released under the terms of the IBM Public
-# License. For details, see the LICENSE file in the top-level source
-# directory or online at http://www.openafs.org/dl/license10.html
-
-# AFS Start and stop AFS components
-#
-#
-# chkconfig: 345 60 20
-# description: AFS is a distributed file system which provides location
-# transparency, caching and secure authentication.
-# Additional configuration can be done in the /etc/sysconfig/afs
-# file. Read the documentation in that file for more information.
-#
-# Note that AFS does not use a pid file in /var/run. It is turned off by
-# unmounting /afs.
-#
-# Modified by Holger Brueckner <darks@fet.org> for gentoo-linux
-
-# Gather up options and post startup script name, if present
-if [ -f /etc/afs/afs.conf ]; then
- . /etc/afs/afs.conf
-fi
-
-
-# include gentoo functions
-. /etc/rc.d/config/functions
-opts="start stop"
-
-# check for ext2 partition
-
-check_ext2() {
- PART=`cat /proc/mounts | grep vice | grep ext2 | awk '{print $1}'`
- if [ -z $PART ]
- then
- echo ">>> PLEASE CREATE A EXT2 (no reiserfs) PARTITION (of aprox. 200M)"
- echo ">>> AND MOUNT IT TO /USR/VICE/CACHE !!!"
- exit 1
- fi
-}
-
-# check if cacheinfo exist, otherwise create it !!
-
-check_cacheinfo(){
- [ ! -f /usr/vice/etc/cacheinfo ] && {
- PART=`cat /proc/mounts | grep vice | grep ext2 | awk '{print $1}'`
- CACHESIZE=`df $PART | grep ^/ | awk '{print $4}'`
- CACHESIZE=`expr $CACHESIZE \* 9`
- CACHESIZE=`expr $CACHESIZE / 10`
- echo "/afs:/usr/vice/cache:$CACHESIZE" > /usr/vice/etc/cacheinfo
- }
-}
-
-# is_on returns 1 if value of arg is "on"
-is_on() {
- if test "$1" = "on" ; then return 0
- else return 1
- fi
-}
-
-# If choose_client can't correctly determine which client to use, set
-# LIBAFS manually.
-choose_client() {
-
- # Use the second field of the uname -v output instead of just
- # doing a match on the whole thing to protect against matching
- # a timezone named SMP -- I don't know of one, but let's be
- # paranoid.
-
- set X `uname -v`; shift
- case $2 in
- SMP) MP=.mp ;; # MP system
- *) MP= ;; # SP system
- esac
-
- # For now, just use uname -r to get the module version.
- VERSION=`uname -r`
-
- LIBAFS=libafs-$VERSION$MP.o
-}
-
-#
-# Find prefix symbol to use with insmod. We find the unregister_filesystem
-# string from /proc/ksyms since we know it's there. If /proc/ksyms does not
-# exist, we print that info to the console and use the uname -v output to
-# decide on a prefix.
-# unregister_filesystem_Rsmp_b240cad8 is a typcial SMP version string from
-# a kernel built from ftp.kernel.org
-#
-
-KSYMS_FILE=/proc/ksyms
-SEARCH_STR="unregister_filesystem"
-DEFAULT_SMP_PREFIX="smp_" # Redhat kernels need "smp" instead
-PREFIX="" # none needed for UP with <= 1Gig memory
-
-set_prefix()
-{
- h='[0-9a-fA-F]'
- h8="$h$h$h$h$h$h$h$h"
- prefix_set=0
-
- set X `fgrep $SEARCH_STR $KSYMS_FILE 2> /dev/null`; shift
- str=$2
- case $str in
- ${SEARCH_STR}_R$h8)
- # No prefix required
- ;;
- $SEARCH_STR)
- # No versioning in kernel symbols
- ;;
- ${SEARCH_STR}_R*$h8)
- suffix=${str#${SEARCH_STR}_R}
- PREFIX=${suffix%$h8}
- ;;
- *)
- case $str in
- '')
- echo afsd: Cannot find \"$SEARCH_STR\" in file $KSYMS_FILE
- ;;
- *)
- echo afsd: Malformed kernel version symbol \"$str\"
- ;;
- esac
-
- echo Guessing prefix from output of uname -v
- set X `uname -v`; shift
- case $2 in
- SMP)
- PREFIX=$DEFAULT_SMP_PREFIX
- ;;
- esac
- ;;
- esac
-}
-
-
-MODLOADDIR=/usr/vice/etc/modload
-# load_client loads the AFS client module if it's not already loaded.
-load_client() {
- # If LIBAFS is set, use it.
- if [ -z "$LIBAFS" ] ; then
- # Try to determine the right client.
- choose_client
- fi
-
- if [ ! -f $MODLOADDIR/$LIBAFS ] ; then
- echo AFS module $MODLOADDIR/$LIBAFS does not exist. Not starting AFS.
- exit 1
- fi
-
- # use the prefix command if required
- set_prefix
- /sbin/insmod ${PREFIX:+-P $PREFIX} -f -m $MODLOADDIR/$LIBAFS > $MODLOADDIR/libafs.map 2>&1
-}
-
-start(){
- # Load kernel extensions
-
- check_ext2
- check_cacheinfo
-
- ebegin "Starting AFS services"
-
- if load_client ; then :
- else
- echo Failed to load AFS client, not starting AFS services.
- eend 1 "Error Starting AFS client"
- fi
-
- # Start bosserver, it if exists
- if is_on $AFS_SERVER && test -x /usr/afs/bin/bosserver ; then
- /usr/afs/bin/bosserver
- fi
-
- # Start AFS client
- if is_on $AFS_CLIENT && test -x /usr/sbin/afsd ; then
- /usr/sbin/afsd ${OPTIONS} 1>&2
- STATUS=$?
- # Start AFS version of inetd.conf if present.
- if test -f /usr/afsws/etc/inetd.conf -a -x /usr/afsws/etc/inetd.afs ; then
- /usr/afsws/etc/inetd.afs /usr/afsws/etc/inetd.conf
- fi
- $AFS_POST_INIT
- fi
- eend $STATUS "Error starting AFS"
-
-}
-
-stop() {
- # Stop AFS
- ebegin "Stopping AFS services"
-
- if is_on $AFS_CLIENT ; then
-# killall inetd.afs
- umount /afs
- STATUS=$?
- fi
-
- if is_on $AFS_SERVER && test -x /usr/afs/bin/bos ; then
- echo "Stopping AFS bosserver"
- /usr/afs/bin/bos shutdown localhost -localauth -wait
- killall -HUP bosserver
- fi
-
- LIBAFS=`/sbin/lsmod | fgrep libafs`
- if [ -n "$LIBAFS" ] ; then
- LIBAFS=`echo $LIBAFS | awk 'BEGIN { FS = " " } { print $1 }'`
- /sbin/rmmod $LIBAFS
- STATUS=$?
- fi
- eend $STATUS "Error starting AFS"
-
-}
-
-doservice ${@}
diff --git a/net-fs/openafs/files/kaserver-patch.diff b/net-fs/openafs/files/kaserver-patch.diff
deleted file mode 100644
index 8ea1458580de..000000000000
--- a/net-fs/openafs/files/kaserver-patch.diff
+++ /dev/null
@@ -1,65 +0,0 @@
---- openafs/src/kauth/kaprocs.c 6 Sep 2002 02:44:03 -0000 1.12
-+++ openafs/src/kauth/kaprocs.c 18 Mar 2003 03:56:18 -0000 1.13
-@@ -1706,6 +1706,11 @@
- celllen = strlen (cell);
- if (import && (celllen == 0)) {code = KABADTICKET; goto abort;}
- if (export && (celllen == 0)) strcpy (cell, lrealm);
-+
-+ if (!krb4_cross && celllen && strcmp(lrealm, cell) != 0) {
-+ code = KABADUSER;
-+ goto abort;
-+ }
-
- des_ecb_encrypt (atimes->SeqBody, &times, schedule, DECRYPT);
- times.start = ntohl(times.start);
---- openafs/src/kauth/kaserver.c 21 Aug 2002 18:13:22 -0000 1.13
-+++ openafs/src/kauth/kaserver.c 18 Mar 2003 03:56:18 -0000 1.14
-@@ -56,6 +56,8 @@
- struct ubik_dbase *KA_dbase;
- afs_int32 myHost = 0;
- afs_int32 verbose_track = 1;
-+afs_int32 krb4_cross = 0;
-+
- struct afsconf_dir *KA_conf; /* for getting cell info */
-
- extern afs_int32 ubik_lastYesTime;
-@@ -193,6 +195,7 @@
- usage:
- printf("Usage: kaserver [-noAuth] [-fastKeys] [-database <dbpath>] "
- "[-localfiles <lclpath>] [-minhours <n>] [-servers <serverlist>] "
-+ "[-crossrealm]"
- /*" [-enable_peer_stats] [-enable_process_stats] " */
- "[-help]\n");
- exit(1);
-@@ -250,6 +253,7 @@
- else if (IsArg("-clear")) level = rxkad_clear;
- else if (IsArg("-sorry")) level = rxkad_clear;
- else if (IsArg("-debug")) verbose_track = 0;
-+ else if (IsArg("-crossrealm")) krb4_cross = 1;
- else if (IsArg("-minhours")) {
- MinHours = atoi(argv[++a]);
- }
---- openafs/src/kauth/kaserver.h 4 Nov 2000 10:04:39 -0000 1.2
-+++ openafs/src/kauth/kaserver.h 18 Mar 2003 23:47:51 -0000 1.4
-@@ -179,6 +179,7 @@
- u_int locktime
- );
-
-+extern afs_int32 krb4_cross;
-
- #define LOCKPW
-
---- openafs/src/kauth/krb_udp.c 22 Aug 2002 18:45:16 -0000 1.20
-+++ openafs/src/kauth/krb_udp.c 18 Mar 2003 03:56:18 -0000 1.21
-@@ -461,6 +461,11 @@
- strncpy (cell, lrealm, MAXKTCREALMLEN-1);
- cell[MAXKTCREALMLEN-1] = 0;
- };
-+
-+ if (!krb4_cross && strcmp(lrealm, cell) != 0) {
-+ code = KERB_ERR_PRINCIPAL_UNKNOWN;
-+ goto abort;
-+ }
-
- if (krb_udp_debug) {
- printf ("UGetTicket: got ticket from '%s'.'%s'@'%s'\n",
diff --git a/net-fs/openafs/files/openafs-1.2.5-sunrpc-overflow.patch b/net-fs/openafs/files/openafs-1.2.5-sunrpc-overflow.patch
deleted file mode 100644
index 554c61e097c8..000000000000
--- a/net-fs/openafs/files/openafs-1.2.5-sunrpc-overflow.patch
+++ /dev/null
@@ -1,54 +0,0 @@
---- openafs/src/rx/xdr_array.c 2001/08/08 00:03:57 1.4
-+++ openafs/src/rx/xdr_array.c 2002/07/31 23:13:49 1.4.2.1
-@@ -84,7 +84,10 @@
- register caddr_t target = *addrp;
- register u_int c; /* the actual element count */
- register bool_t stat = TRUE;
-- register int nodesize;
-+ register u_int nodesize;
-+
-+ i = ((~0) >> 1) / elsize;
-+ if (maxsize > i) maxsize = i;
-
- /* like strings, arrays are really counted arrays */
- if (! xdr_u_int(xdrs, sizep)) {
-
---- openafs/src/rx/Makefile.in 2002/01/20 08:38:38 1.4.2.1
-+++ openafs/src/rx/Makefile.in 2002/08/02 02:45:14 1.4.2.2
-@@ -38,7 +38,7 @@
- # Generic xdr objects (or, at least, xdr stuff that's not newly defined for rx).
- # Really the xdr stuff should be in its own directory.
- #
--XDROBJS = xdr_arrayn.o xdr_rx.o xdr_afsuuid.o
-+XDROBJS = xdr.o xdr_array.o xdr_arrayn.o xdr_rx.o xdr_afsuuid.o
-
- RXOBJS = rx_clock.o rx_event.o rx_user.o rx_lwp.o rx.o rx_null.o rx_globals.o \
- rx_getaddr.o rx_misc.o rx_packet.o rx_rdwr.o rx_trace.o rx_conncache.o \
-
---- openafs/src/rx/xdr.c 2002/06/08 04:47:43 1.3.4.1
-+++ openafs/src/rx/xdr.c 2002/07/31 23:13:49 1.3.4.2
-@@ -557,6 +557,8 @@
- register char *sp = *cpp; /* sp is the actual string pointer */
- u_int size;
- u_int nodesize;
-+
-+ if (maxsize > ((~0) >> 1) - 1) maxsize = ((~0) >> 1) - 1;
-
- /*
- * first deal with the length since xdr strings are counted-strings
-
---- openafs/src/rx/xdr_arrayn.c 2001/08/08 00:03:57 1.4
-+++ openafs/src/rx/xdr_arrayn.c 2002/07/31 23:13:49 1.4.2.1
-@@ -89,7 +89,10 @@
- register caddr_t target = *addrp;
- register u_int c; /* the actual element count */
- register bool_t stat = TRUE;
-- register int nodesize;
-+ register u_int nodesize;
-+
-+ i = ((~0) >> 1) / elsize;
-+ if (maxsize > i) maxsize = i;
-
- /* like strings, arrays are really counted arrays */
- if (! xdr_u_int(xdrs, sizep)) {
-
diff --git a/net-fs/openafs/files/openafs-1.2.8.patch b/net-fs/openafs/files/openafs-1.2.8.patch
deleted file mode 100644
index b90696cabcaa..000000000000
--- a/net-fs/openafs/files/openafs-1.2.8.patch
+++ /dev/null
@@ -1,48 +0,0 @@
-diff -urN openafs-1.2.8/src/pam/Makefile.in openafs-1.2.8-patched/src/pam/Makefile.in
---- openafs-1.2.8/src/pam/Makefile.in 2002-09-10 01:03:42.000000000 -0400
-+++ openafs-1.2.8-patched/src/pam/Makefile.in 2003-07-30 11:57:49.000000000 -0400
-@@ -44,7 +44,7 @@
- afs_pam_msg.o afs_message.o AFS_component_version_number.o
- OBJS = $(SHOBJS) test_pam.o
- INCLUDES=-I${TOP_SRCDIR}/config -I${TOP_INCDIR} \
-- -I/usr/include -I/usr/include/sys
-+ -I/usr/include
- CFLAGS = ${DEBUG} ${INCLUDES} ${PAM_CFLAGS}
-
- all: test_pam ${TOP_LIBDIR}/pam_afs.so.1 ${TOP_LIBDIR}/pam_afs.krb.so.1
-diff -urN openafs-1.2.8/src/ptserver/ptserver.h openafs-1.2.8-patched/src/ptserver/ptserver.h
---- openafs-1.2.8/src/ptserver/ptserver.h 2001-03-27 03:49:41.000000000 -0500
-+++ openafs-1.2.8-patched/src/ptserver/ptserver.h 2003-07-30 11:57:20.000000000 -0400
-@@ -28,7 +28,7 @@
- #define ANONYMOUSID 32766
-
- #define PRDBVERSION 0
--
-+#include <errno.h>
- struct prheader {
- afs_int32 version; /* database version number */
- afs_int32 headerSize; /* bytes in header (almost version#) */
-diff -urN openafs-1.2.8/src/sys/rmtsysd.c openafs-1.2.8-patched/src/sys/rmtsysd.c
---- openafs-1.2.8/src/sys/rmtsysd.c 2001-07-12 15:59:17.000000000 -0400
-+++ openafs-1.2.8-patched/src/sys/rmtsysd.c 2003-07-30 11:56:32.000000000 -0400
-@@ -31,7 +31,7 @@
- #include <stdio.h>
- #include <rx/xdr.h>
- #include "rmtsys.h"
--
-+#include <errno.h>
- extern int errno; /* We ship this over the net if needed */
- extern RMTSYS_ExecuteRequest();
-
-diff -urN openafs-1.2.8/src/sys/rmtsyss.c openafs-1.2.8-patched/src/sys/rmtsyss.c
---- openafs-1.2.8/src/sys/rmtsyss.c 2001-08-07 20:04:10.000000000 -0400
-+++ openafs-1.2.8-patched/src/sys/rmtsyss.c 2003-07-30 11:56:50.000000000 -0400
-@@ -32,7 +32,7 @@
- #endif
- /*#include <afs/cellconfig.h>*/
- #include "rmtsys.h"
--
-+#include <errno.h>
- extern int errno; /* We ship this over the net if needed */
- extern RMTSYS_ExecuteRequest();
-