summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2002-12-30 17:05:01 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2002-12-30 17:05:01 +0000
commite7ce83686f3065bff406e78f286b93a9bfa2a5d5 (patch)
tree646c3dc615e758a4169d6ba821b45a22f1f4e707 /net-fs/intersync
parentsmall patch (diff)
downloadgentoo-2-e7ce83686f3065bff406e78f286b93a9bfa2a5d5.tar.gz
gentoo-2-e7ce83686f3065bff406e78f286b93a9bfa2a5d5.tar.bz2
gentoo-2-e7ce83686f3065bff406e78f286b93a9bfa2a5d5.zip
added rc script and config file
Diffstat (limited to 'net-fs/intersync')
-rw-r--r--net-fs/intersync/ChangeLog7
-rw-r--r--net-fs/intersync/files/intersync.conf36
-rw-r--r--net-fs/intersync/files/intersync.rc29
-rw-r--r--net-fs/intersync/intersync-0.9.5.ebuild3
4 files changed, 73 insertions, 2 deletions
diff --git a/net-fs/intersync/ChangeLog b/net-fs/intersync/ChangeLog
index da334cb7cb6c..8fcbc903610d 100644
--- a/net-fs/intersync/ChangeLog
+++ b/net-fs/intersync/ChangeLog
@@ -1,11 +1,14 @@
# ChangeLog for net-fs/intersync
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-fs/intersync/ChangeLog,v 1.1 2002/12/17 17:46:53 bcowan Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/intersync/ChangeLog,v 1.2 2002/12/30 17:05:01 bcowan Exp $
*intersync-0.9.5 (17 Dec 2002)
+ 30 Dec 2002; Brad Cowan <bcowan@gentoo.org> intersync-0.9.5.ebuild,
+ files/intersync.conf, files/intersync.rc:
+ Added rc scripts and config file.
+
17 Dec 2002; Brad Cowan <bcowan@gentoo.org> intersync-0.9.5.ebuild,
ChangeLog, files/digest-intersync-0.9.5:
-
Initial import, closes bug #12259.
diff --git a/net-fs/intersync/files/intersync.conf b/net-fs/intersync/files/intersync.conf
new file mode 100644
index 000000000000..80a677f287f8
--- /dev/null
+++ b/net-fs/intersync/files/intersync.conf
@@ -0,0 +1,36 @@
+# Config file for /etc/init.d/intersync
+
+# options for the intersync client. for a list of options, run
+# "intersync" without args.
+
+# options as of 0.9.5, --version also exists, but we don't want that here.
+# -d, --docroot=DIRECTORY Set the docroot that contains the cache
+# -i, --local-ip=IP Local listen ip for http (default *)
+# -p, --local-port=PORT Local listen port (default 370 or 2432 for clients)
+# --server=HOSTNAME The server to contact for the initial profile
+# --server-port=PORT Server connect port (default 370)
+# --clientid=CLIENTID Configure system using CLIENTID
+# --fset=FSETNAME Use fsetname, can include branch
+# --help display this help and exit
+# --debug=FLAGS print debug information
+# --hoard=FILE hoard the files listed in FILE
+# --reint quit after reintegration and hoard is done
+# --daemon run intersync as daemon process
+
+CLIENT_OPTS="--daemon"
+# to connect to almach.forsaken.lands, use this:
+# CLIENT_OPTS="--server=almach.forsaken.lands --daemon"
+
+# you _need_ to set this.
+CACHE=
+# CACHE="/imports/home"
+
+
+
+
+
+
+
+
+
+
diff --git a/net-fs/intersync/files/intersync.rc b/net-fs/intersync/files/intersync.rc
new file mode 100644
index 000000000000..7fac76c7d84f
--- /dev/null
+++ b/net-fs/intersync/files/intersync.rc
@@ -0,0 +1,29 @@
+#!/sbin/runscript
+
+depend() {
+ need net logger
+}
+
+checkconfig() {
+ if [ "x$CACHE" == "x" ]; then
+ eerror "Please set CACHE in /etc/conf.d/intersync"
+ return 1
+ fi
+ return 0
+}
+
+start() {
+ checkconfig || return $?
+ ebegin "Starting intersync"
+ start-stop-daemon --start --pidfile /var/run/intersync.pid \
+ --startas /usr/bin/intersync -- $CLIENT_OPTS $CACHE
+ eend $? "Failed to start intersync"
+}
+
+stop() {
+ ebegin "Stopping intersync"
+ start-stop-daemon --stop --quiet --pidfile /var/run/intersync.pid
+ eend $? "Failed to stop intersync"
+}
+
+ \ No newline at end of file
diff --git a/net-fs/intersync/intersync-0.9.5.ebuild b/net-fs/intersync/intersync-0.9.5.ebuild
index 698f201144ee..5b18ad83d653 100644
--- a/net-fs/intersync/intersync-0.9.5.ebuild
+++ b/net-fs/intersync/intersync-0.9.5.ebuild
@@ -33,4 +33,7 @@ src_compile () {
src_install () {
make DESTDIR=${D} install
+
+ exeinto /etc/init.d ; newexe ${FILESDIR}/intersync.rc intersync
+ insinto /etc/conf.d ; newins ${FILESDIR}/intersync.conf intersync
}