summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-08-17 19:20:50 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-08-17 19:20:50 +0000
commit060edd8429430ba8000abf065f63af2f92f2a470 (patch)
tree8dc2ca8ceb466d0c3c3e9e75b426b9fa3b68bf78 /net-fs/davfs2
parentInclude <cstdio> also for RtAudio.cpp wrt #332873 by Jouni Rinne. (diff)
downloadgentoo-2-060edd8429430ba8000abf065f63af2f92f2a470.tar.gz
gentoo-2-060edd8429430ba8000abf065f63af2f92f2a470.tar.bz2
gentoo-2-060edd8429430ba8000abf065f63af2f92f2a470.zip
Fix building (and implicits of fstat, mknod and chmod) with recent glibc wrt #332865 by Michael Schachtebeck.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-fs/davfs2')
-rw-r--r--net-fs/davfs2/ChangeLog7
-rw-r--r--net-fs/davfs2/davfs2-1.4.5.ebuild5
-rw-r--r--net-fs/davfs2/files/davfs2-1.4.5-glibc212.patch59
3 files changed, 68 insertions, 3 deletions
diff --git a/net-fs/davfs2/ChangeLog b/net-fs/davfs2/ChangeLog
index 085081892cc5..8777d360bd7c 100644
--- a/net-fs/davfs2/ChangeLog
+++ b/net-fs/davfs2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-fs/davfs2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/davfs2/ChangeLog,v 1.50 2010/06/22 20:05:45 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/davfs2/ChangeLog,v 1.51 2010/08/17 19:20:50 ssuominen Exp $
+
+ 17 Aug 2010; Samuli Suominen <ssuominen@gentoo.org> davfs2-1.4.5.ebuild,
+ +files/davfs2-1.4.5-glibc212.patch:
+ Fix building (and implicits of fstat, mknod and chmod) with recent glibc
+ wrt #332865 by Michael Schachtebeck.
22 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
davfs2-1.3.3.ebuild, davfs2-1.4.1.ebuild, davfs2-1.4.5.ebuild:
diff --git a/net-fs/davfs2/davfs2-1.4.5.ebuild b/net-fs/davfs2/davfs2-1.4.5.ebuild
index 89aa75e85712..cdcd9d4c61b1 100644
--- a/net-fs/davfs2/davfs2-1.4.5.ebuild
+++ b/net-fs/davfs2/davfs2-1.4.5.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-fs/davfs2/davfs2-1.4.5.ebuild,v 1.2 2010/06/22 20:05:45 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-fs/davfs2/davfs2-1.4.5.ebuild,v 1.3 2010/08/17 19:20:50 ssuominen Exp $
EAPI="2"
-inherit autotools linux-mod
+inherit autotools eutils linux-mod
DESCRIPTION="a Linux file system driver that allows you to mount a WebDAV server as a local disk drive. Davfs2 uses fuse (or coda) for kernel driver and neon for WebDAV interface"
HOMEPAGE="http://savannah.nongnu.org/projects/davfs2"
@@ -22,6 +22,7 @@ DEPEND="dev-libs/libxml2
RDEPEND="${DEPEND}"
src_prepare() {
+ epatch "${FILESDIR}"/${P}-glibc212.patch
sed -e "s/^NE_REQUIRE_VERSIONS.*29/& 30/" -i configure.ac
eautoreconf
}
diff --git a/net-fs/davfs2/files/davfs2-1.4.5-glibc212.patch b/net-fs/davfs2/files/davfs2-1.4.5-glibc212.patch
new file mode 100644
index 000000000000..18d65bb5bb78
--- /dev/null
+++ b/net-fs/davfs2/files/davfs2-1.4.5-glibc212.patch
@@ -0,0 +1,59 @@
+http://bugs.gentoo.org/332865
+
+--- src/dav_coda.c
++++ src/dav_coda.c
+@@ -52,6 +52,9 @@
+ #ifdef HAVE_SYS_TYPES_H
+ #include <sys/types.h>
+ #endif
++#ifdef HAVE_SYS_STAT_H
++#include <sys/stat.h>
++#endif
+
+ #include "defaults.h"
+ #include "mount_davfs.h"
+--- src/dav_fuse.c
++++ src/dav_fuse.c
+@@ -41,6 +41,12 @@
+ #ifdef HAVE_UNISTD_H
+ #include <unistd.h>
+ #endif
++#ifdef HAVE_SYS_TYPES_H
++#include <sys/types.h>
++#endif
++#ifdef HAVE_SYS_STAT_H
++#include <sys/stat.h>
++#endif
+
+ #include "defaults.h"
+ #include "mount_davfs.h"
+--- src/kernel_interface.c
++++ src/kernel_interface.c
+@@ -44,6 +44,12 @@
+ #ifdef HAVE_UNISTD_H
+ #include <unistd.h>
+ #endif
++#ifdef HAVE_SYS_TYPES_H
++#include <sys/types.h>
++#endif
++#ifdef HAVE_SYS_STAT_H
++#include <sys/stat.h>
++#endif
+
+ #ifdef HAVE_SYS_MOUNT_H
+ #include <sys/mount.h>
+--- src/webdav.c
++++ src/webdav.c
+@@ -47,6 +47,12 @@
+ #ifdef HAVE_UNISTD_H
+ #include <unistd.h>
+ #endif
++#ifdef HAVE_SYS_TYPES_H
++#include <sys/types.h>
++#endif
++#ifdef HAVE_SYS_STAT_H
++#include <sys/stat.h>
++#endif
+
+ #include <ne_alloc.h>
+ #include <ne_auth.h>