summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2009-04-25 11:09:43 +0000
committerAlin Năstac <mrness@gentoo.org>2009-04-25 11:09:43 +0000
commit64a7c68f0b454a0b0704fa4e6fec89940135f38a (patch)
treed5b16926194978d693de8b574f5aee96054d2f0e /net-firewall
parentAdding ~amd64 keyword. Fixes #267403 (diff)
downloadgentoo-2-64a7c68f0b454a0b0704fa4e6fec89940135f38a.tar.gz
gentoo-2-64a7c68f0b454a0b0704fa4e6fec89940135f38a.tar.bz2
gentoo-2-64a7c68f0b454a0b0704fa4e6fec89940135f38a.zip
Improve iptables-1.4.3 patch (#265460).
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/ipp2p/ChangeLog6
-rw-r--r--net-firewall/ipp2p/files/ipp2p-0.8.2-iptables-1.4.3.patch26
2 files changed, 23 insertions, 9 deletions
diff --git a/net-firewall/ipp2p/ChangeLog b/net-firewall/ipp2p/ChangeLog
index 9f5e9a8d3b12..d822b765810c 100644
--- a/net-firewall/ipp2p/ChangeLog
+++ b/net-firewall/ipp2p/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-firewall/ipp2p
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipp2p/ChangeLog,v 1.40 2009/04/10 22:25:36 mrness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipp2p/ChangeLog,v 1.41 2009/04/25 11:09:42 mrness Exp $
+
+ 25 Apr 2009; Alin Năstac <mrness@gentoo.org>
+ files/ipp2p-0.8.2-iptables-1.4.3.patch:
+ Improve iptables-1.4.3 patch (#265460).
10 Apr 2009; Alin Năstac <mrness@gentoo.org>
+files/ipp2p-0.8.2-iptables-1.4.3.patch, ipp2p-0.8.2-r4.ebuild:
diff --git a/net-firewall/ipp2p/files/ipp2p-0.8.2-iptables-1.4.3.patch b/net-firewall/ipp2p/files/ipp2p-0.8.2-iptables-1.4.3.patch
index dd704127cc1b..fbead164ded0 100644
--- a/net-firewall/ipp2p/files/ipp2p-0.8.2-iptables-1.4.3.patch
+++ b/net-firewall/ipp2p/files/ipp2p-0.8.2-iptables-1.4.3.patch
@@ -1,6 +1,7 @@
---- libipt_ipp2p.c.old 2009-04-08 18:03:26.574089860 +0200
-+++ libipt_ipp2p.c 2009-04-08 18:03:42.871884390 +0200
-@@ -88,39 +88,39 @@
+diff -Nru ipp2p-0.8.2.orig/libipt_ipp2p.c ipp2p-0.8.2/libipt_ipp2p.c
+--- ipp2p-0.8.2.orig/libipt_ipp2p.c 2009-04-25 11:05:43.000000000 +0000
++++ ipp2p-0.8.2/libipt_ipp2p.c 2009-04-25 11:06:54.000000000 +0000
+@@ -85,39 +85,39 @@
switch (c) {
case '1': /*cmd: ipp2p*/
if ((*flags & SHORT_HAND_IPP2P) == SHORT_HAND_IPP2P)
@@ -49,7 +50,7 @@
*flags += IPP2P_EDK;
info->cmd = *flags;
break;
-@@ -128,21 +128,21 @@
+@@ -125,21 +125,21 @@
case '7': /*cmd: dc*/
if ((*flags & IPP2P_DC) == IPP2P_DC)
@@ -76,7 +77,7 @@
*flags += IPP2P_DC;
info->cmd = *flags;
break;
-@@ -150,70 +150,70 @@
+@@ -147,70 +147,70 @@
case '9': /*cmd: gnu*/
if ((*flags & IPP2P_GNU) == IPP2P_GNU)
@@ -163,7 +164,7 @@
*flags += IPP2P_APPLE;
info->cmd = *flags;
break;
-@@ -221,14 +221,14 @@
+@@ -218,14 +218,14 @@
case 'd': /*cmd: soul*/
if ((*flags & IPP2P_SOUL) == IPP2P_SOUL)
@@ -181,7 +182,7 @@
*flags += IPP2P_SOUL;
info->cmd = *flags;
break;
-@@ -236,67 +236,67 @@
+@@ -233,67 +233,67 @@
case 'e': /*cmd: winmx*/
if ((*flags & IPP2P_WINMX) == IPP2P_WINMX)
@@ -263,7 +264,7 @@
// "\nipp2p-parameter problem: for ipp2p usage type: iptables -m ipp2p --help\n");
return 0;
}
-@@ -308,7 +308,7 @@
+@@ -305,7 +305,7 @@
final_check(unsigned int flags)
{
if (!flags)
@@ -272,3 +273,12 @@
"\nipp2p-parameter problem: for ipp2p usage type: iptables -m ipp2p --help\n");
}
+@@ -378,7 +378,7 @@
+ .next = NULL,
+ .name = "ipp2p",
+ .family = PF_INET,
+- .version = IPTABLES_VERSION,
++ .version = XTABLES_VERSION,
+ .size = XT_ALIGN(sizeof(struct ipt_p2p_info)),
+ .userspacesize = XT_ALIGN(sizeof(struct ipt_p2p_info)),
+ .help = &help,