summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-06-24 13:49:43 +0000
committerAron Griffis <agriffis@gentoo.org>2004-06-24 13:49:43 +0000
commit4756fad6fe81d83a61e65aa00da9fe7ce462c3c4 (patch)
tree6192ff02b41c46d803015c6c6799c1398198e375 /net-firewall
parentQA - fix use invocation (Manifest recommit) (diff)
downloadgentoo-2-4756fad6fe81d83a61e65aa00da9fe7ce462c3c4.tar.gz
gentoo-2-4756fad6fe81d83a61e65aa00da9fe7ce462c3c4.tar.bz2
gentoo-2-4756fad6fe81d83a61e65aa00da9fe7ce462c3c4.zip
QA - fix use invocation
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/iptables/ChangeLog7
-rw-r--r--net-firewall/iptables/iptables-1.2.9-r2.ebuild8
2 files changed, 10 insertions, 5 deletions
diff --git a/net-firewall/iptables/ChangeLog b/net-firewall/iptables/ChangeLog
index 6ad481c00b82..4de82b85a909 100644
--- a/net-firewall/iptables/ChangeLog
+++ b/net-firewall/iptables/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/iptables
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.28 2004/06/09 21:52:35 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.29 2004/06/24 13:45:39 agriffis Exp $
+
+*iptables-1.2.9-r2 (24 Jun 2004)
+
+ 24 Jun 2004; Aron Griffis <agriffis@gentoo.org> iptables-1.2.9-r2.ebuild:
+ QA - fix use invocation
09 Jun 2004; Aron Griffis <agriffis@gentoo.org> iptables-1.2.7a-r3.ebuild,
iptables-1.2.9-r1.ebuild, iptables-1.2.9.ebuild:
diff --git a/net-firewall/iptables/iptables-1.2.9-r2.ebuild b/net-firewall/iptables/iptables-1.2.9-r2.ebuild
index cbcc4b98c96b..f5a8584b7b52 100644
--- a/net-firewall/iptables/iptables-1.2.9-r2.ebuild
+++ b/net-firewall/iptables/iptables-1.2.9-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.2.9-r2.ebuild,v 1.1 2004/06/23 18:43:16 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.2.9-r2.ebuild,v 1.2 2004/06/24 13:45:39 agriffis Exp $
inherit eutils flag-o-matic
@@ -18,7 +18,7 @@ IUSE="ipv6 static extensions"
DEPEND="virtual/linux-sources"
pkg_preinst() {
- if [ "`use extensions`" ]; then
+ if use extensions; then
einfo "WARNING: 3rd party extensions has been enabled."
einfo "This means that iptables will use your currently installed"
einfo "kernel in /usr/src/linux as headers for iptables."
@@ -39,7 +39,7 @@ src_unpack() {
unpack ${A} ; cd ${S}
- if [ "`use extensions`" ]; then
+ if use extensions; then
epatch ${FILESDIR}/extensions/${P}-grsecurity.patch.bz2
epatch ${FILESDIR}/extensions/${P}-imq.patch.bz2
epatch ${FILESDIR}/extensions/${P}-l7.patch.bz2
@@ -74,7 +74,7 @@ src_compile() {
use ipv6 || myconf="${myconf} DO_IPV6=0"
use static && myconf="${myconf} NO_SHARED_LIBS=0"
- if [ "`use extensions`" ]; then
+ if use extensions; then
make ${myconf} \
LIBDIR=/lib \
BINDIR=/sbin \