summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2009-03-03 13:15:52 +0000
committerPeter Volkov <pva@gentoo.org>2009-03-03 13:15:52 +0000
commit238f88655ea74993a0fa9e41854785349f172b5e (patch)
tree3592f13939535cc69b4522addd6153e01508b4ff /net-firewall/ipset
parentversion bump, removed old versions (diff)
downloadgentoo-2-238f88655ea74993a0fa9e41854785349f172b5e.tar.gz
gentoo-2-238f88655ea74993a0fa9e41854785349f172b5e.tar.bz2
gentoo-2-238f88655ea74993a0fa9e41854785349f172b5e.zip
Fixed gethostbyname alignment issue on hppa, bug #260481, thank Antixrict for report and work with upstream. Removed old.
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'net-firewall/ipset')
-rw-r--r--net-firewall/ipset/ChangeLog12
-rw-r--r--net-firewall/ipset/files/ipset-2.4.9-gethostbyname-align.patch14
-rw-r--r--net-firewall/ipset/ipset-2.3.0.20070828-r2.ebuild68
-rw-r--r--net-firewall/ipset/ipset-2.3.1.20080612.ebuild68
-rw-r--r--net-firewall/ipset/ipset-2.3.3a.ebuild92
-rw-r--r--net-firewall/ipset/ipset-2.4.2.ebuild94
-rw-r--r--net-firewall/ipset/ipset-2.4.9-r1.ebuild (renamed from net-firewall/ipset/ipset-2.4.9.ebuild)3
7 files changed, 27 insertions, 324 deletions
diff --git a/net-firewall/ipset/ChangeLog b/net-firewall/ipset/ChangeLog
index af69666860d8..74cf4bb81a7d 100644
--- a/net-firewall/ipset/ChangeLog
+++ b/net-firewall/ipset/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for net-firewall/ipset
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ChangeLog,v 1.23 2009/02/28 14:07:44 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ChangeLog,v 1.24 2009/03/03 13:15:52 pva Exp $
+
+*ipset-2.4.9-r1 (03 Mar 2009)
+
+ 03 Mar 2009; Peter Volkov <pva@gentoo.org>
+ +files/ipset-2.4.9-gethostbyname-align.patch,
+ -ipset-2.3.0.20070828-r2.ebuild, -ipset-2.3.1.20080612.ebuild,
+ -ipset-2.3.3a.ebuild, -ipset-2.4.2.ebuild, -ipset-2.4.9.ebuild,
+ +ipset-2.4.9-r1.ebuild:
+ Fixed gethostbyname alignment issue on hppa, bug #260481, thank Antixrict
+ for report and work with upstream. Removed old.
*ipset-2.4.9 (28 Feb 2009)
diff --git a/net-firewall/ipset/files/ipset-2.4.9-gethostbyname-align.patch b/net-firewall/ipset/files/ipset-2.4.9-gethostbyname-align.patch
new file mode 100644
index 000000000000..cbc2c39f7750
--- /dev/null
+++ b/net-firewall/ipset/files/ipset-2.4.9-gethostbyname-align.patch
@@ -0,0 +1,14 @@
+diff --git a/ipset.c b/ipset.c
+index ba007e5..de6a4ec 100644
+--- a/ipset.c
++++ b/ipset.c
+@@ -626,7 +626,8 @@ void parse_ip(const char *str, ip_set_ip_t * ip)
+ "host/network `%s' resolves to serveral ip-addresses. "
+ "Please specify one.", str);
+
+- *ip = ntohl(((struct in_addr *) host->h_addr_list[0])->s_addr);
++ memcpy(&addr, host->h_addr_list[0], sizeof(struct in_addr));
++ *ip = ntohl(addr.s_addr);
+ return;
+ }
+
diff --git a/net-firewall/ipset/ipset-2.3.0.20070828-r2.ebuild b/net-firewall/ipset/ipset-2.3.0.20070828-r2.ebuild
deleted file mode 100644
index d3dc2181a3bb..000000000000
--- a/net-firewall/ipset/ipset-2.3.0.20070828-r2.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-2.3.0.20070828-r2.ebuild,v 1.1 2007/11/14 05:50:21 pva Exp $
-
-inherit eutils versionator toolchain-funcs
-
-POM_PV="20071021"
-
-MY_PV=$(replace_version_separator 3 -)
-DESCRIPTION="IPset userspace tool for iptables, successor to ippool."
-HOMEPAGE="http://ipset.netfilter.org/"
-SRC_URI="http://ipset.netfilter.org/${PN}-${MY_PV}.tar.bz2
- http://ipset.netfilter.org/patch-o-matic-ng-${POM_PV}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64 ~ppc"
-IUSE=""
-RDEPEND=">=net-firewall/iptables-1.3"
-DEPEND="${RDEPEND}"
-S=${WORKDIR}/ipset-${MY_PV%-*}
-
-pkg_setup() {
- myconf="${myconf} PREFIX="
- myconf="${myconf} LIBDIR=/$(get_libdir)"
- myconf="${myconf} BINDIR=/sbin"
- myconf="${myconf} MANDIR=/usr/share/man"
- myconf="${myconf} INCDIR=/usr/include"
- myconf="${myconf} KERNEL_DIR=${WORKDIR}/patch-o-matic-ng/patchlets/set/linux-2.6"
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" COPT_FLAGS="${CFLAGS}" ${myconf} || die "failed to build"
-}
-
-src_install() {
- emake DESTDIR="${D}" ${myconf} install || die "failed to package"
-}
-
-pkg_postinst() {
- elog "To use ${PN} you must have the ip_set kernel module compiled!"
- elog "To patch you kernel run:"
- elog
- elog " # emerge --config ipset"
- elog
- elog "And follow on-screen instructions"
-}
-
-pkg_config() {
- cd "${ROOT}${PORTAGE_TMPDIR}"
- [ -d patch-o-matic-ng ] && {
- einfo "${ROOT}${PORTAGE_TMPDIR}/patch-o-matic-ng directory exist. Cleaning it..." ;
- rm -rf patch-o-matic-ng;
- }
- mkdir patch-o-matic-ng && cd patch-o-matic-ng
-
- IPTVERINS=`echo $(best_version net-firewall/iptables) | \
- sed -n 's:^[^/]*/[[:alpha:]]*-\([0-9]\+\([.][0-9]\+\)*[a-z]\?\(_\(pre\|p\|beta\|alpha\|rc\)[0-9]*\)*\)\(-r[0-9]\+\)\?$:\1:p'`
-
- einfo "Unpacking patch-o-matic-ng-${POM_PV} and iptables-${IPTVERINS} sources"
- unpack {patch-o-matic-ng-${POM_PV},iptables-${IPTVERINS}}.tar.bz2
-
- einfo "I'm going to patch sources in ${ROOT}usr/src/linux"
- cd patch-o-matic-ng
- KERNEL_DIR="${ROOT}"usr/src/linux IPTABLES_DIR=../iptables-${IPTVERINS} ./runme set
-
- einfo "Cleaning ${ROOT}${PORTAGE_TMPDIR}/patch-o-matic-ng directory"
- rm -rf "${ROOT}${PORTAGE_TMPDIR}"/patch-o-matic-ng
-}
diff --git a/net-firewall/ipset/ipset-2.3.1.20080612.ebuild b/net-firewall/ipset/ipset-2.3.1.20080612.ebuild
deleted file mode 100644
index 84221d7f554d..000000000000
--- a/net-firewall/ipset/ipset-2.3.1.20080612.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-2.3.1.20080612.ebuild,v 1.1 2008/06/25 03:19:51 robbat2 Exp $
-
-inherit eutils versionator toolchain-funcs
-
-POM_PV="20080617"
-
-MY_PV="$(replace_version_separator 3 - "${PV/p/}")"
-DESCRIPTION="IPset userspace tool for iptables, successor to ippool."
-HOMEPAGE="http://ipset.netfilter.org/"
-SRC_URI="http://ipset.netfilter.org/${PN}-${MY_PV}.tar.bz2
- http://ipset.netfilter.org/patch-o-matic-ng-${POM_PV}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64 ~ppc"
-IUSE=""
-RDEPEND=">=net-firewall/iptables-1.4"
-DEPEND="${RDEPEND}"
-S=${WORKDIR}/ipset-${MY_PV%-*}
-
-pkg_setup() {
- myconf="${myconf} PREFIX="
- myconf="${myconf} LIBDIR=/$(get_libdir)"
- myconf="${myconf} BINDIR=/sbin"
- myconf="${myconf} MANDIR=/usr/share/man"
- myconf="${myconf} INCDIR=/usr/include"
- myconf="${myconf} KERNEL_DIR=${WORKDIR}/patch-o-matic-ng/patchlets/set/linux-2.6"
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" COPT_FLAGS="${CFLAGS}" ${myconf} || die "failed to build"
-}
-
-src_install() {
- emake DESTDIR="${D}" ${myconf} install || die "failed to package"
-}
-
-pkg_postinst() {
- elog "To use ${PN} you must have the ip_set kernel module compiled!"
- elog "To patch you kernel run:"
- elog
- elog " # emerge --config ipset"
- elog
- elog "And follow on-screen instructions"
-}
-
-pkg_config() {
- cd "${ROOT}${PORTAGE_TMPDIR}"
- [ -d patch-o-matic-ng ] && {
- einfo "${ROOT}${PORTAGE_TMPDIR}/patch-o-matic-ng directory exist. Cleaning it..." ;
- rm -rf patch-o-matic-ng;
- }
- mkdir patch-o-matic-ng && cd patch-o-matic-ng
-
- IPTVERINS=`echo $(best_version net-firewall/iptables) | \
- sed -n 's:^[^/]*/[[:alpha:]]*-\([0-9]\+\([.][0-9]\+\)*[a-z]\?\(_\(pre\|p\|beta\|alpha\|rc\)[0-9]*\)*\)\(-r[0-9]\+\)\?$:\1:p'`
-
- einfo "Unpacking patch-o-matic-ng-${POM_PV} and iptables-${IPTVERINS} sources"
- unpack {patch-o-matic-ng-${POM_PV},iptables-${IPTVERINS}}.tar.bz2
-
- einfo "I'm going to patch sources in ${ROOT}usr/src/linux"
- cd patch-o-matic-ng
- KERNEL_DIR="${ROOT}"usr/src/linux IPTABLES_DIR=../iptables-${IPTVERINS} ./runme set
-
- einfo "Cleaning ${ROOT}${PORTAGE_TMPDIR}/patch-o-matic-ng directory"
- rm -rf "${ROOT}${PORTAGE_TMPDIR}"/patch-o-matic-ng
-}
diff --git a/net-firewall/ipset/ipset-2.3.3a.ebuild b/net-firewall/ipset/ipset-2.3.3a.ebuild
deleted file mode 100644
index fb544835c4ce..000000000000
--- a/net-firewall/ipset/ipset-2.3.3a.ebuild
+++ /dev/null
@@ -1,92 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-2.3.3a.ebuild,v 1.2 2008/10/14 07:21:01 robbat2 Exp $
-
-inherit eutils versionator toolchain-funcs linux-mod linux-info
-
-DESCRIPTION="IPset tool for iptables, successor to ippool."
-HOMEPAGE="http://ipset.netfilter.org/"
-SRC_URI="http://ipset.netfilter.org/${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64 ~ppc"
-IUSE=""
-RDEPEND=">=net-firewall/iptables-1.4.1"
-DEPEND="${RDEPEND}"
-
-# configurable from outside
-[ -z "${IP_NF_SET_MAX}" ] && IP_NF_SET_MAX=256
-[ -z "${IP_NF_SET_HASHSIZE}" ] && IP_NF_SET_HASHSIZE=1024
-BUILD_PARAMS="IP_NF_SET_MAX=$IP_NF_SET_MAX IP_NF_SET_HASHSIZE=${IP_NF_SET_HASHSIZE}"
-# module fun
-BUILD_TARGETS="all"
-MODULE_NAMES_ARG="kernel/net/ipv4/netfilter:${S}/kernel"
-MODULE_NAMES=""
-for i in ip_set{,_{{ip,port,macip}map,{ip,net,ipport}hash,iptree{,map}}} \
- ipt_{SET,set}; do
- MODULE_NAMES="${MODULE_NAMES} ${i}(${MODULE_NAMES_ARG})"
-done
-# sanity
-CONFIG_CHECK="NETFILTER"
-ERROR_CFG="ipset needs netfilter support in your kernel."
-
-src_unpack() {
- unpack ${A}
- sed -i \
- -e 's/KERNELDIR/(KERNELDIR)/g' \
- -e 's/^(\?KERNEL_\?DIR.*/KERNELDIR ?= /' \
- -e '/^all::/iV ?= 0' \
- -e '/^all::/iKBUILD_OUTPUT ?=' \
- -e 's/$@/ V=$(V) KBUILD_OUTPUT=$(KBUILD_OUTPUT) modules/' \
- "${S}"/kernel/Makefile
- sed -i \
- -e '/asm.semaphore.h/d' \
- "${S}"/kernel/ip_set.c
-}
-
-pkg_setup() {
- get_version
-
- modules=0
- msg=''
- if linux_chkconfig_builtin "MODULES" ; then
- modules=1
- msg="Modular kernel detected, will build kernel modules"
- else
- msg="Nonmodular kernel detected, will not build kernel modules"
- fi
- einfo "${msg}"
-
- [[ $modules -eq 1 ]] && \
- linux-mod_pkg_setup
- myconf="${myconf} PREFIX="
- myconf="${myconf} LIBDIR=/$(get_libdir)"
- myconf="${myconf} BINDIR=/sbin"
- myconf="${myconf} MANDIR=/usr/share/man"
- myconf="${myconf} INCDIR=/usr/include"
- export myconf
-}
-
-src_compile() {
- einfo "Building userspace"
- emake CC="$(tc-getCC)" COPT_FLAGS="${CFLAGS}" ${myconf} binaries || die "failed to build"
-
- if [[ $modules -eq 1 ]]; then
- einfo "Building kernel modules"
- cd "${S}/kernel"
- export KERNELDIR="${KERNEL_DIR}"
- linux-mod_src_compile || die "failed to build modules"
- fi
-}
-
-src_install() {
- einfo "Installing userspace"
- emake DESTDIR="${D}" ${myconf} binaries_install || die "failed to package"
-
- if [[ $modules -eq 1 ]]; then
- einfo "Installing kernel modules"
- cd "${S}/kernel"
- export KERNELDIR="${KERNEL_DIR}"
- linux-mod_src_install
- fi
-}
diff --git a/net-firewall/ipset/ipset-2.4.2.ebuild b/net-firewall/ipset/ipset-2.4.2.ebuild
deleted file mode 100644
index 8a39f360ac4b..000000000000
--- a/net-firewall/ipset/ipset-2.4.2.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-2.4.2.ebuild,v 1.1 2008/10/24 21:28:25 robbat2 Exp $
-
-inherit eutils versionator toolchain-funcs linux-mod linux-info
-
-DESCRIPTION="IPset tool for iptables, successor to ippool."
-HOMEPAGE="http://ipset.netfilter.org/"
-SRC_URI="http://ipset.netfilter.org/${P}.tar.bz2"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~amd64 ~ppc"
-IUSE=""
-RDEPEND=">=net-firewall/iptables-1.4.1"
-DEPEND="${RDEPEND}"
-
-# configurable from outside
-[ -z "${IP_NF_SET_MAX}" ] && IP_NF_SET_MAX=256
-[ -z "${IP_NF_SET_HASHSIZE}" ] && IP_NF_SET_HASHSIZE=1024
-BUILD_PARAMS="IP_NF_SET_MAX=$IP_NF_SET_MAX IP_NF_SET_HASHSIZE=${IP_NF_SET_HASHSIZE}"
-# module fun
-BUILD_TARGETS="all"
-MODULE_NAMES_ARG="kernel/net/ipv4/netfilter:${S}/kernel"
-MODULE_NAMES=""
-for i in ip_set{,_{{ip,port,macip}map,{ip,net,ipport}hash,iptree{,map}}} \
- ipt_{SET,set}; do
- MODULE_NAMES="${MODULE_NAMES} ${i}(${MODULE_NAMES_ARG})"
-done
-# sanity
-CONFIG_CHECK="NETFILTER"
-ERROR_CFG="ipset needs netfilter support in your kernel."
-
-src_unpack() {
- unpack ${A}
- sed -i \
- -e 's/KERNELDIR/(KERNELDIR)/g' \
- -e 's/^(\?KERNEL_\?DIR.*/KERNELDIR ?= /' \
- -e '/^all::/iV ?= 0' \
- -e '/^all::/iKBUILD_OUTPUT ?=' \
- -e 's/$@/ V=$(V) KBUILD_OUTPUT=$(KBUILD_OUTPUT) modules/' \
- "${S}"/kernel/Makefile
- sed -i \
- -e '/asm.semaphore.h/d' \
- "${S}"/kernel/ip_set.c
-
- epatch "${FILESDIR}"/ipset-2.4.2-glibc28-fix.patch
-}
-
-pkg_setup() {
- get_version
-
- modules=0
- msg=''
- if linux_chkconfig_builtin "MODULES" ; then
- modules=1
- msg="Modular kernel detected, will build kernel modules"
- else
- msg="Nonmodular kernel detected, will not build kernel modules"
- fi
- einfo "${msg}"
-
- [[ $modules -eq 1 ]] && \
- linux-mod_pkg_setup
- myconf="${myconf} PREFIX="
- myconf="${myconf} LIBDIR=/$(get_libdir)"
- myconf="${myconf} BINDIR=/sbin"
- myconf="${myconf} MANDIR=/usr/share/man"
- myconf="${myconf} INCDIR=/usr/include"
- export myconf
-}
-
-src_compile() {
- einfo "Building userspace"
- emake CC="$(tc-getCC)" COPT_FLAGS="${CFLAGS}" ${myconf} binaries || die "failed to build"
-
- if [[ $modules -eq 1 ]]; then
- einfo "Building kernel modules"
- cd "${S}/kernel"
- export KERNELDIR="${KERNEL_DIR}"
- linux-mod_src_compile || die "failed to build modules"
- fi
-}
-
-src_install() {
- einfo "Installing userspace"
- emake DESTDIR="${D}" ${myconf} binaries_install || die "failed to package"
-
- if [[ $modules -eq 1 ]]; then
- einfo "Installing kernel modules"
- cd "${S}/kernel"
- export KERNELDIR="${KERNEL_DIR}"
- linux-mod_src_install
- fi
-}
diff --git a/net-firewall/ipset/ipset-2.4.9.ebuild b/net-firewall/ipset/ipset-2.4.9-r1.ebuild
index e1622181017a..b4a8ca810635 100644
--- a/net-firewall/ipset/ipset-2.4.9.ebuild
+++ b/net-firewall/ipset/ipset-2.4.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-2.4.9.ebuild,v 1.1 2009/02/28 14:07:44 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/ipset/ipset-2.4.9-r1.ebuild,v 1.1 2009/03/03 13:15:52 pva Exp $
inherit eutils versionator toolchain-funcs linux-mod linux-info
@@ -42,6 +42,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}/${PN}-2.4.7-LDFLAGS.patch"
+ epatch "${FILESDIR}/${PN}-2.4.9-gethostbyname-align.patch"
}
pkg_setup() {