summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGordon Malm <gengor@gentoo.org>2008-10-13 00:54:38 +0000
committerGordon Malm <gengor@gentoo.org>2008-10-13 00:54:38 +0000
commit5ce234c324c7edfdb763f07cbf01a8c8b627e82b (patch)
treeb1521834af069613f139887ddde6770b52bbab2e /net-firewall/firehol
parentVersion bump per #238969 (diff)
downloadgentoo-2-5ce234c324c7edfdb763f07cbf01a8c8b627e82b.tar.gz
gentoo-2-5ce234c324c7edfdb763f07cbf01a8c8b627e82b.tar.bz2
gentoo-2-5ce234c324c7edfdb763f07cbf01a8c8b627e82b.zip
Bump to version 1.273.
(Portage version: 2.2_rc12/cvs/Linux 2.6.26-hardened-r2-rc3-2008091301 i686)
Diffstat (limited to 'net-firewall/firehol')
-rw-r--r--net-firewall/firehol/ChangeLog7
-rw-r--r--net-firewall/firehol/firehol-1.273.ebuild73
2 files changed, 79 insertions, 1 deletions
diff --git a/net-firewall/firehol/ChangeLog b/net-firewall/firehol/ChangeLog
index c54921f3e75c..ed838268b6e0 100644
--- a/net-firewall/firehol/ChangeLog
+++ b/net-firewall/firehol/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/firehol
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/firehol/ChangeLog,v 1.37 2008/09/27 13:37:48 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/firehol/ChangeLog,v 1.38 2008/10/13 00:54:38 gengor Exp $
+
+*firehol-1.273 (13 Oct 2008)
+
+ 13 Oct 2008; Gordon Malm <gengor@gentoo.org> +firehol-1.273.ebuild:
+ Version bump. Thanks to Syed Amer Gilani and Kerin Millar in bug #233787.
27 Sep 2008; Petteri Räty <betelgeuse@gentoo.org>
firehol-1.256-r1.ebuild:
diff --git a/net-firewall/firehol/firehol-1.273.ebuild b/net-firewall/firehol/firehol-1.273.ebuild
new file mode 100644
index 000000000000..06c6bb93f6d5
--- /dev/null
+++ b/net-firewall/firehol/firehol-1.273.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/firehol/firehol-1.273.ebuild,v 1.1 2008/10/13 00:54:38 gengor Exp $
+
+EAPI=2
+
+inherit eutils linux-info
+
+DESCRIPTION="iptables firewall generator"
+HOMEPAGE="http://firehol.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+DEPEND="sys-apps/iproute2"
+RDEPEND="net-firewall/iptables
+ sys-apps/iproute2[-minimal]
+ virtual/modutils
+ || (
+ net-misc/wget
+ net-misc/curl
+ )"
+
+pkg_setup() {
+ # perform checks for kernel config from eclass linux-info
+ # for now we just print warnings as I am not sure if these
+ # are required always...
+ local KCONFIG_OPTS="~NF_CONNTRACK_IPV4 ~NF_CONNTRACK_MARK \
+ ~IP_NF_IPTABLES ~IP_NF_FILTER ~IP_NF_TARGET_REJECT \
+ ~IP_NF_TARGET_LOG ~IP_NF_TARGET_ULOG ~NF_NAT \
+ ~IP_NF_TARGET_MASQUERADE ~IP_NF_TARGET_REDIRECT ~IP_NF_MANGLE"
+ get_version
+ if [ ${KV_PATCH} -ge 25 ]; then
+ CONFIG_CHECK="~NF_CONNTRACK ${KCONFIG_OPTS}"
+ else
+ CONFIG_CHECK="~NF_CONNTRACK_ENABLED ${KCONFIG_OPTS}"
+ fi
+ linux-info_pkg_setup
+}
+
+src_install() {
+ newsbin firehol.sh firehol
+
+ dodir /etc/firehol /etc/firehol/examples /etc/firehol/services
+ insinto /etc/firehol/examples
+ doins examples/* || die
+
+ newconfd "${FILESDIR}/firehol.conf.d" firehol || die
+
+ dodoc ChangeLog README TODO WhatIsNew || die
+ dohtml doc/*.html doc/*.css || die
+
+ docinto scripts
+ dodoc get-iana.sh adblock.sh || die
+
+ doman man/*.1 man/*.5 || die
+
+ newinitd "${FILESDIR}/firehol.initrd" firehol || die
+}
+
+pkg_postinst() {
+ elog "The default path to firehol's configuration file is /etc/firehol/firehol.conf"
+ elog "See /etc/firehol/examples for configuration examples."
+ #
+ # Install a default configuration if none is available yet
+ if [[ ! -e "${ROOT}/etc/firehol/firehol.conf" ]]; then
+ einfo "Installing a sample configuration as ${ROOT}/etc/firehol/firehol.conf"
+ cp "${ROOT}/etc/firehol/examples/client-all.conf" "${ROOT}/etc/firehol/firehol.conf"
+ fi
+}