summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-05-13 19:17:43 +0000
committerMichał Górny <mgorny@gentoo.org>2014-05-13 19:17:43 +0000
commitac9e120d5de715676894a92abbcd52dad3fed492 (patch)
tree7b4502235d42565f237ea911d6ecff7ba20fb1bd /net-dns
parentEnable multilib support, bug #499382. (diff)
downloadgentoo-2-ac9e120d5de715676894a92abbcd52dad3fed492.tar.gz
gentoo-2-ac9e120d5de715676894a92abbcd52dad3fed492.tar.bz2
gentoo-2-ac9e120d5de715676894a92abbcd52dad3fed492.zip
Enable multilib support, bug #499380.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/unbound/ChangeLog7
-rw-r--r--net-dns/unbound/unbound-1.4.21-r2.ebuild110
2 files changed, 116 insertions, 1 deletions
diff --git a/net-dns/unbound/ChangeLog b/net-dns/unbound/ChangeLog
index 0d7ae2948774..bf95aebaffd4 100644
--- a/net-dns/unbound/ChangeLog
+++ b/net-dns/unbound/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/unbound
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/ChangeLog,v 1.65 2014/01/14 14:00:24 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/ChangeLog,v 1.66 2014/05/13 19:17:43 mgorny Exp $
+
+*unbound-1.4.21-r2 (13 May 2014)
+
+ 13 May 2014; Michał Górny <mgorny@gentoo.org> +unbound-1.4.21-r2.ebuild:
+ Enable multilib support, bug #499380.
14 Jan 2014; Agostino Sarubbo <ago@gentoo.org> unbound-1.4.21-r1.ebuild:
Stable for x86, wrt bug #494572
diff --git a/net-dns/unbound/unbound-1.4.21-r2.ebuild b/net-dns/unbound/unbound-1.4.21-r2.ebuild
new file mode 100644
index 000000000000..7c7a25ea018a
--- /dev/null
+++ b/net-dns/unbound/unbound-1.4.21-r2.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/unbound/unbound-1.4.21-r2.ebuild,v 1.1 2014/05/13 19:17:43 mgorny Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit eutils flag-o-matic multilib-minimal python-single-r1 systemd user
+
+DESCRIPTION="A validating, recursive and caching DNS resolver"
+HOMEPAGE="http://unbound.net/"
+SRC_URI="http://unbound.net/downloads/${P}.tar.gz"
+
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~x86 ~x64-macos"
+IUSE="debug gost python selinux static-libs test threads"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# Note: expat is needed by executable only but the Makefile is custom
+# and doesn't make it possible to easily install the library without
+# the executables. MULTILIB_USEDEP may be dropped once build system
+# is fixed.
+
+RDEPEND="dev-libs/expat[${MULTILIB_USEDEP}]
+ dev-libs/libevent[${MULTILIB_USEDEP}]
+ >=dev-libs/openssl-0.9.8[${MULTILIB_USEDEP}]
+ >=net-libs/ldns-1.6.13[ecdsa,ssl,gost?,${MULTILIB_USEDEP}]
+ python? ( ${PYTHON_DEPS} )
+ selinux? ( sec-policy/selinux-bind )"
+
+DEPEND="${RDEPEND}
+ python? ( dev-lang/swig )
+ test? (
+ net-dns/ldns-utils[examples]
+ dev-util/splint
+ app-text/wdiff
+ )"
+
+# bug #347415
+RDEPEND="${RDEPEND}
+ net-dns/dnssec-root"
+
+pkg_setup() {
+ enewgroup unbound
+ enewuser unbound -1 -1 /etc/unbound unbound
+
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ # To avoid below error messages, set 'trust-anchor-file' to same value in
+ # 'auto-trust-anchor-file'.
+ # [23109:0] error: Could not open autotrust file for writing,
+ # /etc/dnssec/root-anchors.txt: Permission denied
+ epatch "${FILESDIR}"/${PN}-1.4.12-gentoo.patch
+
+ # required for the python part
+ multilib_copy_sources
+}
+
+src_configure() {
+ append-ldflags -Wl,-z,noexecstack
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable gost) \
+ $(use_enable static-libs static) \
+ $(multilib_native_use_with python pythonmodule) \
+ $(multilib_native_use_with python pyunbound) \
+ $(use_with threads pthreads) \
+ --disable-rpath \
+ --enable-ecdsa \
+ --with-ldns="${EPREFIX}"/usr \
+ --with-libevent="${EPREFIX}"/usr \
+ --with-pidfile="${EPREFIX}"/var/run/unbound.pid \
+ --with-rootkey-file="${EPREFIX}"/etc/dnssec/root-anchors.txt
+
+ # http://unbound.nlnetlabs.nl/pipermail/unbound-users/2011-April/001801.html
+ # $(use_enable debug lock-checks) \
+ # $(use_enable debug alloc-checks) \
+ # $(use_enable debug alloc-lite) \
+ # $(use_enable debug alloc-nonregional) \
+}
+
+multilib_src_install_all() {
+ prune_libtool_files --modules
+ use python && python_optimize
+
+ newinitd "${FILESDIR}"/unbound.initd unbound
+ newconfd "${FILESDIR}"/unbound.confd unbound
+
+ systemd_dounit "${FILESDIR}"/unbound.service
+ systemd_newunit "${FILESDIR}"/unbound_at.service "unbound@.service"
+ systemd_dounit "${FILESDIR}"/unbound-anchor.service
+
+ dodoc doc/{README,CREDITS,TODO,Changelog,FEATURES}
+
+ # bug #315519
+ dodoc contrib/unbound_munin_
+
+ docinto selinux
+ dodoc contrib/selinux/*
+
+ exeinto /usr/share/${PN}
+ doexe contrib/update-anchor.sh
+}