summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2009-04-22 10:30:16 +0000
committerRaúl Porcel <armin76@gentoo.org>2009-04-22 10:30:16 +0000
commit7a58a83d2c4689f26eb796819cfa689b0bec6793 (patch)
treedc34b0c836a127cd74978adc354777d642abcc6f /net-dns
parentFix rake dependency. (diff)
downloadgentoo-2-7a58a83d2c4689f26eb796819cfa689b0bec6793.tar.gz
gentoo-2-7a58a83d2c4689f26eb796819cfa689b0bec6793.tar.bz2
gentoo-2-7a58a83d2c4689f26eb796819cfa689b0bec6793.zip
Version bump
(Portage version: 2.1.6.7/cvs/Linux ia64)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/openresolv/ChangeLog7
-rw-r--r--net-dns/openresolv/openresolv-3.3.ebuild49
2 files changed, 55 insertions, 1 deletions
diff --git a/net-dns/openresolv/ChangeLog b/net-dns/openresolv/ChangeLog
index e57635b9a5a6..b55f35e294fd 100644
--- a/net-dns/openresolv/ChangeLog
+++ b/net-dns/openresolv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/openresolv
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/openresolv/ChangeLog,v 1.33 2009/04/20 09:16:29 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/openresolv/ChangeLog,v 1.34 2009/04/22 10:30:16 armin76 Exp $
+
+*openresolv-3.3 (22 Apr 2009)
+
+ 22 Apr 2009; Raúl Porcel <armin76@gentoo.org> +openresolv-3.3.ebuild:
+ Version bump
*openresolv-3.2 (20 Apr 2009)
diff --git a/net-dns/openresolv/openresolv-3.3.ebuild b/net-dns/openresolv/openresolv-3.3.ebuild
new file mode 100644
index 000000000000..64dcb712d25f
--- /dev/null
+++ b/net-dns/openresolv/openresolv-3.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/openresolv/openresolv-3.3.ebuild,v 1.1 2009/04/22 10:30:16 armin76 Exp $
+
+inherit eutils
+
+DESCRIPTION="A framework for managing DNS information"
+HOMEPAGE="http://roy.marples.name/projects/openresolv"
+SRC_URI="http://roy.marples.name/downloads/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="!net-dns/resolvconf-gentoo
+ !<net-dns/dnsmasq-2.40-r1"
+RDEPEND=""
+
+pkg_setup() {
+ export PREFIX=
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}
+
+pkg_postinst() {
+ einfo "${PN}-3.0 has a new configuration file /etc/resolvconf.conf"
+ einfo "instead of mini files in different directories."
+ einfo "You should configure /etc/resolvconf.conf if you use a resolver"
+ einfo "other than libc."
+}
+
+pkg_config() {
+ if [ "${ROOT}" != "/" ]; then
+ eerror "We cannot configure unless \$ROOT=/"
+ return 1
+ fi
+
+ if [ -n "$(resolvconf -l)" ]; then
+ einfo "${PN} already has DNS information"
+ else
+ ebegin "Copying /etc/resolv.conf to resolvconf -a dummy"
+ resolvconf -a dummy </etc/resolv.conf
+ eend $? || return $?
+ einfo "The dummy interface will disappear when you next reboot"
+ fi
+}