summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-08-20 08:23:45 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-08-20 08:23:45 +0000
commit4d9d489fe1dffff1edb6180d00c551a4bb93a3f4 (patch)
tree9b6ffbb0f5a0aa9b6b1afc68561edc813436447b /net-dns
parentinitial commit (diff)
downloadgentoo-2-4d9d489fe1dffff1edb6180d00c551a4bb93a3f4.tar.gz
gentoo-2-4d9d489fe1dffff1edb6180d00c551a4bb93a3f4.tar.bz2
gentoo-2-4d9d489fe1dffff1edb6180d00c551a4bb93a3f4.zip
initial commit
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/ndu/ChangeLog7
-rw-r--r--net-dns/ndu/Manifest4
-rw-r--r--net-dns/ndu/files/digest-ndu-0.41
-rw-r--r--net-dns/ndu/metadata.xml9
-rw-r--r--net-dns/ndu/ndu-0.4.ebuild38
5 files changed, 58 insertions, 1 deletions
diff --git a/net-dns/ndu/ChangeLog b/net-dns/ndu/ChangeLog
new file mode 100644
index 000000000000..444b79a53842
--- /dev/null
+++ b/net-dns/ndu/ChangeLog
@@ -0,0 +1,7 @@
+# ChangeLog for net-dns/ndu
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ndu/ChangeLog,v 1.1 2003/08/20 08:23:42 robbat2 Exp $
+
+ 20 Aug 2003; Robin H. Johnson <robbat2@gentoo.org> :
+ initial commit
+
diff --git a/net-dns/ndu/Manifest b/net-dns/ndu/Manifest
index e4e37823dde3..8913b370f75c 100644
--- a/net-dns/ndu/Manifest
+++ b/net-dns/ndu/Manifest
@@ -1,2 +1,4 @@
-MD5 a886d86a031989ea4d9ff8f7327da32c ndu-0.4.ebuild 537
+MD5 60c0ec1bd1aa63a98e5a204d12a22b5f ChangeLog 277
+MD5 b0d485ea1a51fb83c70daedef2599272 metadata.xml 279
+MD5 6d6aa6f57d49d3272d2ce725a6e6a26e ndu-0.4.ebuild 1126
MD5 f3a54eec95c7e1c3fe531456a3ae15b2 files/digest-ndu-0.4 58
diff --git a/net-dns/ndu/files/digest-ndu-0.4 b/net-dns/ndu/files/digest-ndu-0.4
new file mode 100644
index 000000000000..5093a5f3bafe
--- /dev/null
+++ b/net-dns/ndu/files/digest-ndu-0.4
@@ -0,0 +1 @@
+MD5 dbf8b8e7b65cf189e732ff11c7f08181 ndu-0.4.tar.gz 16118
diff --git a/net-dns/ndu/metadata.xml b/net-dns/ndu/metadata.xml
new file mode 100644
index 000000000000..02e945c7cb52
--- /dev/null
+++ b/net-dns/ndu/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>robbat2@gentoo.org</email>
+ <name>Robin H. Johnson</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-dns/ndu/ndu-0.4.ebuild b/net-dns/ndu/ndu-0.4.ebuild
new file mode 100644
index 000000000000..4134d612e0c5
--- /dev/null
+++ b/net-dns/ndu/ndu-0.4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ndu/ndu-0.4.ebuild,v 1.1 2003/08/20 08:23:42 robbat2 Exp $
+
+DESCRIPTION="DNS serial number incrementer and reverse zone builder"
+URI_BASE="http://uranus.it.swin.edu.au/~jn/linux/"
+SRC_URI="${URI_BASE}/${P}.tar.gz"
+HOMEPAGE="${URI_BASE}/dns.htm"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="sys-apps/sed virtual/glibc"
+RDEPEND="net-dns/bind virtual/glibc"
+S=${WORKDIR}/${P}
+
+src_compile() {
+ cd ${S}/src
+ sed -i 's|gcc|$(CXX)|g' Makefile
+ sed -i 's|#define CONFIG_PATH "/etc/"|#define CONFIG_PATH "/etc/bind/"|g' ndc.c
+ emake
+ sed -i 's|VISUAL|EDITOR|g' dnsedit
+ cd ${S}
+ sed -i 's|0.0.127.in-addr.arpa|127.in-addr.arpa|g' ndu.conf
+ echo '## if you use a chrooted setup, then you need to uncomment these lines:' >>ndu.conf
+ echo '#process "/chroot/dns/named.conf"' >>ndu.conf
+ echo '#chroot "/chroot/dns"' >>ndu.conf
+}
+
+src_install () {
+ into /usr
+ dosbin src/{dnsedit,ndu}
+ dobin src/dnstouch
+ into /
+ insinto /etc/bind
+ doins ndu.conf
+ dodoc README INSTALL
+}