summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2013-03-29 13:05:51 +0000
committerChristian Ruppert <idl0r@gentoo.org>2013-03-29 13:05:51 +0000
commit3b5febb7d595d662e19cbf764b16a1ded647d772 (patch)
treefda6a6d13b0744a8e1df6703abada9970bd264a3 /net-dns
parentSecurity bump (diff)
downloadgentoo-2-3b5febb7d595d662e19cbf764b16a1ded647d772.tar.gz
gentoo-2-3b5febb7d595d662e19cbf764b16a1ded647d772.tar.bz2
gentoo-2-3b5febb7d595d662e19cbf764b16a1ded647d772.zip
Version bump
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key B427ABC8)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/bind-tools/ChangeLog10
-rw-r--r--net-dns/bind-tools/bind-tools-9.9.2_p2.ebuild103
2 files changed, 111 insertions, 2 deletions
diff --git a/net-dns/bind-tools/ChangeLog b/net-dns/bind-tools/ChangeLog
index b8cc2e7c9a33..d6cc283dd6e0 100644
--- a/net-dns/bind-tools/ChangeLog
+++ b/net-dns/bind-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dns/bind-tools
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/bind-tools/ChangeLog,v 1.234 2012/12/16 17:39:10 armin76 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind-tools/ChangeLog,v 1.235 2013/03/29 13:05:51 idl0r Exp $
+
+*bind-tools-9.9.2_p2 (29 Mar 2013)
+
+ 29 Mar 2013; Christian Ruppert <idl0r@gentoo.org>
+ +bind-tools-9.9.2_p2.ebuild:
+ Version bump
16 Dec 2012; Raúl Porcel <armin76@gentoo.org> bind-tools-9.9.2.ebuild:
alpha/ia64/s390/sh/sparc stable wrt #440318
diff --git a/net-dns/bind-tools/bind-tools-9.9.2_p2.ebuild b/net-dns/bind-tools/bind-tools-9.9.2_p2.ebuild
new file mode 100644
index 000000000000..8e5e25ef9139
--- /dev/null
+++ b/net-dns/bind-tools/bind-tools-9.9.2_p2.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/bind-tools/bind-tools-9.9.2_p2.ebuild,v 1.1 2013/03/29 13:05:51 idl0r Exp $
+
+EAPI="4"
+
+inherit eutils autotools flag-o-matic toolchain-funcs
+
+MY_PN=${PN//-tools}
+MY_PV=${PV/_p/-P}
+MY_PV=${MY_PV/_rc/rc}
+MY_P="${MY_PN}-${MY_PV}"
+
+DESCRIPTION="bind tools: dig, nslookup, host, nsupdate, dnssec-keygen"
+HOMEPAGE="http://www.isc.org/software/bind"
+SRC_URI="ftp://ftp.isc.org/isc/bind9/${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="ISC BSD BSD-2 HPND JNIC RSA openssl"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc gssapi idn ipv6 readline ssl urandom xml"
+# no PKCS11 currently as it requires OpenSSL to be patched, also see bug 409687
+
+DEPEND="ssl? ( dev-libs/openssl )
+ xml? ( dev-libs/libxml2 )
+ idn? ( net-dns/idnkit )
+ gssapi? ( virtual/krb5 )
+ readline? ( sys-libs/readline )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ # bug 231247
+ epatch "${FILESDIR}"/${PN}-9.5.0_p1-lwconfig.patch
+
+ # Disable tests for now, bug 406399
+ sed -i '/^SUBDIRS/s:tests::' bin/Makefile.in lib/Makefile.in || die
+
+ # bug #220361
+ rm {aclocal,libtool}.m4
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=
+
+ if use urandom; then
+ myconf="${myconf} --with-randomdev=/dev/urandom"
+ else
+ myconf="${myconf} --with-randomdev=/dev/random"
+ fi
+
+ # bug 344029
+ append-cflags "-DDIG_SIGCHASE"
+
+ # localstatedir for nsupdate -l, bug 395785
+ tc-export BUILD_CC
+ econf \
+ --localstatedir=/var \
+ --without-python \
+ $(use_enable ipv6) \
+ $(use_with idn) \
+ $(use_with ssl openssl "${EPREFIX}"/usr) \
+ $(use_with xml libxml2) \
+ $(use_with gssapi) \
+ $(use_with readline) \
+ ${myconf}
+
+ # bug #151839
+ echo '#undef SO_BSDCOMPAT' >> config.h
+}
+
+src_compile() {
+ local AR=$(tc-getAR)
+
+ emake AR=$AR -C lib/ || die "emake lib failed"
+ emake AR=$AR -C bin/dig/ || die "emake bin/dig failed"
+ emake AR=$AR -C bin/nsupdate/ || die "emake bin/nsupdate failed"
+ emake AR=$AR -C bin/dnssec/ || die "emake bin/dnssec failed"
+}
+
+src_install() {
+ dodoc README CHANGES FAQ
+
+ cd "${S}"/bin/dig
+ dobin dig host nslookup
+ doman {dig,host,nslookup}.1
+
+ cd "${S}"/bin/nsupdate
+ dobin nsupdate
+ doman nsupdate.1
+ if use doc; then
+ dohtml nsupdate.html
+ fi
+
+ cd "${S}"/bin/dnssec
+ dobin dnssec-keygen
+ doman dnssec-keygen.8
+ if use doc; then
+ dohtml dnssec-keygen.html
+ fi
+}