summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2011-03-26 03:03:28 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2011-03-26 03:03:28 +0000
commit33b83abc9782e8cb3b7f9dc835ee51d0177cb1ff (patch)
tree8205b04ea7088cb202b1ee9a586c48a23abd0895 /net-dns
parentVersion bumped, bug #360171. (diff)
downloadgentoo-2-33b83abc9782e8cb3b7f9dc835ee51d0177cb1ff.tar.gz
gentoo-2-33b83abc9782e8cb3b7f9dc835ee51d0177cb1ff.tar.bz2
gentoo-2-33b83abc9782e8cb3b7f9dc835ee51d0177cb1ff.zip
Version bumped, bug #360171.
(Portage version: 2.1.9.43/cvs/Linux x86_64)
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/ldns-utils/ChangeLog7
-rw-r--r--net-dns/ldns-utils/ldns-utils-1.6.9.ebuild53
2 files changed, 59 insertions, 1 deletions
diff --git a/net-dns/ldns-utils/ChangeLog b/net-dns/ldns-utils/ChangeLog
index 3c02facea533..3592d9f1d96e 100644
--- a/net-dns/ldns-utils/ChangeLog
+++ b/net-dns/ldns-utils/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/ldns-utils
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/ldns-utils/ChangeLog,v 1.7 2011/01/25 13:37:37 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ldns-utils/ChangeLog,v 1.8 2011/03/26 03:03:28 matsuu Exp $
+
+*ldns-utils-1.6.9 (26 Mar 2011)
+
+ 26 Mar 2011; MATSUU Takuto <matsuu@gentoo.org> +ldns-utils-1.6.9.ebuild:
+ Version bumped, bug #360171.
*ldns-utils-1.6.8 (25 Jan 2011)
diff --git a/net-dns/ldns-utils/ldns-utils-1.6.9.ebuild b/net-dns/ldns-utils/ldns-utils-1.6.9.ebuild
new file mode 100644
index 000000000000..e526ecb6f53f
--- /dev/null
+++ b/net-dns/ldns-utils/ldns-utils-1.6.9.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/ldns-utils/ldns-utils-1.6.9.ebuild,v 1.1 2011/03/26 03:03:28 matsuu Exp $
+
+EAPI="2"
+
+MY_P="${P/-utils}"
+DESCRIPTION="Set of utilities to simplify various dns(sec) tasks."
+HOMEPAGE="http://www.nlnetlabs.nl/projects/ldns/"
+SRC_URI="http://www.nlnetlabs.nl/downloads/ldns/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples gost ssl"
+
+DEPEND=">=net-libs/ldns-${PV}[gost?,ssl?]
+ examples? ( net-libs/libpcap )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ cd "${S}"/drill
+ econf $(use_with ssl) || die
+
+ if use examples; then
+ cd "${S}"/examples
+ econf \
+ $(use_enable gost) \
+ $(use_enable ssl sha2) \
+ $(use_with ssl) || die
+ fi
+}
+
+src_compile() {
+ emake -C drill || die "emake for drill failed"
+ if use examples; then
+ emake -C examples || die "emake for examples failed"
+ fi
+}
+
+src_install() {
+ cd "${S}"/drill
+ emake DESTDIR="${D}" install || die "emake install for drill failed"
+ dodoc ChangeLog.22-nov-2005 README REGRESSIONS || die
+
+ if use examples; then
+ cd "${S}"/examples
+ emake DESTDIR="${D}" install || die "emake install for examples failed"
+ newdoc README README.examples || die
+ fi
+}