summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-08-06 13:39:15 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-08-06 13:39:15 +0000
commitd07475d43d4faff959a6165cb91238a9e9c3b3f4 (patch)
treea605f0fdaa1bf2feda6d99dcbcd4baa01bbca9a3 /net-dns/host/host-20070128-r1.ebuild
parentQA (diff)
downloadgentoo-2-d07475d43d4faff959a6165cb91238a9e9c3b3f4.tar.gz
gentoo-2-d07475d43d4faff959a6165cb91238a9e9c3b3f4.tar.bz2
gentoo-2-d07475d43d4faff959a6165cb91238a9e9c3b3f4.zip
Repect LDFLAGS + QA fixes from Doktor Notor <notordoktor@gmail.com>. Bug #309153
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-dns/host/host-20070128-r1.ebuild')
-rw-r--r--net-dns/host/host-20070128-r1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-dns/host/host-20070128-r1.ebuild b/net-dns/host/host-20070128-r1.ebuild
new file mode 100644
index 000000000000..521c47e9799e
--- /dev/null
+++ b/net-dns/host/host-20070128-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/host/host-20070128-r1.ebuild,v 1.1 2010/08/06 13:39:15 hwoarang Exp $
+
+EAPI="2"
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="A powerful command-line DNS query and test tool implementing many additional protocols"
+HOMEPAGE="http://www.weird.com/~woods/projects/host.html"
+SRC_URI="ftp://ftp.weird.com/pub/local/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="debug"
+
+# Bug 91515
+RESTRICT="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-Makefile.patch"
+ sed -i -e "s:^\(# if defined(__alpha).*\):\1 || defined(__x86_64__):" \
+ port.h || die "sed failed"
+}
+
+src_compile() {
+ use debug && export DEBUGDEFS="-DDEBUG"
+ emake CC="$(tc-getCC)" RES_LIB=/usr/$(get_libdir)/libresolv.a || die "emake failed"
+}
+
+src_install () {
+ # This tool has slightly different format of output from "standard" host.
+ # Renaming it to host-woods, hopefully this does not conflict with anything.
+
+ newbin host host-woods || die "newbin failed"
+ newman host.1 host-woods.1 || die "newman failed"
+ dodoc RELEASE_NOTES ToDo || die "dodoc failed"
+}