summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2005-01-14 14:29:08 +0000
committerAndrej Kacian <ticho@gentoo.org>2005-01-14 14:29:08 +0000
commitc2c240f7d3f8f43f8d1ecc5889d82fe500c70e7e (patch)
treeac33d5161c73eaea01c8ba36e4a5fd20eaa15248 /net-dns/dlint
parentStable on x86. (Manifest recommit) (diff)
downloadgentoo-2-c2c240f7d3f8f43f8d1ecc5889d82fe500c70e7e.tar.gz
gentoo-2-c2c240f7d3f8f43f8d1ecc5889d82fe500c70e7e.tar.bz2
gentoo-2-c2c240f7d3f8f43f8d1ecc5889d82fe500c70e7e.zip
Use fixheadtails.eclass instead of arbitrary sed calls.
Diffstat (limited to 'net-dns/dlint')
-rw-r--r--net-dns/dlint/ChangeLog9
-rw-r--r--net-dns/dlint/dlint-1.4.0-r1.ebuild9
-rw-r--r--net-dns/dlint/dlint-1.4.0.ebuild4
3 files changed, 13 insertions, 9 deletions
diff --git a/net-dns/dlint/ChangeLog b/net-dns/dlint/ChangeLog
index 604a1e6b9c28..2fdc2ba330a7 100644
--- a/net-dns/dlint/ChangeLog
+++ b/net-dns/dlint/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-dns/dlint
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dlint/ChangeLog,v 1.6 2004/10/19 14:10:26 ticho Exp $
+# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dlint/ChangeLog,v 1.7 2005/01/14 14:29:08 ticho Exp $
+
+ 14 Jan 2005; Andrej Kacian <ticho@gentoo.org> dlint-1.4.0-r1.ebuild:
+ Use fixheadtails.eclass instead of arbitrary sed calls. Fix changelog.
+
+*dlint-1.4.0-r1 (19 Oct 2004)
19 Oct 2004; Andrej Kacian <ticho@gentoo.org> :
Fix deprecated use of head(1) and tail(1). Closes #67995, reported by Ray
diff --git a/net-dns/dlint/dlint-1.4.0-r1.ebuild b/net-dns/dlint/dlint-1.4.0-r1.ebuild
index 4a999fd1c443..3f3d597290c8 100644
--- a/net-dns/dlint/dlint-1.4.0-r1.ebuild
+++ b/net-dns/dlint/dlint-1.4.0-r1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dlint/dlint-1.4.0-r1.ebuild,v 1.1 2004/10/19 14:10:26 ticho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dlint/dlint-1.4.0-r1.ebuild,v 1.2 2005/01/14 14:29:08 ticho Exp $
-inherit eutils
+inherit eutils fixheadtails
S=${WORKDIR}/${P/-/}
DESCRIPTION="Dlint analyzes any DNS zone you specify, and reports any problems it finds by displaying errors and warnings"
@@ -23,8 +23,7 @@ RDEPEND="sys-apps/coreutils
src_compile() {
sed -i -e 's:rrfilt=\"/usr/local/bin/digparse\":rrfilt=\"/usr/bin/digparse\":' \
dlint
- sed -i -e "s:head -:head -n :g" dlint
- sed -i -e "s:tail +:tail -n +:g" dlint
+ ht_fix_file dlint
}
src_install () {
diff --git a/net-dns/dlint/dlint-1.4.0.ebuild b/net-dns/dlint/dlint-1.4.0.ebuild
index 4f51aeca4452..899157a8dbb3 100644
--- a/net-dns/dlint/dlint-1.4.0.ebuild
+++ b/net-dns/dlint/dlint-1.4.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/dlint/dlint-1.4.0.ebuild,v 1.12 2004/07/14 23:23:13 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dlint/dlint-1.4.0.ebuild,v 1.13 2005/01/14 14:29:08 ticho Exp $
MY_P=${PN}${PV}
S=${WORKDIR}/${MY_P}