summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2008-05-19 20:26:53 +0000
committerAlin Năstac <mrness@gentoo.org>2008-05-19 20:26:53 +0000
commit054fd1353cafa7e909799593af7d35dea8656128 (patch)
treeae7144b2422cb3e19ee1d32420a4993042f4626f /net-dialup/slmodem/files
parentChanged dependency for postgresql to virtual/postgresql-base (diff)
downloadgentoo-2-054fd1353cafa7e909799593af7d35dea8656128.tar.gz
gentoo-2-054fd1353cafa7e909799593af7d35dea8656128.tar.bz2
gentoo-2-054fd1353cafa7e909799593af7d35dea8656128.zip
Version bump (#222537).
(Portage version: 2.1.4.4)
Diffstat (limited to 'net-dialup/slmodem/files')
-rw-r--r--net-dialup/slmodem/files/slmodem-2.9.11-makefile-r1.patch45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-dialup/slmodem/files/slmodem-2.9.11-makefile-r1.patch b/net-dialup/slmodem/files/slmodem-2.9.11-makefile-r1.patch
new file mode 100644
index 000000000000..cfac3030ac4e
--- /dev/null
+++ b/net-dialup/slmodem/files/slmodem-2.9.11-makefile-r1.patch
@@ -0,0 +1,45 @@
+diff -Nru slmodem-2.9.11-20080417.orig/modem/Makefile slmodem-2.9.11-20080417/modem/Makefile
+--- slmodem-2.9.11-20080417.orig/modem/Makefile 2008-04-18 06:06:17.000000000 +0300
++++ slmodem-2.9.11-20080417/modem/Makefile 2008-05-19 23:18:45.000000000 +0300
+@@ -16,15 +16,15 @@
+ ARCH64:=$(shell uname -m | sed -e '/amd64/s//x86_64/' | grep -c x86_64)
+
+ ifeq ($(ARCH64), 0)
+-CC:= gcc
++CC?= gcc
+ else
+ # SUPPORT_ALSA:=1
+-CC:= gcc -m32
++CC?= gcc -m32
+ endif
+
+ RM:= rm -f
+
+-CFLAGS+= -Wall -g -O -I. -DCONFIG_DEBUG_MODEM
++CFLAGS+= -Wall -finline -I. -DCONFIG_DEBUG_MODEM
+
+ modem-objs:= \
+ modem.o modem_datafile.o modem_at.o modem_timer.o \
+@@ -42,18 +42,18 @@
+ ifdef SUPPORT_ALSA
+ CFLAGS+= -DSUPPORT_ALSA=1
+ ifeq ($(ARCH64), 0)
+-LFLAGS+= /usr/lib/libasound.so
++LDLIBS+= /usr/lib/libasound.so
+ else
+ # LFLAGS+= /usr/lib32/libasound.so , replaced by -l commands search for asound
+-LFLAGS+= -lasound
++LDLIBS+= -lasound
+ endif
+ endif
+
+ slmodemd:
+- $(CC) -o slmodemd modem_main.o $(all-objs) $(LFLAGS)
++ $(CC) $(LDFLAGS) -o slmodemd modem_main.o $(all-objs) $(LDLIBS)
+
+ modem_test:
+- $(CC) -o modem_test modem_test.o $(all-objs) $(LFLAGS)
++ $(CC) $(LDFLAGS) -o modem_test modem_test.o $(all-objs) $(LDLIBS)
+
+ clean:
+ $(RM) slmodemd modem_test modem_main.o modem_cmdline.o modem_test.o $(modem-objs) $(dp-objs) $(sysdep-objs)