summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2008-06-14 16:54:53 +0000
committerZac Medico <zmedico@gentoo.org>2008-06-14 16:54:53 +0000
commit9055413eb4cc4426a5c334443c2c8cace678fdf0 (patch)
treea9cf0b1679ac82df99a1b69bf4db6b08abf339d2 /net-dialup/ppp
parentadded USE=otp for app-crypt/heimdal in use.local.desc (diff)
downloadgentoo-2-9055413eb4cc4426a5c334443c2c8cace678fdf0.tar.gz
gentoo-2-9055413eb4cc4426a5c334443c2c8cace678fdf0.tar.bz2
gentoo-2-9055413eb4cc4426a5c334443c2c8cace678fdf0.zip
Bug #226505 - For compatibility with phase execution order in
>=portage-2.1.5, call has_version inside pkg_preinst instead of pkg_postinst. (Portage version: 2.2_pre10652/cvs/Linux 2.6.25-0518-x86-64 i686)
Diffstat (limited to 'net-dialup/ppp')
-rw-r--r--net-dialup/ppp/ChangeLog8
-rw-r--r--net-dialup/ppp/ppp-2.4.4-r14.ebuild10
-rw-r--r--net-dialup/ppp/ppp-2.4.4-r15.ebuild10
3 files changed, 21 insertions, 7 deletions
diff --git a/net-dialup/ppp/ChangeLog b/net-dialup/ppp/ChangeLog
index 54d3b837e495..4b1589262fae 100644
--- a/net-dialup/ppp/ChangeLog
+++ b/net-dialup/ppp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dialup/ppp
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp/ChangeLog,v 1.211 2008/05/14 22:05:03 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp/ChangeLog,v 1.212 2008/06/14 16:54:53 zmedico Exp $
+
+ 14 Jun 2008; Zac Medico <zmedico@gentoo.org> ppp-2.4.4-r14.ebuild,
+ ppp-2.4.4-r15.ebuild:
+ Bug #226505 - For compatibility with phase execution order in
+ >=portage-2.1.5, call has_version inside pkg_preinst instead of
+ pkg_postinst.
14 May 2008; Diego Pettenò <flameeyes@gentoo.org> ppp-2.4.4-r15.ebuild:
Depend on virtual/pam as the code builds fine with OpenPAM.
diff --git a/net-dialup/ppp/ppp-2.4.4-r14.ebuild b/net-dialup/ppp/ppp-2.4.4-r14.ebuild
index 76cb17f0c13b..04b1685f2b63 100644
--- a/net-dialup/ppp/ppp-2.4.4-r14.ebuild
+++ b/net-dialup/ppp/ppp-2.4.4-r14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp/ppp-2.4.4-r14.ebuild,v 1.3 2008/03/31 04:38:30 ricmm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp/ppp-2.4.4-r14.ebuild,v 1.4 2008/06/14 16:54:53 zmedico Exp $
inherit eutils flag-o-matic toolchain-funcs linux-info pam
@@ -132,7 +132,11 @@ src_compile() {
}
pkg_preinst() {
- if use radius && [ -d "${ROOT}/etc/radiusclient" ] && has_version "<${CATEGORY}/${PN}-2.4.3-r5"; then
+ has_version "<${CATEGORY}/${PN}-2.4.3-r5"
+ previous_less_than_2_4_3_r5=$?
+
+ if use radius && [ -d "${ROOT}/etc/radiusclient" ] && \
+ [[ $previous_less_than_2_4_3_r5 = 0 ]] ; then
ebegin "Copy /etc/radiusclient to /etc/ppp/radius"
cp -pPR "${ROOT}/etc/radiusclient" "${ROOT}/etc/ppp/radius"
eend $?
@@ -281,7 +285,7 @@ pkg_postinst() {
# lib name has changed
sed -i -e "s:^pppoe.so:rp-pppoe.so:" "${ROOT}/etc/ppp/options"
- if use radius && has_version "<${CATEGORY}/${PN}-2.4.3-r5"; then
+ if use radius && [[ $previous_less_than_2_4_3_r5 = 0 ]] ; then
echo
ewarn "As of ${PN}-2.4.3-r5, the RADIUS configuration files have moved from"
ewarn " /etc/radiusclient to /etc/ppp/radius."
diff --git a/net-dialup/ppp/ppp-2.4.4-r15.ebuild b/net-dialup/ppp/ppp-2.4.4-r15.ebuild
index 4c8290004f60..d5512621e4d5 100644
--- a/net-dialup/ppp/ppp-2.4.4-r15.ebuild
+++ b/net-dialup/ppp/ppp-2.4.4-r15.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp/ppp-2.4.4-r15.ebuild,v 1.2 2008/05/14 22:05:03 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/ppp/ppp-2.4.4-r15.ebuild,v 1.3 2008/06/14 16:54:53 zmedico Exp $
inherit eutils flag-o-matic toolchain-funcs linux-info pam
@@ -133,7 +133,11 @@ src_compile() {
}
pkg_preinst() {
- if use radius && [ -d "${ROOT}/etc/radiusclient" ] && has_version "<${CATEGORY}/${PN}-2.4.3-r5"; then
+ has_version "<${CATEGORY}/${PN}-2.4.3-r5"
+ previous_less_than_2_4_3_r5=$?
+
+ if use radius && [ -d "${ROOT}/etc/radiusclient" ] && \
+ [[ $previous_less_than_2_4_3_r5 = 0 ]] ; then
ebegin "Copy /etc/radiusclient to /etc/ppp/radius"
cp -pPR "${ROOT}/etc/radiusclient" "${ROOT}/etc/ppp/radius"
eend $?
@@ -282,7 +286,7 @@ pkg_postinst() {
# lib name has changed
sed -i -e "s:^pppoe.so:rp-pppoe.so:" "${ROOT}/etc/ppp/options"
- if use radius && has_version "<${CATEGORY}/${PN}-2.4.3-r5"; then
+ if use radius && [[ $previous_less_than_2_4_3_r5 = 0 ]] ; then
echo
ewarn "As of ${PN}-2.4.3-r5, the RADIUS configuration files have moved from"
ewarn " /etc/radiusclient to /etc/ppp/radius."