summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2013-04-01 13:40:24 +0000
committerSergey Popov <pinkbyte@gentoo.org>2013-04-01 13:40:24 +0000
commit94d7655a61f9dc759f7a33fb0dd2f44bcca4d0d8 (patch)
treef606977e7744210a2f2464af0d2a1fd4f494624f /net-dialup/cistronradius
parentVersion bump. (diff)
downloadgentoo-2-94d7655a61f9dc759f7a33fb0dd2f44bcca4d0d8.tar.gz
gentoo-2-94d7655a61f9dc759f7a33fb0dd2f44bcca4d0d8.tar.bz2
gentoo-2-94d7655a61f9dc759f7a33fb0dd2f44bcca4d0d8.zip
Revision bump: fix QA issues, bump to EAPI 5, add epatch_user, respect LDFLAGS, wrt bug #332727
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key 0x1F357D42)
Diffstat (limited to 'net-dialup/cistronradius')
-rw-r--r--net-dialup/cistronradius/ChangeLog11
-rw-r--r--net-dialup/cistronradius/cistronradius-1.6.8-r1.ebuild50
2 files changed, 59 insertions, 2 deletions
diff --git a/net-dialup/cistronradius/ChangeLog b/net-dialup/cistronradius/ChangeLog
index 4ad487a0a60e..98a2d6af5562 100644
--- a/net-dialup/cistronradius/ChangeLog
+++ b/net-dialup/cistronradius/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-dialup/cistronradius
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/cistronradius/ChangeLog,v 1.18 2008/10/18 07:15:40 mrness Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/cistronradius/ChangeLog,v 1.19 2013/04/01 13:40:24 pinkbyte Exp $
+
+*cistronradius-1.6.8-r1 (01 Apr 2013)
+
+ 01 Apr 2013; Sergey Popov <pinkbyte@gentoo.org>
+ +cistronradius-1.6.8-r1.ebuild:
+ Revision bump: fix QA issues, bump to EAPI 5, add epatch_user, respect
+ LDFLAGS, wrt bug #332727
18 Oct 2008; Alin Năstac <mrness@gentoo.org> cistronradius-1.6.8.ebuild:
Pass Makefile parameters through emake command line (#240872).
diff --git a/net-dialup/cistronradius/cistronradius-1.6.8-r1.ebuild b/net-dialup/cistronradius/cistronradius-1.6.8-r1.ebuild
new file mode 100644
index 000000000000..9aa69898afcb
--- /dev/null
+++ b/net-dialup/cistronradius/cistronradius-1.6.8-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/cistronradius/cistronradius-1.6.8-r1.ebuild,v 1.1 2013/04/01 13:40:24 pinkbyte Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="An authentication and accounting server for terminal servers that speak the RADIUS protocol"
+SRC_URI="ftp://ftp.radius.cistron.nl/pub/radius/radiusd-cistron-${PV}.tar.gz"
+HOMEPAGE="http://www.radius.cistron.nl/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~x86"
+
+DEPEND="!net-dialup/freeradius
+ !net-dialup/gnuradius"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/radiusd-cistron-${PV}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gcc41.patch"
+ sed -i -e "s:SHAREDIR/::g" raddb/dictionary || die
+ mv src/checkrad.pl src/checkrad || die
+
+ epatch_user
+}
+
+src_compile() {
+ emake -C src \
+ CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ BINDIR=/usr/bin SBINDIR=/usr/sbin \
+ MANDIR=/usr/share/man SHAREDIR=/usr/share/radius
+}
+
+src_install() {
+ insinto /etc/raddb
+ doins raddb/*
+ dodoc README doc/{ChangeLog,FAQ.txt,README*}
+ doman doc/{*.1,*.8,*.5rad,*.8rad}
+
+ exeinto /usr/sbin
+ doexe src/{checkrad,radiusd,radrelay}
+ exeinto /usr/bin
+ doexe src/{radclient,radlast,radtest,radwho,radzap}
+
+ newinitd "${FILESDIR}/cistronradius.rc" cistronradius
+}