summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-12-18 21:39:26 +0000
committerJeroen Roovers <jer@gentoo.org>2012-12-18 21:39:26 +0000
commitfa8d7274399ac13aae62e2c0d45def692535874f (patch)
tree2403ed5f21a2b76a042252b4b5176dc9309add2f /net-analyzer
parentStable for ia64, wrt bug #447012 (diff)
downloadgentoo-2-fa8d7274399ac13aae62e2c0d45def692535874f.tar.gz
gentoo-2-fa8d7274399ac13aae62e2c0d45def692535874f.tar.bz2
gentoo-2-fa8d7274399ac13aae62e2c0d45def692535874f.zip
Version bump.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/sarg/ChangeLog8
-rw-r--r--net-analyzer/sarg/metadata.xml4
-rw-r--r--net-analyzer/sarg/sarg-2.3.3.ebuild63
3 files changed, 74 insertions, 1 deletions
diff --git a/net-analyzer/sarg/ChangeLog b/net-analyzer/sarg/ChangeLog
index 8557cd01040b..1c5f2e708619 100644
--- a/net-analyzer/sarg/ChangeLog
+++ b/net-analyzer/sarg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/sarg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sarg/ChangeLog,v 1.70 2012/04/17 18:07:41 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sarg/ChangeLog,v 1.71 2012/12/18 21:39:26 jer Exp $
+
+*sarg-2.3.3 (18 Dec 2012)
+
+ 18 Dec 2012; Jeroen Roovers <jer@gentoo.org> +sarg-2.3.3.ebuild,
+ metadata.xml:
+ Version bump.
17 Apr 2012; Jeroen Roovers <jer@gentoo.org> -sarg-2.3.1-r2.ebuild,
-files/sarg-2.3.1-underlinking.patch:
diff --git a/net-analyzer/sarg/metadata.xml b/net-analyzer/sarg/metadata.xml
index cc912433d83d..426edc634023 100644
--- a/net-analyzer/sarg/metadata.xml
+++ b/net-analyzer/sarg/metadata.xml
@@ -10,4 +10,8 @@
you to view "where" your users are going to on the Internet. Sarg provides many
informations about Squid users activities: times, bytes, sites, etc...
</longdescription>
+ <use>
+ <flag name="pcre">Enable support for regular expressions in the hostalias file through <pkg>dev-libs/libpcre</pkg></flag>
+ <flag name="gd">Enable support for graphs in reports through <pkg>media-libs/gd</pkg></flag>
+ </use>
</pkgmetadata>
diff --git a/net-analyzer/sarg/sarg-2.3.3.ebuild b/net-analyzer/sarg/sarg-2.3.3.ebuild
new file mode 100644
index 000000000000..48a4b358d9b7
--- /dev/null
+++ b/net-analyzer/sarg/sarg-2.3.3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sarg/sarg-2.3.3.ebuild,v 1.1 2012/12/18 21:39:26 jer Exp $
+
+EAPI=4
+inherit autotools eutils
+
+DESCRIPTION="Squid Analysis Report Generator"
+HOMEPAGE="http://sarg.sourceforge.net/sarg.php"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE="+gd pcre"
+
+DEPEND="
+ pcre? ( dev-libs/libpcre )
+ gd? ( media-libs/gd[png,truetype] )
+"
+RDEPEND="${DEPEND}"
+
+DOCS=( BETA-TESTERS CONTRIBUTORS DONATIONS README ChangeLog htaccess )
+
+src_prepare() {
+ sed -i configure.in -e '/LDFLAGS=/s:LDFLAGS:LIBS:g' || die
+
+ sed \
+ -e 's:/usr/local/squid/var/logs/access.log:/var/log/squid/access.log:' \
+ -e 's:/usr/local/\(squidGuard/squidGuard.conf\):/etc/\1:' \
+ -e 's:/var/www/html/squid-reports:/var/www/localhost/htdocs/squid-reports:' \
+ -e 's:/usr/local/sarg/exclude_codes:/etc/sarg/exclude_codes:' \
+ -i sarg.conf || die
+
+ sed -e 's:"/var/www/html/squid-reports":"/var/www/localhost/htdocs/squid-reports":' \
+ -i log.c || die #43132
+
+ sed -e 's:/usr/local/sarg/passwd:/etc/sarg/passwd:' \
+ -i htaccess || die
+
+ sed -e 's:/usr/local/\(sarg/sarg.conf\):/etc/\1:' \
+ -e 's:/usr/local/squid/etc/passwd:/etc/squid/passwd:' \
+ -i user_limit_block || die
+
+ sed -e 's:/usr/local/squid/etc/block.txt:/etc/squid/etc/block.txt:' \
+ -i sarg-php/sarg-block-it.php || die
+
+ sed -e 's:/usr/local/\(sarg/sarg.conf\):/etc/\1:' \
+ -e 's:/usr/local/\(squidGuard/squidGuard.conf\):/etc/\1:' \
+ -i sarg.1 sarg-php/sarg-squidguard-block.php || die
+
+ # https://sourceforge.net/tracker/?func=detail&aid=3415225&group_id=68910&atid=522793
+ sed 's:\(@mandir@\):\1/man1:' -i Makefile.in || die #379395
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with pcre) \
+ $(use_with gd) \
+ --sysconfdir=/etc/sarg/
+}