summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2008-06-16 14:42:53 +0000
committerHanno Böck <hanno@gentoo.org>2008-06-16 14:42:53 +0000
commite168f9066db3d0df6146c4dbbb3c5e9aa50d5fb1 (patch)
tree03266a70a4408eef78460bb20c488de3efebad5d /net-analyzer
parentFix repoman warnings, such as too long description and documentation. (diff)
downloadgentoo-2-e168f9066db3d0df6146c4dbbb3c5e9aa50d5fb1.tar.gz
gentoo-2-e168f9066db3d0df6146c4dbbb3c5e9aa50d5fb1.tar.bz2
gentoo-2-e168f9066db3d0df6146c4dbbb3c5e9aa50d5fb1.zip
openvas-plugins: fix openvas-nvt-sync
(Portage version: 2.1.5.5)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/openvas-plugins/ChangeLog8
-rw-r--r--net-analyzer/openvas-plugins/files/openvas-fix-nvt-sync.diff11
-rw-r--r--net-analyzer/openvas-plugins/openvas-plugins-1.0.1-r1.ebuild25
3 files changed, 43 insertions, 1 deletions
diff --git a/net-analyzer/openvas-plugins/ChangeLog b/net-analyzer/openvas-plugins/ChangeLog
index eb73e948daa8..3f0413438f56 100644
--- a/net-analyzer/openvas-plugins/ChangeLog
+++ b/net-analyzer/openvas-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/openvas-plugins
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/openvas-plugins/ChangeLog,v 1.2 2008/06/07 17:12:08 hanno Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/openvas-plugins/ChangeLog,v 1.3 2008/06/16 14:42:53 hanno Exp $
+
+*openvas-plugins-1.0.1-r1 (16 Jun 2008)
+
+ 16 Jun 2008; Hanno Boeck <hanno@gentoo.org>
+ +files/openvas-fix-nvt-sync.diff, +openvas-plugins-1.0.1-r1.ebuild:
+ Fix bogus creation of directory tree in openvas-nvt-sync.
*openvas-plugins-1.0.1 (07 Jun 2008)
diff --git a/net-analyzer/openvas-plugins/files/openvas-fix-nvt-sync.diff b/net-analyzer/openvas-plugins/files/openvas-fix-nvt-sync.diff
new file mode 100644
index 000000000000..dccae6d05b8e
--- /dev/null
+++ b/net-analyzer/openvas-plugins/files/openvas-fix-nvt-sync.diff
@@ -0,0 +1,11 @@
+--- openvas-plugins-1.0.1/openvas-nvt-sync.in.orig 2008-06-16 16:32:36.000000000 +0200
++++ openvas-plugins-1.0.1/openvas-nvt-sync.in 2008-06-16 16:32:44.000000000 +0200
+@@ -77,7 +77,7 @@
+ sync_nvts (){
+ echo "Synchonizing NVTs via RSYNC ..."
+
+- mkdir -p \"$NVT_DIR\"
++ mkdir -p "$NVT_DIR"
+ eval "rsync -avrP \"$FEED\" \"$NVT_DIR\""
+ if [ $? -ne 0 ] ; then
+ echo "Error: rsync failed. Your NVT collection might be broken now."
diff --git a/net-analyzer/openvas-plugins/openvas-plugins-1.0.1-r1.ebuild b/net-analyzer/openvas-plugins/openvas-plugins-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..001fd1dabd4e
--- /dev/null
+++ b/net-analyzer/openvas-plugins/openvas-plugins-1.0.1-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/openvas-plugins/openvas-plugins-1.0.1-r1.ebuild,v 1.1 2008/06/16 14:42:53 hanno Exp $
+
+inherit eutils
+
+DESCRIPTION="A remote security scanner for Linux (openvas-plugins)"
+HOMEPAGE="http://www.openvas.org/"
+SRC_URI="http://wald.intevation.org/frs/download.php/459/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND="net-analyzer/openvas-server"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/openvas-fix-nvt-sync.diff"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc docs/*.txt || die "dodoc failed"
+}