summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2012-12-01 17:15:54 +0000
committerJeroen Roovers <jer@gentoo.org>2012-12-01 17:15:54 +0000
commitc9b3a49060a3efe2caab6be2475b6cc4a3d60551 (patch)
tree6ecf0d915a997a7c6785c49aea89efe4bf5ecb90 /net-analyzer
parentrevbump, apply patch from #436148 (diff)
downloadgentoo-2-c9b3a49060a3efe2caab6be2475b6cc4a3d60551.tar.gz
gentoo-2-c9b3a49060a3efe2caab6be2475b6cc4a3d60551.tar.bz2
gentoo-2-c9b3a49060a3efe2caab6be2475b6cc4a3d60551.zip
Break up long lines. Clean up.
(Portage version: 2.2.0_alpha143/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nmap/ChangeLog5
-rw-r--r--net-analyzer/nmap/nmap-6.01.ebuild33
2 files changed, 27 insertions, 11 deletions
diff --git a/net-analyzer/nmap/ChangeLog b/net-analyzer/nmap/ChangeLog
index 21ca157c4494..58814391a720 100644
--- a/net-analyzer/nmap/ChangeLog
+++ b/net-analyzer/nmap/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-analyzer/nmap
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.258 2012/12/01 16:47:11 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.259 2012/12/01 17:15:54 jer Exp $
+
+ 01 Dec 2012; Jeroen Roovers <jer@gentoo.org> nmap-6.01.ebuild:
+ Break up long lines. Clean up.
01 Dec 2012; Jeroen Roovers <jer@gentoo.org> nmap-6.01.ebuild:
Fix python dependencies (bug #435462 by Alexander Zubkov).
diff --git a/net-analyzer/nmap/nmap-6.01.ebuild b/net-analyzer/nmap/nmap-6.01.ebuild
index 5615905825f5..a40432f4abd6 100644
--- a/net-analyzer/nmap/nmap-6.01.ebuild
+++ b/net-analyzer/nmap/nmap-6.01.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-6.01.ebuild,v 1.4 2012/12/01 16:47:11 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-6.01.ebuild,v 1.5 2012/12/01 17:15:54 jer Exp $
EAPI="4"
PYTHON_DEPEND="2"
@@ -60,31 +60,44 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-make.patch
# Fix desktop files wrt bug #432714
- sed -i -e '/^Encoding/d' zenmap/install_scripts/unix/zenmap.desktop
- sed -i -e '/^Encoding/d' zenmap/install_scripts/unix/zenmap-root.desktop
- sed -i -e 's/Categories=Application;Network;Security/Categories=Network;System;Security/' zenmap/install_scripts/unix/zenmap.desktop
- sed -i -e 's/Categories=Application;Network;Security/Categories=Network;System;Security/' zenmap/install_scripts/unix/zenmap-root.desktop
+ sed -i \
+ -e '/^Encoding/d' \
+ -e 's|^Categories=.*|Categories=Network;System;Security;|g' \
+ zenmap/install_scripts/unix/zenmap-root.desktop \
+ zenmap/install_scripts/unix/zenmap.desktop || die
}
src_configure() {
# The bundled libdnet is incompatible with the version available in the
# tree, so we cannot use the system library here.
- econf --with-libdnet=included \
+ econf \
$(use_with gtk zenmap) \
$(use_with lua liblua) \
$(use_with ncat) \
$(use_with ndiff) \
$(use_with nmap-update) \
$(use_with nping) \
- $(use_with ssl openssl)
+ $(use_with ssl openssl) \
+ --with-libdnet=included
}
src_install() {
- LC_ALL=C emake DESTDIR="${D}" -j1 STRIP=: nmapdatadir="${EPREFIX}"/usr/share/nmap install
+ LC_ALL=C emake \
+ -j1 \
+ DESTDIR="${D}" \
+ STRIP=: \
+ nmapdatadir="${EPREFIX}"/usr/share/nmap \
+ install
if use nmap-update;then
- LC_ALL=C emake DESTDIR="${D}" -j1 STRIP=: \
- nmapdatadir="${EPREFIX}"/usr/share/nmap -C nmap-update install
+ LC_ALL=C emake \
+ -C nmap-update \
+ -j1 \
+ DESTDIR="${D}" \
+ STRIP=: \
+ nmapdatadir="${EPREFIX}"/usr/share/nmap \
+ install
fi
+
dodoc CHANGELOG HACKING docs/README docs/*.txt
use gtk && doicon "${FILESDIR}/nmap-logo-64.png"