summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Ruppert <idl0r@gentoo.org>2013-12-03 23:16:35 +0000
committerChristian Ruppert <idl0r@gentoo.org>2013-12-03 23:16:35 +0000
commitbf55c7ee38ebaf9a7db3bb8dc559f86d405fe472 (patch)
treee450a401ff888b5411f59ab88cab0445eca1b965 /net-analyzer
parentAdd new version. Fix console compilation error. (diff)
downloadgentoo-2-bf55c7ee38ebaf9a7db3bb8dc559f86d405fe472.tar.gz
gentoo-2-bf55c7ee38ebaf9a7db3bb8dc559f86d405fe472.tar.bz2
gentoo-2-bf55c7ee38ebaf9a7db3bb8dc559f86d405fe472.zip
Version bump. Cleanup. Bug 482026, thanks to Bertrand Jacquin <beber@meleeweb.net>
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key B427ABC8)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/mk-livestatus/ChangeLog14
-rw-r--r--net-analyzer/mk-livestatus/files/gcc-4.7-compile.patch11
-rw-r--r--net-analyzer/mk-livestatus/files/mk-livestatus-1.2.2_p2-no-strip.diff23
-rw-r--r--net-analyzer/mk-livestatus/files/mk-livestatus-1.2.2_p2-test-RequireRcsKeywords.diff18
-rw-r--r--net-analyzer/mk-livestatus/mk-livestatus-1.1.8.ebuild107
-rw-r--r--net-analyzer/mk-livestatus/mk-livestatus-1.2.2_p2.ebuild (renamed from net-analyzer/mk-livestatus/mk-livestatus-1.1.10_p1.ebuild)66
6 files changed, 92 insertions, 147 deletions
diff --git a/net-analyzer/mk-livestatus/ChangeLog b/net-analyzer/mk-livestatus/ChangeLog
index cd3f7bbd3ce6..8f95a0805c58 100644
--- a/net-analyzer/mk-livestatus/ChangeLog
+++ b/net-analyzer/mk-livestatus/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for net-analyzer/mk-livestatus
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mk-livestatus/ChangeLog,v 1.6 2012/12/22 18:24:19 ago Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mk-livestatus/ChangeLog,v 1.7 2013/12/03 23:16:35 idl0r Exp $
+
+*mk-livestatus-1.2.2_p2 (03 Dec 2013)
+
+ 03 Dec 2013; Christian Ruppert <idl0r@gentoo.org>
+ -mk-livestatus-1.1.8.ebuild, -mk-livestatus-1.1.10_p1.ebuild,
+ +mk-livestatus-1.2.2_p2.ebuild, +files/mk-livestatus-1.2.2_p2-no-strip.diff,
+ +files/mk-livestatus-1.2.2_p2-test-RequireRcsKeywords.diff,
+ -files/gcc-4.7-compile.patch:
+ Version bump. Cleanup. Bug 482026, thanks to Bertrand Jacquin
+ <beber@meleeweb.net>
22 Dec 2012; Agostino Sarubbo <ago@gentoo.org> mk-livestatus-1.2.0_p2.ebuild:
Add ~ppc, wrt bug #429088
diff --git a/net-analyzer/mk-livestatus/files/gcc-4.7-compile.patch b/net-analyzer/mk-livestatus/files/gcc-4.7-compile.patch
deleted file mode 100644
index 186f610109f6..000000000000
--- a/net-analyzer/mk-livestatus/files/gcc-4.7-compile.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/TableLog.cc.orig 2012-07-07 19:52:47.171651476 +0200
-+++ src/TableLog.cc 2012-07-07 19:53:20.291525974 +0200
-@@ -41,6 +41,8 @@
- #include "TableCommands.h"
- #include "TableContacts.h"
-
-+#include <cstddef>
-+
- #define CHECK_MEM_CYCLE 1000 /* Check memory every N'th new message */
-
- // watch nagios' logfile rotation
diff --git a/net-analyzer/mk-livestatus/files/mk-livestatus-1.2.2_p2-no-strip.diff b/net-analyzer/mk-livestatus/files/mk-livestatus-1.2.2_p2-no-strip.diff
new file mode 100644
index 000000000000..a3f81a5054cb
--- /dev/null
+++ b/net-analyzer/mk-livestatus/files/mk-livestatus-1.2.2_p2-no-strip.diff
@@ -0,0 +1,23 @@
+--- src/Makefile.am 2013-08-20 14:24:46.000000000 +0200
++++ src/Makefile.am 2013-08-20 14:25:20.000000000 +0200
+@@ -54,9 +54,9 @@
+
+ livecheck$(EXEEXT): livecheck.c strutil.c check_icmp.c
+ if HAVE_DIET
+- diet -v $(CC) -Wno-deprecated-declarations $(CFLAGS) $(LDFLAGS) -I.. -s -o $@ $^
++ diet -v $(CC) -Wno-deprecated-declarations $(CFLAGS) $(LDFLAGS) -I.. -o $@ $^
+ else
+- $(CC) -x c -Wno-deprecated-declarations $(CFLAGS) $(LDFLAGS) -I.. -s -o $@ $^
++ $(CC) -x c -Wno-deprecated-declarations $(CFLAGS) $(LDFLAGS) -I.. -o $@ $^
+ endif
+
+ livestatus_so_CXXFLAGS = -I$(top_srcdir)/nagios -fPIC
+@@ -64,7 +64,7 @@
+
+ livestatus.o: $(livestatus_so_OBJECTS) $(livestatus_so_DEPENDENCIES)
+ -rm -f plugin.so
+- $(CXX) $(LDFLAGS) -s -fPIC -shared $(livestatus_so_OBJECTS) -o $@ -lpthread -lstdc++
++ $(CXX) $(LDFLAGS) -fPIC -shared $(livestatus_so_OBJECTS) -o $@ -lpthread -lstdc++
+
+ all-local: livestatus.o
+
diff --git a/net-analyzer/mk-livestatus/files/mk-livestatus-1.2.2_p2-test-RequireRcsKeywords.diff b/net-analyzer/mk-livestatus/files/mk-livestatus-1.2.2_p2-test-RequireRcsKeywords.diff
new file mode 100644
index 000000000000..95b2830feccf
--- /dev/null
+++ b/net-analyzer/mk-livestatus/files/mk-livestatus-1.2.2_p2-test-RequireRcsKeywords.diff
@@ -0,0 +1,18 @@
+--- ./api/perl/t/perlcriticrc 2013-08-21 22:37:57.791099241 +0200
++++ ./api/perl/t/perlcriticrc 2013-08-21 22:38:02.943210061 +0200
+@@ -133,8 +133,6 @@ severity = 3
+ [Perl::Critic::Policy::Miscellanea::ProhibitTies]
+ severity = 4
+
+-[-Perl::Critic::Policy::Miscellanea::RequireRcsKeywords]
+-
+ [Perl::Critic::Policy::Modules::ProhibitAutomaticExportation]
+ severity = 4
+
+@@ -283,4 +281,4 @@ severity = 5
+ severity = 5
+
+ [Perl::Critic::Policy::Variables::RequireNegativeIndices]
+-severity = 4
+\ No newline at end of file
++severity = 4
diff --git a/net-analyzer/mk-livestatus/mk-livestatus-1.1.8.ebuild b/net-analyzer/mk-livestatus/mk-livestatus-1.1.8.ebuild
deleted file mode 100644
index 586f0260a751..000000000000
--- a/net-analyzer/mk-livestatus/mk-livestatus-1.1.8.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mk-livestatus/mk-livestatus-1.1.8.ebuild,v 1.3 2011/04/27 13:50:15 idl0r Exp $
-
-EAPI=3
-
-GENTOO_DEPEND_ON_PERL=no
-PERL_EXPORT_PHASE_FUNCTIONS=no
-
-inherit perl-module python
-
-DESCRIPTION="Nagios/Icinga event broker module that allows quick/direct access to your status data"
-HOMEPAGE="http://mathias-kettner.de/checkmk_livestatus.html"
-SRC_URI="http://mathias-kettner.de/download/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples perl python test"
-
-RDEPEND="perl? (
- dev-lang/perl
- virtual/perl-Digest-MD5
- virtual/perl-Thread-Queue
- )"
-DEPEND="${RDEPEND}
- perl? (
- dev-perl/Module-Install
- test? (
- dev-perl/File-Copy-Recursive
- dev-perl/Test-Pod
- dev-perl/Test-Perl-Critic
- dev-perl/Test-Pod-Coverage
- dev-perl/Perl-Critic
- dev-perl/Perl-Critic-Policy-Dynamic-NoIndirect
- dev-perl/Perl-Critic-Deprecated
- dev-perl/Perl-Critic-Nits
- )
- )"
-
-# For perl test
-SRC_TEST="parallel"
-
-src_prepare() {
- # Use system Module::Install instead, it will be copied to $S by
- # Module::install itself.
- rm -rf api/perl/inc
-
- if use perl; then
- perl-module_src_prepare
- fi
-
- sed -i -e 's:$(LDFLAGS) -s:$(LDFLAGS):' src/Makefile.in || die
-}
-
-src_configure() {
- econf
-
- if use perl; then
- cd api/perl/
- perl-module_src_configure
- fi
-}
-
-src_compile() {
- emake || die
-
- if use perl; then
- cd api/perl
- perl-module_src_compile
- fi
-}
-
-src_test() {
- if use perl; then
- cd api/perl
-
- export TEST_AUTHOR="Test Author"
- perl-module_src_test
- fi
-}
-
-src_install() {
- emake -C src/ DESTDIR="${D}" install-binPROGRAMS install-data-local || die
-
- if use perl; then
- cd api/perl
- perl-module_src_install
- cd "${S}"
-
- if use examples; then
- docinto examples/
- dodoc api/perl/examples/dump.pl || die
- fi
- fi
- if use python; then
- insinto $(python_get_sitedir)
- doins api/python/livestatus.py || die
-
- if use examples; then
- newdoc api/python/README README.python || die
-
- docinto examples/
- dodoc api/python/{example,example_multisite,make_nagvis_map}.py || die
- fi
- fi
-}
diff --git a/net-analyzer/mk-livestatus/mk-livestatus-1.1.10_p1.ebuild b/net-analyzer/mk-livestatus/mk-livestatus-1.2.2_p2.ebuild
index 91c7f4a26376..6d6e53b36763 100644
--- a/net-analyzer/mk-livestatus/mk-livestatus-1.1.10_p1.ebuild
+++ b/net-analyzer/mk-livestatus/mk-livestatus-1.2.2_p2.ebuild
@@ -1,43 +1,51 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mk-livestatus/mk-livestatus-1.1.10_p1.ebuild,v 1.2 2012/09/03 18:48:33 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/mk-livestatus/mk-livestatus-1.2.2_p2.ebuild,v 1.1 2013/12/03 23:16:35 idl0r Exp $
-EAPI=3
+EAPI=5
GENTOO_DEPEND_ON_PERL=no
PERL_EXPORT_PHASE_FUNCTIONS=no
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit autotools perl-module python-r1 eutils
MY_PV="${PV/_p/p}"
MY_P="${PN}-${MY_PV}"
-inherit perl-module python eutils
-
DESCRIPTION="Nagios/Icinga event broker module that allows quick/direct access to your status data"
HOMEPAGE="http://mathias-kettner.de/checkmk_livestatus.html"
SRC_URI="http://mathias-kettner.de/download/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE="examples perl python test"
RDEPEND="perl? (
- dev-lang/perl
- virtual/perl-Digest-MD5
- virtual/perl-Thread-Queue
+ dev-lang/perl:0
+ virtual/perl-Digest-MD5:0
+ virtual/perl-Scalar-List-Utils:0
+ >=virtual/perl-Thread-Queue-2.11:0
+ virtual/perl-Encode:0
+ dev-perl/JSON-XS:0
)"
DEPEND="${RDEPEND}
perl? (
- dev-perl/Module-Install
+ dev-perl/Module-Install:0
+ virtual/perl-ExtUtils-MakeMaker:0
+ virtual/perl-File-Path:0
+ virtual/perl-File-Spec:0
+ virtual/perl-File-Temp:0
test? (
- dev-perl/File-Copy-Recursive
- dev-perl/Test-Pod
- dev-perl/Test-Perl-Critic
- dev-perl/Test-Pod-Coverage
- dev-perl/Perl-Critic
- dev-perl/Perl-Critic-Policy-Dynamic-NoIndirect
- dev-perl/Perl-Critic-Deprecated
- dev-perl/Perl-Critic-Nits
+ dev-perl/File-Copy-Recursive:0
+ dev-perl/Test-Pod:0
+ dev-perl/Test-Perl-Critic:0
+ dev-perl/Test-Pod-Coverage:0
+ dev-perl/Perl-Critic:0
+ dev-perl/Perl-Critic-Policy-Dynamic-NoIndirect:0
+ dev-perl/Perl-Critic-Deprecated:0
+ dev-perl/Perl-Critic-Nits:0
)
)"
@@ -55,9 +63,13 @@ src_prepare() {
perl-module_src_prepare
fi
- sed -i -e 's:$(LDFLAGS) -s:$(LDFLAGS):' src/Makefile.in || die
+ epatch "${FILESDIR}/${P}-no-strip.diff"
+ epatch "${FILESDIR}/${P}-test-RequireRcsKeywords.diff"
- epatch "${FILESDIR}/gcc-4.7-compile.patch"
+ # Script too old
+ rm -f missing
+
+ eautoreconf
}
src_configure() {
@@ -70,7 +82,7 @@ src_configure() {
}
src_compile() {
- emake || die
+ emake
if use perl; then
cd api/perl
@@ -88,7 +100,7 @@ src_test() {
}
src_install() {
- emake -C src/ DESTDIR="${D}" install-binPROGRAMS install-data-local || die
+ emake -C src/ DESTDIR="${ED}" install-binPROGRAMS install-data-local
if use perl; then
cd api/perl
@@ -97,18 +109,18 @@ src_install() {
if use examples; then
docinto examples/
- dodoc api/perl/examples/dump.pl || die
+ dodoc api/perl/examples/dump.pl
fi
fi
+
if use python; then
- insinto $(python_get_sitedir)
- doins api/python/livestatus.py || die
+ python_foreach_impl python_domodule api/python/livestatus.py
if use examples; then
- newdoc api/python/README README.python || die
+ newdoc api/python/README README.python
docinto examples/
- dodoc api/python/{example,example_multisite,make_nagvis_map}.py || die
+ dodoc api/python/{example,example_multisite,make_nagvis_map}.py
fi
fi
}