summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-10-14 07:23:04 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-10-14 07:23:04 +0000
commitb4e25de8bfcb2aebe4415d8c20acdd5b55c4b451 (patch)
tree30fc9f9f444f825a94a7537b5377bf1a665d76e2 /net-analyzer
parenttypo fix (diff)
downloadgentoo-2-b4e25de8bfcb2aebe4415d8c20acdd5b55c4b451.tar.gz
gentoo-2-b4e25de8bfcb2aebe4415d8c20acdd5b55c4b451.tar.bz2
gentoo-2-b4e25de8bfcb2aebe4415d8c20acdd5b55c4b451.zip
Security update.
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/net-snmp/ChangeLog7
-rw-r--r--net-analyzer/net-snmp/files/digest-net-snmp-5.0.61
-rw-r--r--net-analyzer/net-snmp/files/net-snmp-5.0.6-gentoo.diff27
-rw-r--r--net-analyzer/net-snmp/net-snmp-5.0.6.ebuild72
4 files changed, 106 insertions, 1 deletions
diff --git a/net-analyzer/net-snmp/ChangeLog b/net-analyzer/net-snmp/ChangeLog
index 5b2e9c49a47b..10ce4616f44c 100644
--- a/net-analyzer/net-snmp/ChangeLog
+++ b/net-analyzer/net-snmp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/net-snmp
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/ChangeLog,v 1.4 2002/09/28 19:02:56 owen Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/ChangeLog,v 1.5 2002/10/14 07:23:04 aliz Exp $
+
+*net-snmp-5.0.6 (14 Oct 2002)
+
+ 14 Oct 2002; Daniel Ahlberg <aliz@gentoo.org> :
+ Security update. Added patch to fix compilation with libwrap.
*net-snmp-5.0.2a-r1 (4 Aug 2002)
diff --git a/net-analyzer/net-snmp/files/digest-net-snmp-5.0.6 b/net-analyzer/net-snmp/files/digest-net-snmp-5.0.6
new file mode 100644
index 000000000000..c9b5cd8a5311
--- /dev/null
+++ b/net-analyzer/net-snmp/files/digest-net-snmp-5.0.6
@@ -0,0 +1 @@
+MD5 8c67aae0d7d8fa00625361cece1a2138 net-snmp-5.0.6.tar.gz 2209625
diff --git a/net-analyzer/net-snmp/files/net-snmp-5.0.6-gentoo.diff b/net-analyzer/net-snmp/files/net-snmp-5.0.6-gentoo.diff
new file mode 100644
index 000000000000..9a14dcb642e6
--- /dev/null
+++ b/net-analyzer/net-snmp/files/net-snmp-5.0.6-gentoo.diff
@@ -0,0 +1,27 @@
+diff -Naur net-snmp-5.0.5.orig/agent/snmp_agent.c net-snmp-5.0.5/agent/snmp_agent.c
+--- net-snmp-5.0.5.orig/agent/snmp_agent.c Tue Oct 1 04:18:12 2002
++++ net-snmp-5.0.5/agent/snmp_agent.c Wed Oct 2 20:10:14 2002
+@@ -71,6 +71,9 @@
+
+ #ifdef USE_LIBWRAP
+ #include <tcpd.h>
++#ifdef HAVE_SYSLOG_H
++#include <syslog.h>
++#endif
+ int allow_severity = LOG_INFO;
+ int deny_severity = LOG_WARNING;
+ #endif
+diff -Naur net-snmp-5.0.5.orig/apps/snmptrapd.c net-snmp-5.0.5/apps/snmptrapd.c
+--- net-snmp-5.0.5.orig/apps/snmptrapd.c Thu Sep 12 08:24:50 2002
++++ net-snmp-5.0.5/apps/snmptrapd.c Wed Oct 2 20:10:05 2002
+@@ -99,8 +99,10 @@
+ #if USE_LIBWRAP
+ #include <tcpd.h>
+
++/*
+ int allow_severity = LOG_INFO;
+ int deny_severity = LOG_WARNING;
++*/
+ #endif
+
+ #define NETSNMP_DS_APP_NUMERIC_IP 8 /* must not conflict with agent's DS booleans */
diff --git a/net-analyzer/net-snmp/net-snmp-5.0.6.ebuild b/net-analyzer/net-snmp/net-snmp-5.0.6.ebuild
new file mode 100644
index 000000000000..aa6383ee39a4
--- /dev/null
+++ b/net-analyzer/net-snmp/net-snmp-5.0.6.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/net-snmp/net-snmp-5.0.6.ebuild,v 1.1 2002/10/14 07:23:04 aliz Exp $
+
+IUSE="ssl kerberos ipv6 tcpd"
+
+S=${WORKDIR}/${P%[a-z]}
+DESCRIPTION="Software for generating and retrieving SNMP data"
+SRC_URI="mirror://sourceforge/net-snmp/${P}.tar.gz"
+HOMEPAGE="http://net-snmp.sourceforge.net/"
+
+DEPEND="virtual/glibc <sys-libs/db-2
+ >=sys-libs/zlib-1.1.4
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ ssl? ( >=dev-libs/openssl-0.9.6d )
+ kerberos? ( >=app-crypt/krb5-1.2.5 )"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="x86 ppc sparc sparc64"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ patch -p1 < ${FILESDIR}/${PF}-gentoo.diff
+}
+
+src_compile() {
+ local myconf disable_sec_services
+
+ use ssl || myconf="${myconf} --enable-internal-md5 --with-openssl=no"
+ use tcpd && myconf="${myconf} --with-libwrap" || myconf="${myconf} --with-libwrap=no"
+ use ipv6 && myconf="${myconf} --enable-ipv6" || myconf="${myconf} --disable-ipv6"
+ # Doesn't seem that emerge passes the escaped double quotes properly -- nitro
+ #use ipv6 || myconf="${myconf} --with-out-transports=\"TCPIPv6 UDPIPv6\""
+ use kerberos && myconf="${myconf} --with-security-modules=\"usm ksm\""
+
+ econf \
+ --with-cflags="${CFLAGS}" \
+ --host="${CHOST}" \
+ --with-zlib \
+ --enable-shared \
+ --with-sys-location="Unknown" \
+ --with-sys-contact="root@Unknown" \
+ --with-default-snmp-version="3" \
+ --with-logfile=/var/log/net-snmpd.log \
+ --with-persistent-directory=/var/lib/net-snmp \
+ --with-mib-modules=host \
+ ${myconf} || die "bad ./configure"
+
+ # Parallel make doesn't work.
+ make || die "compile problem"
+}
+
+src_install () {
+
+ einstall exec_prefix=${D}/usr \
+ persistentdir=${D}/var/lib/net-snmp || die
+
+ dodir /var/lib/net-snmp
+
+ dodoc AGENT.txt ChangeLog FAQ INSTALL NEWS PORTING README* TODO EXAMPLE.conf.def
+
+ # Close bug #5882:
+ rm -f ${D}/usr/bin/snmptrap
+ dosym /usr/bin/snmptrap /usr/bin/snmpinform
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/net-snmpd.rc6 net-snmpd
+}