summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Koltsov <maksbotan@gentoo.org>2012-06-02 14:13:16 +0000
committerMaxim Koltsov <maksbotan@gentoo.org>2012-06-02 14:13:16 +0000
commitb06275c917915bafc8d125d582f7b95811599680 (patch)
tree71a4e5027c1e2b1bb6d186efd043829df942d2a5 /net-analyzer
parentkeyword ~amd64-fbsd (diff)
downloadgentoo-2-b06275c917915bafc8d125d582f7b95811599680.tar.gz
gentoo-2-b06275c917915bafc8d125d582f7b95811599680.tar.bz2
gentoo-2-b06275c917915bafc8d125d582f7b95811599680.zip
Bump to 1.4.7, fix bugs 405431, 324093 and 416259. Thanks to Andreis Vinogradovs
(Portage version: 2.1.10.63/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/rrdtool/ChangeLog9
-rw-r--r--net-analyzer/rrdtool/files/0001_rrdtool-1.4.7-configure.ac.patch22
-rw-r--r--net-analyzer/rrdtool/rrdtool-1.4.7.ebuild142
3 files changed, 172 insertions, 1 deletions
diff --git a/net-analyzer/rrdtool/ChangeLog b/net-analyzer/rrdtool/ChangeLog
index df3f760cfb98..376f50b9b082 100644
--- a/net-analyzer/rrdtool/ChangeLog
+++ b/net-analyzer/rrdtool/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/rrdtool
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.225 2012/05/04 06:08:08 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/ChangeLog,v 1.226 2012/06/02 14:13:16 maksbotan Exp $
+
+*rrdtool-1.4.7 (02 Jun 2012)
+
+ 02 Jun 2012; Maxim Koltsov <maksbotan@gentoo.org>
+ +files/0001_rrdtool-1.4.7-configure.ac.patch, +rrdtool-1.4.7.ebuild:
+ Bump to 1.4.7, fix bugs 405431, 324093 and 416259. Thanks to Andreis
+ Vinogradovs
04 May 2012; Jeff Horelick <jdhore@gentoo.org> rrdtool-1.4.5-r1.ebuild,
rrdtool-1.4.5-r2.ebuild:
diff --git a/net-analyzer/rrdtool/files/0001_rrdtool-1.4.7-configure.ac.patch b/net-analyzer/rrdtool/files/0001_rrdtool-1.4.7-configure.ac.patch
new file mode 100644
index 000000000000..ad97bec2defa
--- /dev/null
+++ b/net-analyzer/rrdtool/files/0001_rrdtool-1.4.7-configure.ac.patch
@@ -0,0 +1,22 @@
+diff --git a/configure.ac b/configure.ac
+--- a/configure.ac
++++ b/configure.ac
+@@ -148,7 +148,7 @@
+ AC_PROG_CPP
+ AC_PROG_CC
+ AM_PROG_CC_C_O
+-AC_PROG_LIBTOOL
++LT_INIT
+
+ dnl Try to detect/use GNU features
+ CFLAGS="$CFLAGS -D_GNU_SOURCE"
+@@ -204,9 +204,6 @@
+ AC_CHECK_FUNC(acos, , AC_CHECK_LIB(m, acos))
+
+
+-dnl add pic flag in any case this makes sure all our code is relocatable
+-eval `./libtool --config | grep pic_flag=`
+-CFLAGS="$CFLAGS $pic_flag"
+
+
+ dnl Checks for library functions.
diff --git a/net-analyzer/rrdtool/rrdtool-1.4.7.ebuild b/net-analyzer/rrdtool/rrdtool-1.4.7.ebuild
new file mode 100644
index 000000000000..8d123e15faa5
--- /dev/null
+++ b/net-analyzer/rrdtool/rrdtool-1.4.7.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/rrdtool/rrdtool-1.4.7.ebuild,v 1.1 2012/06/02 14:13:16 maksbotan Exp $
+
+EAPI="4"
+
+GENTOO_DEPEND_ON_PERL="no"
+PYTHON_DEPEND="python? 2"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit eutils distutils flag-o-matic multilib perl-module autotools
+
+DESCRIPTION="A system to store and display time-series data"
+HOMEPAGE="http://oss.oetiker.ch/rrdtool/"
+SRC_URI="http://oss.oetiker.ch/rrdtool/pub/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos ~x86-solaris"
+IUSE="dbi doc lua perl python ruby rrdcgi tcl tcpd"
+
+# This versions are minimal versions upstream tested with.
+RDEPEND="
+ >=media-libs/libpng-1.5.10
+ >=dev-libs/libxml2-2.7.8
+ >=x11-libs/cairo-1.10.2[svg]
+ >=dev-libs/glib-2.28.7
+ >=x11-libs/pango-1.28
+ lua? ( dev-lang/lua[deprecated] )
+ perl? ( dev-lang/perl )
+ ruby? ( >=dev-lang/ruby-1.8.6_p287-r13 )
+ tcl? ( dev-lang/tcl )
+ tcpd? ( sys-apps/tcp-wrappers )
+ dbi? ( dev-db/libdbi )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ sys-apps/gawk"
+
+DISTUTILS_SETUP_FILES=("bindings/python|setup.py")
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/0001_"${P}"-configure.ac.patch
+ epatch "${FILESDIR}/${PN}"-1.4.5-automake-1.11.2.patch
+ sed -i '/PERLLD/s:same as PERLCC:same-as-PERLCC:' configure.ac #281694
+
+ # Python bindings are built/installed manually
+ sed -e "/^all-local:/s/ @COMP_PYTHON@//" -i bindings/Makefile.am
+
+ eautoreconf
+}
+
+src_configure() {
+ filter-flags -ffast-math
+
+ export RRDDOCDIR=${EPREFIX}/usr/share/doc/${PF}
+
+ # to solve bug #260380
+ [[ ${CHOST} == *-solaris* ]] && append-flags -D__EXTENSIONS__
+
+ # Stub configure.ac
+ local myconf=()
+ if ! use tcpd; then
+ myconf+="--disable-libwrap"
+ fi
+ if ! use dbi; then
+ myconf+="--disable-libdbi"
+ fi
+
+ econf \
+ --disable-static \
+ $(use_enable rrdcgi) \
+ $(use_enable lua) \
+ $(use_enable lua lua-site-install) \
+ $(use_enable ruby) \
+ $(use_enable ruby ruby-site-install) \
+ $(use_enable perl) \
+ $(use_enable perl perl-site-install) \
+ --with-perl-options=INSTALLDIRS=vendor \
+ $(use_enable tcl) \
+ $(use_with tcl tcllib "${EPREFIX}"/usr/$(get_libdir)) \
+ $(use_enable python) \
+ ${myconf[@]}
+}
+
+src_compile() {
+ default
+
+ use python && distutils_src_compile
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ if ! use doc ; then
+ rm -rf "${ED}"usr/share/doc/${PF}/{html,txt}
+ fi
+
+ if use !rrdcgi ; then
+ # uses rrdcgi, causes invalid shebang error in Prefix, useless
+ # without rrdcgi installed
+ rm -f "${ED}"usr/share/${PN}/examples/cgi-demo.cgi
+ fi
+
+ if use perl ; then
+ perl_delete_localpod
+ perl_delete_packlist
+ fi
+
+ use python && distutils_src_install
+
+ dodoc CHANGES CONTRIBUTORS NEWS README THREADS TODO
+
+ find "${ED}"usr -name '*.la' -exec rm -f {} +
+}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+
+ ewarn "Since version 1.3, rrdtool dump emits completely legal xml. Basically this"
+ ewarn "means that it contains an xml header and a DOCTYPE definition. Unfortunately"
+ ewarn "this causes older versions of rrdtool restore to be unhappy."
+ ewarn
+ ewarn "To restore a new dump with an old rrdtool restore version, either remove"
+ ewarn "the xml header and the doctype by hand (both on the first line of the dump)"
+ ewarn "or use rrdtool dump --no-header."
+ ewarn
+ ewarn ">=net-analyzer/rrdtool-1.3 does not have any default font bundled. Thus if"
+ ewarn ">you've upgraded from rrdtool-1.2.x and don't have any font installed to make"
+ ewarn ">lables visible, please, install some font, e.g. media-fonts/dejavu."
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}