summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarcelo Góes <vanquirius@gentoo.org>2007-02-03 23:59:28 +0000
committerMarcelo Góes <vanquirius@gentoo.org>2007-02-03 23:59:28 +0000
commit94fbd0c332514100e72d67d4e6554d437abcad7f (patch)
tree1960bd94980b9ccd8b9de4a3fcf6dedb5fe0c024 /net-analyzer
parentAdd a patch to fix graphviz display of call graphs, thanks to Albert Astals C... (diff)
downloadgentoo-2-94fbd0c332514100e72d67d4e6554d437abcad7f.tar.gz
gentoo-2-94fbd0c332514100e72d67d4e6554d437abcad7f.tar.bz2
gentoo-2-94fbd0c332514100e72d67d4e6554d437abcad7f.zip
0.99.5 version bump for bug 165077
(Portage version: 2.1.1-r2)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/wireshark/ChangeLog11
-rw-r--r--net-analyzer/wireshark/files/digest-wireshark-0.99.53
-rw-r--r--net-analyzer/wireshark/wireshark-0.99.5.ebuild136
3 files changed, 148 insertions, 2 deletions
diff --git a/net-analyzer/wireshark/ChangeLog b/net-analyzer/wireshark/ChangeLog
index 0ae0519171f9..1934e67d6f7e 100644
--- a/net-analyzer/wireshark/ChangeLog
+++ b/net-analyzer/wireshark/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/wireshark
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.43 2006/11/16 14:48:49 uberlord Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/ChangeLog,v 1.44 2007/02/03 23:59:28 vanquirius Exp $
+
+*wireshark-0.99.5 (03 Feb 2007)
+
+ 03 Feb 2007; Marcelo Goes <vanquirius@gentoo.org>
+ +wireshark-0.99.5.ebuild:
+ 0.99.5 version bump for bug 165077, reported by Executioner <executioner at
+ phobik dot org>.
16 Nov 2006; Roy Marples <uberlord@gentoo.org> wireshark-0.99.4.ebuild,
wireshark-0.99.4-r1.ebuild:
diff --git a/net-analyzer/wireshark/files/digest-wireshark-0.99.5 b/net-analyzer/wireshark/files/digest-wireshark-0.99.5
new file mode 100644
index 000000000000..aa4590b38fe7
--- /dev/null
+++ b/net-analyzer/wireshark/files/digest-wireshark-0.99.5
@@ -0,0 +1,3 @@
+MD5 ff067e0f2a0e0e53362bc6a943ff8622 wireshark-0.99.5.tar.bz2 11007039
+RMD160 1b3f7bb8e2c73a945fff86fb8ab2aa79481ba809 wireshark-0.99.5.tar.bz2 11007039
+SHA256 9801c0c974a646606c56935dfd1aa503c9b007c76a3f1709f69ba038daf5860e wireshark-0.99.5.tar.bz2 11007039
diff --git a/net-analyzer/wireshark/wireshark-0.99.5.ebuild b/net-analyzer/wireshark/wireshark-0.99.5.ebuild
new file mode 100644
index 000000000000..e808b72f82ad
--- /dev/null
+++ b/net-analyzer/wireshark/wireshark-0.99.5.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/wireshark/wireshark-0.99.5.ebuild,v 1.1 2007/02/03 23:59:28 vanquirius Exp $
+
+inherit libtool flag-o-matic eutils autotools
+
+DESCRIPTION="A network protocol analyzer formerly known as ethereal"
+HOMEPAGE="http://www.wireshark.org/"
+#SRC_URI="http://www.wireshark.org/download/src/${MY_P}.tar.bz2"
+SRC_URI="mirror://sourceforge/wireshark/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="adns gtk ipv6 portaudio snmp ssl kerberos threads selinux"
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+ snmp? ( >=net-analyzer/net-snmp-5.1.1 )
+ gtk? ( >=dev-libs/glib-2.0.4
+ =x11-libs/gtk+-2*
+ x11-libs/pango
+ dev-libs/atk )
+ !gtk? ( =dev-libs/glib-1.2* )
+ ssl? ( >=dev-libs/openssl-0.9.6e )
+ !ssl? ( net-libs/gnutls )
+ net-libs/libpcap
+ >=dev-libs/libpcre-4.2
+ adns? ( net-libs/adns )
+ kerberos? ( virtual/krb5 )
+ portaudio? ( media-libs/portaudio )
+ selinux? ( sec-policy/selinux-wireshark )"
+# lua fails with version 5.0 and 5.1 is not in portage yet - 2006-04-25
+# lua? ( >=dev-lang/lua-5.1 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.15.0
+ dev-lang/perl
+ sys-devel/bison
+ sys-devel/flex
+ sys-apps/sed"
+
+pkg_setup() {
+ # bug 119208
+ if has_version "<=dev-lang/perl-5.8.8_rc1" && built_with_use dev-lang/perl minimal ; then
+ ewarn "wireshark will not build if dev-lang/perl is compiled with"
+ ewarn "USE=minimal. Rebuild dev-lang/perl with USE=-minimal and try again."
+ ebeep 5
+ die "dev-lang/perl compiled with USE=minimal"
+ fi
+
+ if ! use gtk; then
+ ewarn "USE=-gtk will mean no gui called wireshark will be created and"
+ ewarn "only command line utils are available"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"/epan
+ epatch "${FILESDIR}"/wireshark-except-double-free.diff
+}
+
+src_compile() {
+ replace-flags -O? -O
+ filter-flags -fstack-protector # see bug #133092
+
+ local myconf
+
+ if use gtk; then
+ einfo "Building with gtk support"
+ else
+ einfo "Building without gtk support"
+ myconf="${myconf} --disable-wireshark"
+ # the asn1 plugin needs gtk
+ sed -i -e '/plugins.asn1/d' Makefile.in || die "sed failed"
+ sed -i -e '/^SUBDIRS/s/asn1//' plugins/Makefile.in || die "sed failed"
+ fi
+
+ # $(use_with lua) \
+ econf $(use_with ssl) \
+ $(use_enable ipv6) \
+ $(use_with adns) \
+ $(use_with kerberos krb5) \
+ $(use_with snmp net-snmp) \
+ $(use_with portaudio) \
+ $(use_enable gtk gtk2) \
+ $(use_enable threads) \
+ --without-ucd-snmp \
+ --enable-dftest \
+ --enable-randpkt \
+ --sysconfdir=/etc/wireshark \
+ --enable-editcap \
+ --enable-capinfos \
+ --enable-text2pcap \
+ --enable-dftest \
+ --enable-randpkt \
+ ${myconf} || die "econf failed"
+
+ # fixes an access violation caused by libnetsnmp - see bug 79068
+ use snmp && export MIBDIRS="${D}/usr/share/snmp/mibs"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ insinto /usr/include/wiretap
+ doins wiretap/wtap.h
+
+ dodoc AUTHORS ChangeLog NEWS README*
+
+ insinto /usr/share/icons/hicolor/16x16/apps
+ newins "${S}"/image/hi16-app-wireshark.png wireshark.png
+ insinto /usr/share/icons/hicolor/32x32/apps
+ newins "${S}"/image/hi32-app-wireshark.png wireshark.png
+ insinto /usr/share/icons/hicolor/48x48/apps
+ newins "${S}"/image/hi48-app-wireshark.png wireshark.png
+ make_desktop_entry wireshark "Wireshark" wireshark
+ dosym tshark /usr/bin/tethereal
+ use gtk && dosym wireshark /usr/bin/ethereal
+}
+
+pkg_postinst() {
+ ewarn "Due to a history of security flaws in this piece of software, it may contain more flaws."
+ ewarn "To protect yourself against malicious damage due to potential flaws in this product we recommend"
+ ewarn "you take the following security precautions when running wireshark in an untrusted environment:"
+ ewarn "do not run any longer than you need to;"
+ ewarn "use in a root jail - prefereably one that has been hardened with grsec like rootjail protections;"
+ ewarn "use a hardened operating system;"
+ ewarn "do not listen to addition interfaces;"
+ ewarn "if possible, run behind a firewall;"
+ ewarn "take a capture with tcpdump and analyze running wireshark as a least privileged user;"
+ ewarn "and subscribe to wireshark's announce list to be notified of newly discovered vulnerabilities."
+}
+