summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2006-07-25 15:42:36 +0000
committerPeter Volkov <pva@gentoo.org>2006-07-25 15:42:36 +0000
commit6883c08e0077dca65b05d4da908019a17db2602e (patch)
treeead85bb5100c05c02e4a21e0f9d4efb0d2c3611b /net-analyzer
parentadded ethereal -> wireshark and tethereal -> tshark symlinks (diff)
downloadgentoo-2-6883c08e0077dca65b05d4da908019a17db2602e.tar.gz
gentoo-2-6883c08e0077dca65b05d4da908019a17db2602e.tar.bz2
gentoo-2-6883c08e0077dca65b05d4da908019a17db2602e.zip
Version bump. Thank upstream dev Loren Bandiera for report.
(Portage version: 2.1-r1)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/sussen/ChangeLog8
-rw-r--r--net-analyzer/sussen/files/digest-sussen-0.263
-rw-r--r--net-analyzer/sussen/files/sussen-0.26-agent-empty-definitions.patch35
-rw-r--r--net-analyzer/sussen/sussen-0.26.ebuild75
4 files changed, 120 insertions, 1 deletions
diff --git a/net-analyzer/sussen/ChangeLog b/net-analyzer/sussen/ChangeLog
index 3e8a1bb0cb5a..252119e93002 100644
--- a/net-analyzer/sussen/ChangeLog
+++ b/net-analyzer/sussen/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/sussen
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sussen/ChangeLog,v 1.25 2006/07/12 15:11:44 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sussen/ChangeLog,v 1.26 2006/07/25 15:42:36 pva Exp $
+
+*sussen-0.26 (25 Jul 2006)
+
+ 25 Jul 2006; Peter Volkov <pva@gentoo.org>
+ +files/sussen-0.26-agent-empty-definitions.patch, +sussen-0.26.ebuild:
+ Version bump. Thank upstream dev Loren Bandiera for report.
12 Jul 2006; Danny van Dyk <kugelfang@gentoo.org> sussen-0.15.ebuild:
QA: Added doc to IUSE.
diff --git a/net-analyzer/sussen/files/digest-sussen-0.26 b/net-analyzer/sussen/files/digest-sussen-0.26
new file mode 100644
index 000000000000..b0c138bdde39
--- /dev/null
+++ b/net-analyzer/sussen/files/digest-sussen-0.26
@@ -0,0 +1,3 @@
+MD5 437afe876766c2fd124b6bfb00b2f746 sussen-0.26.tar.gz 876168
+RMD160 f7fbdf3166b9136b4d6b5497afa63771e486b79a sussen-0.26.tar.gz 876168
+SHA256 f0796145f30820f07f0b2fddad6c1eabea22813b1111cef5728321dc46a19314 sussen-0.26.tar.gz 876168
diff --git a/net-analyzer/sussen/files/sussen-0.26-agent-empty-definitions.patch b/net-analyzer/sussen/files/sussen-0.26-agent-empty-definitions.patch
new file mode 100644
index 000000000000..80e2f60d8e63
--- /dev/null
+++ b/net-analyzer/sussen/files/sussen-0.26-agent-empty-definitions.patch
@@ -0,0 +1,35 @@
+diff -Naur sussen-0.26.orig/agent/Main.cs sussen-0.26/agent/Main.cs
+--- sussen-0.26.orig/agent/Main.cs 2006-07-18 18:52:01.000000000 +0400
++++ sussen-0.26/agent/Main.cs 2006-07-25 17:08:45.000000000 +0400
+@@ -330,6 +330,13 @@
+ }
+ }
+
++ if (definitionFile == string.Empty || definitionFile == null) {
++ Console.WriteLine ("ERROR: No definitions file specified.");
++ PrintUsage ();
++
++ Environment.Exit (-1);
++ }
++
+ if (familyName == null)
+ #if MONO_BUILD
+ familyName = "linux";
+diff -Naur sussen-0.26.orig/Makefile.am sussen-0.26/Makefile.am
+--- sussen-0.26.orig/Makefile.am 2006-07-25 17:07:29.000000000 +0400
++++ sussen-0.26/Makefile.am 2006-07-25 17:08:45.000000000 +0400
+@@ -1,12 +1,12 @@
+ ACLOCAL_AMFLAGS = -I m4
+
+ if ENABLE_GNOME
+-GNOME_DIRS = applet editor
++GNOME_DIRS = applet editor resources
+ else
+ GNOME_DIRS =
+ endif
+
+-SUBDIRS = debian oval agent $(GNOME_DIRS) resources po www xml m4
++SUBDIRS = debian oval agent $(GNOME_DIRS) po www xml m4
+
+ EXTRA_DIST =\
+ README \
diff --git a/net-analyzer/sussen/sussen-0.26.ebuild b/net-analyzer/sussen/sussen-0.26.ebuild
new file mode 100644
index 000000000000..f5f8ecfd435f
--- /dev/null
+++ b/net-analyzer/sussen/sussen-0.26.ebuild
@@ -0,0 +1,75 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sussen/sussen-0.26.ebuild,v 1.1 2006/07/25 15:42:36 pva Exp $
+
+inherit eutils gnome2 mono autotools
+
+DESCRIPTION="Sussen is a tool that checks for vulnerabilities and configuration issues on computer systems"
+HOMEPAGE="http://dev.mmgsecurity.com/projects/sussen/"
+SRC_URI="http://dev.mmgsecurity.com/downloads//${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+IUSE="doc dbus gnome"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+RDEPEND="=dev-lang/mono-1.1*
+ gnome? ( >=dev-dotnet/gtk-sharp-2.4
+ >=dev-dotnet/gnome-sharp-2.4
+ >=dev-dotnet/gconf-sharp-2.4
+ >=dev-dotnet/glade-sharp-2.4
+ gnome-base/gnome-panel )
+ dbus? ( sys-apps/dbus )"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/monodoc-1.1.8 )
+ app-arch/rpm
+ >=dev-util/intltool-0.34.2"
+
+DOCS="AUTHORS ChangeLog README TODO"
+
+pkg_setup() {
+ if use dbus ; then
+ built_with_use -a sys-apps/dbus mono || die \
+ "${PN} requires dbus build with mono support. Please, reemerge dbus with USE=\"mono\""
+ fi
+ use gnome || { elog "You do not have gnome in your USE flags.";
+ elog "applet and editor will not be built." ; }
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-agent-empty-definitions.patch
+
+ autoreconf || die
+}
+
+src_compile () {
+ econf ${myconf} \
+ $(use_enable dbus) \
+ $(use_enable gnome) || die "./configure failed"
+ LANG=C emake -j1 || die
+}
+
+src_install () {
+ make GACUTIL_FLAGS="/root ${D}/usr/$(get_libdir) /gacdir /usr/$(get_libdir) /package ${PN}" \
+ DESTDIR=${D} install || die
+
+ dodoc ${DOCS}
+
+ elog "sussen-applet is a GNOME applet. You can not run it directly from"
+ elog "the command line. Use GNOME panel to invoke it."
+ elog "You can also run it as the tray icon: sussen-applet --tray-icon"
+ echo
+ ewarn "sussen-editor is still work in progress. Just basic functionality is"
+ ewarn "working (New, Save, Execute)."
+ echo
+ ewarn "Beginning with sussen-0.24 default location for oval definitions changed."
+ ewarn "If you had previous versions installed, please, run the following"
+ ewarn "commands to clean outdated locations for each users that ran sussen:"
+ ewarn
+ ewarn "gconftool-2 --unset /apps/sussen-applet/oval_xml_directory"
+ ewarn "gconftool-2 --unset /apps/sussen-applet/oval_download_directory"
+ echo
+}