summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-02-16 00:10:03 +0000
committerJeroen Roovers <jer@gentoo.org>2014-02-16 00:10:03 +0000
commit5088352e32e238062840527acdf93fb0a26bf2f5 (patch)
treea43bdc57a16e8314c2fa1a7fb99010ff7936a788 /net-analyzer
parentWhitespace (diff)
downloadgentoo-2-5088352e32e238062840527acdf93fb0a26bf2f5.tar.gz
gentoo-2-5088352e32e238062840527acdf93fb0a26bf2f5.tar.bz2
gentoo-2-5088352e32e238062840527acdf93fb0a26bf2f5.zip
Fix building against sys-libs/ncurses[tinfo]. Clean up patches/ebuild.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/ifstatus/ChangeLog11
-rw-r--r--net-analyzer/ifstatus/files/ifstatus-1.1.0-asneeded.patch7
-rw-r--r--net-analyzer/ifstatus/files/ifstatus-1.1.0-gcc43.patch4
-rw-r--r--net-analyzer/ifstatus/files/ifstatus-1.1.0-tinfo.patch22
-rw-r--r--net-analyzer/ifstatus/ifstatus-1.1.0-r1.ebuild40
5 files changed, 76 insertions, 8 deletions
diff --git a/net-analyzer/ifstatus/ChangeLog b/net-analyzer/ifstatus/ChangeLog
index 4d614e89c9bb..d68f1c595121 100644
--- a/net-analyzer/ifstatus/ChangeLog
+++ b/net-analyzer/ifstatus/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/ifstatus
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ifstatus/ChangeLog,v 1.7 2009/06/02 11:51:00 flameeyes Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ifstatus/ChangeLog,v 1.8 2014/02/16 00:10:03 jer Exp $
+
+*ifstatus-1.1.0-r1 (16 Feb 2014)
+
+ 16 Feb 2014; Jeroen Roovers <jer@gentoo.org> +ifstatus-1.1.0-r1.ebuild,
+ files/ifstatus-1.1.0-asneeded.patch, files/ifstatus-1.1.0-gcc43.patch,
+ +files/ifstatus-1.1.0-tinfo.patch:
+ Fix building against sys-libs/ncurses[tinfo]. Clean up patches/ebuild.
02 Jun 2009; Diego E. Pettenò <flameeyes@gentoo.org>
ifstatus-1.1.0.ebuild, +files/ifstatus-1.1.0-asneeded.patch:
diff --git a/net-analyzer/ifstatus/files/ifstatus-1.1.0-asneeded.patch b/net-analyzer/ifstatus/files/ifstatus-1.1.0-asneeded.patch
index 0b95a6163259..a82c085155b3 100644
--- a/net-analyzer/ifstatus/files/ifstatus-1.1.0-asneeded.patch
+++ b/net-analyzer/ifstatus/files/ifstatus-1.1.0-asneeded.patch
@@ -1,12 +1,11 @@
-diff -ru a/Makefile b/Makefile
---- a/Makefile 2009-01-23 22:23:43.000000000 -0600
-+++ b/Makefile 2009-01-23 22:27:06.000000000 -0600
+--- a/Makefile
++++ b/Makefile
@@ -1,7 +1,7 @@
# Makefile for IFStatus
# Gabriel Montenegro
-LDFLAGS = -lncurses
-+LDLIBS = -lncurses
++LDLIBS = $(shell pkg-config --libs ncurses)
BIN = ifstatus
OBJ = BorderDecorator.o\
diff --git a/net-analyzer/ifstatus/files/ifstatus-1.1.0-gcc43.patch b/net-analyzer/ifstatus/files/ifstatus-1.1.0-gcc43.patch
index fb4d1e855889..27111d7576f4 100644
--- a/net-analyzer/ifstatus/files/ifstatus-1.1.0-gcc43.patch
+++ b/net-analyzer/ifstatus/files/ifstatus-1.1.0-gcc43.patch
@@ -1,5 +1,5 @@
---- Main.h~ 2006-01-17 01:49:50.000000000 +0100
-+++ Main.h 2008-06-22 20:21:02.434437686 +0200
+--- a/Main.h
++++ b/Main.h
@@ -38,6 +38,7 @@
#include <unistd.h>
#include <string.h>
diff --git a/net-analyzer/ifstatus/files/ifstatus-1.1.0-tinfo.patch b/net-analyzer/ifstatus/files/ifstatus-1.1.0-tinfo.patch
new file mode 100644
index 000000000000..f7997cd48418
--- /dev/null
+++ b/net-analyzer/ifstatus/files/ifstatus-1.1.0-tinfo.patch
@@ -0,0 +1,22 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,9 +1,7 @@
+ # Makefile for IFStatus
+ # Gabriel Montenegro
+
+-GCC = g++
+-LDFLAGS = -lncurses
+-CFLAGS = -O2 -Wall
++LDLIBS = $(shell pkg-config --libs ncurses)
+
+ BIN = ifstatus
+ OBJ = BorderDecorator.o\
+@@ -30,7 +28,7 @@
+ all : ifstatus printdone
+
+ ifstatus : $(OBJ)
+- $(GCC) $(CFLAGS) $(LDFLAGS) $^ -o $@
++ $(LINK.cc) $^ $(LDLIBS) -o $@
+
+ printdone:
+ @if [ -e "./${BIN}" ]; then echo "Compiled.."; else echo "Error compiling!"; fi
diff --git a/net-analyzer/ifstatus/ifstatus-1.1.0-r1.ebuild b/net-analyzer/ifstatus/ifstatus-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..39554f777985
--- /dev/null
+++ b/net-analyzer/ifstatus/ifstatus-1.1.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ifstatus/ifstatus-1.1.0-r1.ebuild,v 1.1 2014/02/16 00:10:03 jer Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+
+DESCRIPTION="A simple CLI program for displaying network statistics in real time."
+HOMEPAGE="http://ifstatus.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-v${PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+
+RDEPEND=">=sys-libs/ncurses-4.2"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+ epatch "${FILESDIR}/${P}-tinfo.patch"
+ tc-export CXX
+}
+
+src_install() {
+ dobin ifstatus
+ dodoc AUTHORS README
+}
+
+pkg_postinst() {
+ elog "You may want to configure ~/.ifstatus/ifstatus.cfg"
+ elog "before running ifstatus. For example, you may add"
+ elog "Interfaces = eth0 there. Read the README file for"
+ elog "more information."
+}