summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2012-05-15 22:09:09 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2012-05-15 22:09:09 +0000
commit45e673a7c95193c47eacb7b407659576eb84e4d1 (patch)
tree0f984a78c482f6cbf66f69610c47ad948ab7353b /net-analyzer
parentDrop ancient (diff)
downloadgentoo-2-45e673a7c95193c47eacb7b407659576eb84e4d1.tar.gz
gentoo-2-45e673a7c95193c47eacb7b407659576eb84e4d1.tar.bz2
gentoo-2-45e673a7c95193c47eacb7b407659576eb84e4d1.zip
adding 1.7.0 and removing 1.6.1-r1
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/icinga/ChangeLog10
-rw-r--r--net-analyzer/icinga/files/fix-prestripped-binaries-1.7.0.patch23
-rw-r--r--net-analyzer/icinga/files/icinga-init.d34
-rwxr-xr-xnet-analyzer/icinga/files/icinga-init.d-250
-rw-r--r--net-analyzer/icinga/icinga-1.6.1-r2.ebuild4
-rw-r--r--net-analyzer/icinga/icinga-1.7.0.ebuild (renamed from net-analyzer/icinga/icinga-1.6.1-r1.ebuild)47
-rw-r--r--net-analyzer/icinga/metadata.xml1
7 files changed, 87 insertions, 82 deletions
diff --git a/net-analyzer/icinga/ChangeLog b/net-analyzer/icinga/ChangeLog
index 2bed39f06b94..46dbe4097b44 100644
--- a/net-analyzer/icinga/ChangeLog
+++ b/net-analyzer/icinga/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-analyzer/icinga
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga/ChangeLog,v 1.14 2012/03/09 10:00:55 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga/ChangeLog,v 1.15 2012/05/15 22:09:09 prometheanfire Exp $
+
+*icinga-1.7.0 (15 May 2012)
+
+ 15 May 2012; Matthew Thode <prometheanfire@gentoo.org>
+ +files/fix-prestripped-binaries-1.7.0.patch, +icinga-1.7.0.ebuild,
+ -files/icinga-init.d, -icinga-1.6.1-r1.ebuild, files/icinga-init.d,
+ icinga-1.6.1-r2.ebuild, metadata.xml:
+ adding 1.7.0 and removing 1.6.1-r1
09 Mar 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org> icinga-1.6.1-r2.ebuild:
x86 stable wrt bug #403949
diff --git a/net-analyzer/icinga/files/fix-prestripped-binaries-1.7.0.patch b/net-analyzer/icinga/files/fix-prestripped-binaries-1.7.0.patch
new file mode 100644
index 000000000000..256cfc83232f
--- /dev/null
+++ b/net-analyzer/icinga/files/fix-prestripped-binaries-1.7.0.patch
@@ -0,0 +1,23 @@
+diff -rupN icinga-1.7.0beta1-orig//base/Makefile.in icinga-1.7.0beta1//base/Makefile.in
+--- icinga-1.7.0beta1-orig//base/Makefile.in 2012-05-09 07:10:21.000000000 -0500
++++ icinga-1.7.0beta1//base/Makefile.in 2012-05-14 14:00:29.666346315 -0500
+@@ -41,7 +41,7 @@ HTMLDIR=@datarootdir@
+ INSTALL=@INSTALL@
+ INSTALL_OPTS=@INSTALL_OPTS@
+ COMMAND_OPTS=@COMMAND_OPTS@
+-STRIP=@STRIP@
++STRIP=/bin/true
+
+ CGIURL=@cgiurl@
+ HTMURL=@htmurl@
+diff -rupN icinga-1.7.0beta1-orig//cgi/Makefile.in icinga-1.7.0beta1//cgi/Makefile.in
+--- icinga-1.7.0beta1-orig//cgi/Makefile.in 2012-05-09 07:10:21.000000000 -0500
++++ icinga-1.7.0beta1//cgi/Makefile.in 2012-05-14 14:00:43.285346614 -0500
+@@ -21,7 +21,7 @@ INSTALL=@INSTALL@
+ INSTALL_OPTS=@INSTALL_OPTS@
+ INSTALL_OPTS_WEB=@INSTALL_OPTS_WEB@
+ COMMAND_OPTS=@COMMAND_OPTS@
+-STRIP=@STRIP@
++STRIP=/bin/true
+
+ CGIEXTRAS=@CGIEXTRAS@
diff --git a/net-analyzer/icinga/files/icinga-init.d b/net-analyzer/icinga/files/icinga-init.d
index f734f714b338..683e52c4c4e5 100644
--- a/net-analyzer/icinga/files/icinga-init.d
+++ b/net-analyzer/icinga/files/icinga-init.d
@@ -1,19 +1,11 @@
#!/sbin/runscript
-opts="${opts} reload checkconfig"
+extra_commands="${extra_commands} reload checkconfig"
depend() {
need net
use dns logger firewall
- after mysql postgresql
-}
-
-reload()
-{
- checkconfig || return 1
- ebegin "Reloading configuration"
- killall -HUP icinga &>/dev/null
- eend $?
+ after mysql postgresql ido2db
}
checkconfig() {
@@ -24,20 +16,28 @@ checkconfig() {
eend $? "Configuration Error. Please fix your configfile"
}
-start() {
+reload()
+{
checkconfig || return 1
+ ebegin "Reloading configuration"
+ kill -HUP `cat /var/run/icinga/icinga.lock` &>/dev/null
+ eend $?
+}
+
+start() {
ebegin "Starting icinga"
- touch /var/icinga/icinga.log /var/icinga/status.sav
- chown icinga:icinga /var/icinga/icinga.log /var/icinga/status.sav
- rm -f /var/icinga/rw/icinga.cmd
- start-stop-daemon --quiet --start --startas /usr/sbin/icinga -e HOME="/var/icinga/home" --pidfile /var/icinga/icinga.lock -- -d /etc/icinga/icinga.cfg
+ checkpath -d -o icinga:icinga /tmp/icinga /var/run/icinga /var/log/icinga /var/lib/icinga
+ checkpath -f -o icinga:icinga /var/log/icinga/icinga.log
+ rm -f /var/lib/icinga/rw/icinga.cmd
+ start-stop-daemon --start --exec /usr/sbin/icinga -e HOME="/var/lib/icinga/home" --pidfile /var/run/icinga/icinga.lock -- -d /etc/icinga/icinga.cfg
eend $?
}
stop() {
ebegin "Stopping icinga"
- start-stop-daemon --quiet --stop --pidfile /var/icinga/icinga.lock
- rm -f /var/icinga/status.log /var/icinga/icinga.tmp /var/icinga/icinga.lock /var/icinga/rw/icinga.cmd
+ start-stop-daemon --stop --pidfile /var/run/icinga/icinga.lock
+ rm -f /var/lib/icinga/status.log /var/run/icinga/icinga.lock /var/lib/icinga/rw/icinga.cmd
+ rm -r /tmp/icinga
eend $?
}
diff --git a/net-analyzer/icinga/files/icinga-init.d-2 b/net-analyzer/icinga/files/icinga-init.d-2
deleted file mode 100755
index 683e52c4c4e5..000000000000
--- a/net-analyzer/icinga/files/icinga-init.d-2
+++ /dev/null
@@ -1,50 +0,0 @@
-#!/sbin/runscript
-
-extra_commands="${extra_commands} reload checkconfig"
-
-depend() {
- need net
- use dns logger firewall
- after mysql postgresql ido2db
-}
-
-checkconfig() {
- # Silent Check
- /usr/sbin/icinga -v /etc/icinga/icinga.cfg &>/dev/null && return 0
- # Now we know there's problem - run again and display errors
- /usr/sbin/icinga -v /etc/icinga/icinga.cfg
- eend $? "Configuration Error. Please fix your configfile"
-}
-
-reload()
-{
- checkconfig || return 1
- ebegin "Reloading configuration"
- kill -HUP `cat /var/run/icinga/icinga.lock` &>/dev/null
- eend $?
-}
-
-start() {
- ebegin "Starting icinga"
- checkpath -d -o icinga:icinga /tmp/icinga /var/run/icinga /var/log/icinga /var/lib/icinga
- checkpath -f -o icinga:icinga /var/log/icinga/icinga.log
- rm -f /var/lib/icinga/rw/icinga.cmd
- start-stop-daemon --start --exec /usr/sbin/icinga -e HOME="/var/lib/icinga/home" --pidfile /var/run/icinga/icinga.lock -- -d /etc/icinga/icinga.cfg
- eend $?
-}
-
-stop() {
- ebegin "Stopping icinga"
- start-stop-daemon --stop --pidfile /var/run/icinga/icinga.lock
- rm -f /var/lib/icinga/status.log /var/run/icinga/icinga.lock /var/lib/icinga/rw/icinga.cmd
- rm -r /tmp/icinga
- eend $?
-}
-
-svc_restart() {
- checkconfig || return 1
- ebegin "Restarting icinga"
- svc_stop
- svc_start
- eend $?
-}
diff --git a/net-analyzer/icinga/icinga-1.6.1-r2.ebuild b/net-analyzer/icinga/icinga-1.6.1-r2.ebuild
index 0029df7e8abd..e3b3c71af769 100644
--- a/net-analyzer/icinga/icinga-1.6.1-r2.ebuild
+++ b/net-analyzer/icinga/icinga-1.6.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga/icinga-1.6.1-r2.ebuild,v 1.3 2012/03/09 10:00:55 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga/icinga-1.6.1-r2.ebuild,v 1.4 2012/05/15 22:09:09 prometheanfire Exp $
EAPI=2
@@ -112,7 +112,7 @@ src_install() {
emake DESTDIR="${D}" install-idoutils || die
fi
- newinitd "${FILESDIR}"/icinga-init.d-2 icinga || die
+ newinitd "${FILESDIR}"/icinga-init.d icinga || die
newconfd "${FILESDIR}"/icinga-conf.d icinga || die
if use idoutils ; then
newinitd "${FILESDIR}"/ido2db-init.d ido2db || die
diff --git a/net-analyzer/icinga/icinga-1.6.1-r1.ebuild b/net-analyzer/icinga/icinga-1.7.0.ebuild
index a8fced06fc3a..5a4237647693 100644
--- a/net-analyzer/icinga/icinga-1.6.1-r1.ebuild
+++ b/net-analyzer/icinga/icinga-1.7.0.ebuild
@@ -1,19 +1,22 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga/icinga-1.6.1-r1.ebuild,v 1.3 2011/12/29 15:59:11 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga/icinga-1.7.0.ebuild,v 1.1 2012/05/15 22:09:09 prometheanfire Exp $
EAPI=2
-inherit depend.apache eutils multilib toolchain-funcs
+inherit depend.apache eutils multilib toolchain-funcs versionator
DESCRIPTION="Nagios Fork - Check daemon, CGIs, docs, IDOutils"
HOMEPAGE="http://www.icinga.org/"
+#MY_PV=$(delete_version_separator 3)
+#SRC_URI="mirror://sourceforge/${PN}/${PN}-${MY_PV}.tar.gz"
+#S=${WORKDIR}/${PN}-${MY_PV}
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="+apache2 debug +idoutils lighttpd +mysql perl plugins postgres ssl +vim-syntax +web"
+IUSE="+apache2 debug eventhandler +idoutils lighttpd +mysql perl +plugins postgres ssl +vim-syntax +web"
DEPEND="idoutils? ( dev-db/libdbi-drivers[mysql?,postgres?] )
perl? ( dev-lang/perl )
virtual/mailx
@@ -32,11 +35,11 @@ pkg_setup() {
depend.apache_pkg_setup
enewgroup icinga
enewgroup nagios
- enewuser icinga -1 -1 /var/spool/icinga "icinga,nagios"
+ enewuser icinga -1 -1 /var/lib/icinga "icinga,nagios"
}
src_prepare() {
- epatch "${FILESDIR}/fix-prestripped-binaries.patch"
+ epatch "${FILESDIR}/fix-prestripped-binaries-1.7.0.patch"
}
src_configure() {
@@ -55,18 +58,31 @@ src_configure() {
--disable-statuswrl
--with-cgiurl=/icinga/cgi-bin
--with-log-dir=/var/log/icinga
+ --libdir=/usr/$(get_libdir)
--bindir=/usr/sbin
--sbindir=/usr/$(get_libdir)/icinga/cgi-bin
--datarootdir=/usr/share/icinga/htdocs
--localstatedir=/var/lib/icinga
--sysconfdir=/etc/icinga
--with-lockfile=/var/run/icinga/icinga.lock
- --with-temp-dir=/tmp/icinga"
+ --with-temp-dir=/tmp/icinga
+ --with-temp-file=/tmp/icinga/icinga.tmp"
+
+ if use idoutils ; then
+ myconf+=" --with-ido2db-lockfile=/var/run/icinga/ido2db.lock
+ --with-icinga-chkfile=/var/lib/icinga/icinga.chk
+ --with-ido-sockfile=/var/lib/icinga/ido.sock
+ --with-idomod-tmpfile=/tmp/icinga/idomod.tmp"
+ fi
+
+ if use eventhandler ; then
+ myconfig+=" --with-eventhandler-dir=/etc/icinga/eventhandlers"
+ fi
if use plugins ; then
- myconf+=" --libexecdir=/usr/$(get_libdir)/nagios/plugins"
+ myconf+=" --with-plugin-dir=/usr/$(get_libdir)/nagios/plugins"
else
- myconf+=" --libexecdir=/usr/$(get_libdir)/icinga/plugins"
+ myconf+=" --with-plugin-dir=/usr/$(get_libdir)/nagios/plugins"
fi
if use !apache2 && use !lighttpd ; then
@@ -106,13 +122,15 @@ src_install() {
emake DESTDIR="${D}" install{,-config,-commandmode} || die
- sed -i -e 's/var\/lib\/icinga\/icinga.tmp/tmp\/icinga\/icinga.tmp/g' "${D}"/etc/icinga/icinga.cfg || die
-
if use idoutils ; then
emake DESTDIR="${D}" install-idoutils || die
fi
- newinitd "${FILESDIR}"/icinga-init.d-2 icinga || die
+ if use eventhandler ; then
+ emake DESTDIR="${D}" install-eventhandlers || die
+ fi
+
+ newinitd "${FILESDIR}"/icinga-init.d icinga || die
newconfd "${FILESDIR}"/icinga-conf.d icinga || die
if use idoutils ; then
newinitd "${FILESDIR}"/ido2db-init.d ido2db || die
@@ -135,6 +153,11 @@ src_install() {
fi
fi
+ if use eventhandler ; then
+ dodir /etc/icinga/eventhandlers || die
+ fowners icinga:icinga /etc/icinga/eventhandlers || die
+ fi
+
fowners -R root:root /usr/$(get_libdir)/icinga || die
cd "${D}" || die
find usr/$(get_libdir)/icinga -type d -exec fperms 755 {} +
diff --git a/net-analyzer/icinga/metadata.xml b/net-analyzer/icinga/metadata.xml
index 65a79e7a3190..476a6f0d37ed 100644
--- a/net-analyzer/icinga/metadata.xml
+++ b/net-analyzer/icinga/metadata.xml
@@ -7,6 +7,7 @@
<flag name="lighttpd">Adds Lighttpd support</flag>
<flag name="plugins">Adds support for nagios plugins</flag>
<flag name="web">Adds generic web interface support</flag>
+ <flag name="eventhandler">Adds support for running custom scripts whenever a host or service state change occurs</flag>
</use>
<maintainer>
<email>prometheanfire@gentoo.org</email>