summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2006-06-04 18:11:16 +0000
committerPeter Volkov <pva@gentoo.org>2006-06-04 18:11:16 +0000
commit45205092e9a6f46ec7500bd7dc919f4b7f76b91f (patch)
tree81d64850f87dc0571a0b99b730c34154a449f8db /net-analyzer
parentRemove hardcoding of .m4 files from configure.in. Fixes bug 135463 (diff)
downloadgentoo-2-45205092e9a6f46ec7500bd7dc919f4b7f76b91f.tar.gz
gentoo-2-45205092e9a6f46ec7500bd7dc919f4b7f76b91f.tar.bz2
gentoo-2-45205092e9a6f46ec7500bd7dc919f4b7f76b91f.zip
Partial fix for bug 135493. sussen-applet should not crash when cancel pressed during execution.
(Portage version: 2.0.54-r2)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/sussen/ChangeLog9
-rw-r--r--net-analyzer/sussen/Manifest3
-rw-r--r--net-analyzer/sussen/files/digest-sussen-0.22-r11
-rw-r--r--net-analyzer/sussen/files/sussen-0.22-applet-cancel-scan-crash.patch32
-rw-r--r--net-analyzer/sussen/sussen-0.22-r1.ebuild55
5 files changed, 99 insertions, 1 deletions
diff --git a/net-analyzer/sussen/ChangeLog b/net-analyzer/sussen/ChangeLog
index 3766c4eeddc5..d03563a89a3f 100644
--- a/net-analyzer/sussen/ChangeLog
+++ b/net-analyzer/sussen/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-analyzer/sussen
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sussen/ChangeLog,v 1.16 2006/05/29 17:07:47 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sussen/ChangeLog,v 1.17 2006/06/04 18:11:15 pva Exp $
+
+*sussen-0.22-r1 (04 Jun 2006)
+
+ 04 Jun 2006; Peter Volkov <pva@gentoo.org>
+ +files/sussen-0.22-applet-cancel-scan-crash.patch, +sussen-0.22-r1.ebuild:
+ Partial fix for bug 135493. sussen-applet should not crash when cancel pressed
+ during execution.
*sussen-0.22 (29 May 2006)
diff --git a/net-analyzer/sussen/Manifest b/net-analyzer/sussen/Manifest
index a26963169ae8..a2a05ca851f0 100644
--- a/net-analyzer/sussen/Manifest
+++ b/net-analyzer/sussen/Manifest
@@ -5,12 +5,15 @@ MD5 034a05b578eae1d70b56349b853e5d92 files/digest-sussen-0.15 63
MD5 7909b6528ae1de89d5682b72b3dca83d files/digest-sussen-0.19 63
MD5 e3343da7f441c043bcebf6e0b1a08e3a files/digest-sussen-0.21 63
MD5 2155275b1249ccfcc99963dd9546ca5e files/digest-sussen-0.22 63
+MD5 2155275b1249ccfcc99963dd9546ca5e files/digest-sussen-0.22-r1 63
MD5 5dd20ca6159958efc7303bd449ea592e files/digest-sussen-0.5.3 64
+MD5 06d36be407bde33246cc4cea8ded89b9 files/sussen-0.22-applet-cancel-scan-crash.patch 752
MD5 637389da071d8ee0c0292695525bc29f metadata.xml 160
MD5 284a33f91290e58dc976067ff9438ae5 sussen-0.10.ebuild 745
MD5 eb4b0f734206dfbff9990d9a1edb216f sussen-0.12.ebuild 745
MD5 b1481061b30678b085039bd5c9952ef8 sussen-0.15.ebuild 855
MD5 60d350134a4ad2790feccb71a4e472a9 sussen-0.19.ebuild 1139
MD5 7d6ed18daf3a7e934469d3cbe9d78e97 sussen-0.21.ebuild 1478
+MD5 cda342aa1f19327535c85a8023d33493 sussen-0.22-r1.ebuild 1538
MD5 97aee108b0a5f075ad5c0c59a3ba3fd4 sussen-0.22.ebuild 1436
MD5 606a391d68a2efbd6f306c20cd73fdbe sussen-0.5.3.ebuild 1118
diff --git a/net-analyzer/sussen/files/digest-sussen-0.22-r1 b/net-analyzer/sussen/files/digest-sussen-0.22-r1
new file mode 100644
index 000000000000..1f0c4bb7b5ef
--- /dev/null
+++ b/net-analyzer/sussen/files/digest-sussen-0.22-r1
@@ -0,0 +1 @@
+MD5 e4176264bf3f14e6badb726e18a14c4d sussen-0.22.tar.gz 765383
diff --git a/net-analyzer/sussen/files/sussen-0.22-applet-cancel-scan-crash.patch b/net-analyzer/sussen/files/sussen-0.22-applet-cancel-scan-crash.patch
new file mode 100644
index 000000000000..10b0be87e335
--- /dev/null
+++ b/net-analyzer/sussen/files/sussen-0.22-applet-cancel-scan-crash.patch
@@ -0,0 +1,32 @@
+diff -Naur sussen-0.22.orig/applet/ActionDialog.cs sussen-0.22/applet/ActionDialog.cs
+--- sussen-0.22.orig/applet/ActionDialog.cs 2006-05-13 20:05:54.000000000 +0400
++++ sussen-0.22/applet/ActionDialog.cs 2006-06-04 22:01:24.000000000 +0400
+@@ -59,6 +59,8 @@
+ ActionDialogType actionDialogType;
+
+ bool scanDone;
++ bool userCancelled;
++
+ uint scanTimer;
+ string xmlDirectory;
+ string downloadDirectory;
+@@ -190,6 +192,11 @@
+ {
+ GLib.Source.Remove (scanTimer);
+ notify.Close ();
++
++ if (userCancelled) {
++ userCancelled = false;
++ return;
++ }
+
+ scanDone = true;
+ executeButton.Sensitive = true;
+@@ -354,6 +361,7 @@
+ notify.WakeupMain ();
+
+ scanDone = true;
++ userCancelled = true;
+ }
+ }
+
diff --git a/net-analyzer/sussen/sussen-0.22-r1.ebuild b/net-analyzer/sussen/sussen-0.22-r1.ebuild
new file mode 100644
index 000000000000..ebc6c37b0130
--- /dev/null
+++ b/net-analyzer/sussen/sussen-0.22-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sussen/sussen-0.22-r1.ebuild,v 1.1 2006/06/04 18:11:15 pva Exp $
+
+inherit gnome2 mono autotools
+
+DESCRIPTION="Sussen is a tool that checks for vulnerabilities and configuration issues on computer systems"
+HOMEPAGE="http://dev.mmgsecurity.com/projects/sussen/"
+SRC_URI="http://dev.mmgsecurity.com/downloads//${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+IUSE="doc"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+RDEPEND="=dev-lang/mono-1.1*
+ >=dev-dotnet/gtk-sharp-2.4
+ >=dev-dotnet/gnome-sharp-2.4
+ >=dev-dotnet/gconf-sharp-2.4
+ >=dev-dotnet/glade-sharp-2.4
+ gnome-base/gnome-panel"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/monodoc-1.1.8 )
+ app-arch/rpm
+ >=dev-util/intltool-0.34.2"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ pwd
+ epatch ${FILESDIR}/${P}-applet-cancel-scan-crash.patch
+}
+
+src_compile () {
+ econf ${myconf} || die "./configure failed"
+ LANG=C emake -j1 || die
+}
+
+src_install () {
+ make GACUTIL_FLAGS="/root ${D}/usr/$(get_libdir) /gacdir /usr/$(get_libdir) /package ${PN}" \
+ DESTDIR=${D} install || die
+
+ dodoc ${DOCS}
+
+ einfo "sussen-applet is a GNOME applet. You can not run it directly from"
+ einfo "the command line. Use GNOME panel to invoke it."
+ einfo "You can also run it as the tray icon: sussen-applet --tray-icon"
+ echo
+ ewarn "sussen-editor is still work in progress. Just basic functionality is"
+ ewarn "working (New, Save, Execute)."
+ echo
+}