summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRadoslaw Stachowiak <radek@gentoo.org>2004-12-27 20:45:58 +0000
committerRadoslaw Stachowiak <radek@gentoo.org>2004-12-27 20:45:58 +0000
commit350c94c66d1fdbdd9b29ff3f0be321d8eb07e9a6 (patch)
treee3d79ce298fbf62122321ab7e1e3231ff5efc08d /net-analyzer
parentFixed digest. (diff)
downloadgentoo-2-350c94c66d1fdbdd9b29ff3f0be321d8eb07e9a6.tar.gz
gentoo-2-350c94c66d1fdbdd9b29ff3f0be321d8eb07e9a6.tar.bz2
gentoo-2-350c94c66d1fdbdd9b29ff3f0be321d8eb07e9a6.zip
new version.
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/xprobe/ChangeLog8
-rw-r--r--net-analyzer/xprobe/Manifest4
-rw-r--r--net-analyzer/xprobe/files/digest-xprobe-0.2.11
-rw-r--r--net-analyzer/xprobe/xprobe-0.2.1.ebuild47
4 files changed, 58 insertions, 2 deletions
diff --git a/net-analyzer/xprobe/ChangeLog b/net-analyzer/xprobe/ChangeLog
index e5a7cdfe5958..6bd8428e223e 100644
--- a/net-analyzer/xprobe/ChangeLog
+++ b/net-analyzer/xprobe/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/xprobe
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/xprobe/ChangeLog,v 1.6 2004/07/10 10:11:26 eldad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/xprobe/ChangeLog,v 1.7 2004/12/27 20:45:58 radek Exp $
+
+ 27 Dec 2004; Radoslaw Stachowiak <radek@gentoo.org> :
+ New version of xprobe xprobe, so called xprobe2, due to xprobe1 being
+ obsoleted. xprobe 2 has different approach to operating system
+ fingerprinting. Xprobe2 rely on fuzzy signature matching, probabilistic
+ guesses, multiple matches simultaneously, and a signature database.
10 Jul 2004; Eldad Zack <eldad@gentoo.org> +metadata.xml,
xprobe-0.0.2.ebuild:
diff --git a/net-analyzer/xprobe/Manifest b/net-analyzer/xprobe/Manifest
index 8e770cbffd22..e9b2e4de0a74 100644
--- a/net-analyzer/xprobe/Manifest
+++ b/net-analyzer/xprobe/Manifest
@@ -1,5 +1,7 @@
+MD5 aeb7d62b364297015a187bde48e33e3f xprobe-0.2.1.ebuild 1217
MD5 2353631375a431272405873e2c72b605 xprobe-0.0.2.ebuild 762
-MD5 a892456b3ebe778e561b1a822e3df168 ChangeLog 643
+MD5 6648d4d01a0809a35426a6e3bd0ce2d9 ChangeLog 981
MD5 ac6c11d70b477833baa876a5460fba26 metadata.xml 224
MD5 9610e3d9785f7b6eb29ab995ef30fb08 files/xprobe-0.0.2-gentoo.patch 387
MD5 2d7fd3216e38d4a4adb0d40c689bb944 files/digest-xprobe-0.0.2 63
+MD5 6b20f3d65e14741fe524b8b88dbdbd73 files/digest-xprobe-0.2.1 65
diff --git a/net-analyzer/xprobe/files/digest-xprobe-0.2.1 b/net-analyzer/xprobe/files/digest-xprobe-0.2.1
new file mode 100644
index 000000000000..c212ab98fa00
--- /dev/null
+++ b/net-analyzer/xprobe/files/digest-xprobe-0.2.1
@@ -0,0 +1 @@
+MD5 aaddb4bf793ef573b7fb43ee91bb2224 xprobe2-0.2.1.tar.gz 481766
diff --git a/net-analyzer/xprobe/xprobe-0.2.1.ebuild b/net-analyzer/xprobe/xprobe-0.2.1.ebuild
new file mode 100644
index 000000000000..373a1acc72e6
--- /dev/null
+++ b/net-analyzer/xprobe/xprobe-0.2.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/xprobe/xprobe-0.2.1.ebuild,v 1.1 2004/12/27 20:45:58 radek Exp $
+
+inherit eutils
+
+# This is new xprobe, so called xprobe2, due to xprobe1 being obsoleted.
+# xprobe 2 has different approach to operating system fingerprinting.
+# Xprobe2 rely on fuzzy signature matching, probabilistic guesses, multiple
+# matches simultaneously, and a signature database.
+#
+DESCRIPTION="Active OS fingerprinting tool - this is Xprobe2"
+SRC_URI="mirror://sourceforge/${PN}/${PN}2-${PV}.tar.gz"
+HOMEPAGE="http://www.sys-security.com/html/projects/X.html"
+
+KEYWORDS="~x86"
+SLOT="0"
+LICENSE="GPL-2"
+
+DEPEND=">=net-libs/libpcap-0.6.1"
+IUSE=""
+
+src_unpack() {
+
+ unpack ${A}
+
+ #epatch ${FILESDIR}/${P}-gentoo.patch || die "epatch failed"
+}
+
+src_compile() {
+
+ cd "${WORKDIR}/${PN}2-${PV}"
+ # needed due to broken configure script
+ unset CFLAGS
+ unset CXXFLAGS
+ econf || die "could not configure"
+ emake || die "could not make"
+}
+
+src_install () {
+ cd "${WORKDIR}/${PN}2-${PV}"
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS CREDITS COPYING
+ dodoc CHANGELOG TODO README
+ dodoc docs/*
+}
+