summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-03-13 21:09:51 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2015-03-13 21:09:51 +0000
commit06290906ee126b16355bb4aa342d9d453b5f274c (patch)
treeef43ac8de6f80e24d7b7f0bc512e766b25a8819b /net-analyzer
parentanother bump (diff)
downloadgentoo-2-06290906ee126b16355bb4aa342d9d453b5f274c.tar.gz
gentoo-2-06290906ee126b16355bb4aa342d9d453b5f274c.tar.bz2
gentoo-2-06290906ee126b16355bb4aa342d9d453b5f274c.zip
fixing reload in init script
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x33ED3FD25AFC78BA)
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/icinga2/ChangeLog6
-rw-r--r--net-analyzer/icinga2/files/icinga2.initd2
-rw-r--r--net-analyzer/icinga2/icinga2-2.3.2.ebuild3
3 files changed, 8 insertions, 3 deletions
diff --git a/net-analyzer/icinga2/ChangeLog b/net-analyzer/icinga2/ChangeLog
index 16f6ba9a4c75..e3453dad9989 100644
--- a/net-analyzer/icinga2/ChangeLog
+++ b/net-analyzer/icinga2/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/icinga2
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga2/ChangeLog,v 1.30 2015/03/13 20:46:49 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga2/ChangeLog,v 1.31 2015/03/13 21:09:51 prometheanfire Exp $
+
+ 13 Mar 2015; Matthew Thode <prometheanfire@gentoo.org> files/icinga2.initd,
+ icinga2-2.3.2.ebuild:
+ fixing reload in init script
*icinga2-2.3.2 (13 Mar 2015)
diff --git a/net-analyzer/icinga2/files/icinga2.initd b/net-analyzer/icinga2/files/icinga2.initd
index da26015a9db7..010ef0c480e0 100644
--- a/net-analyzer/icinga2/files/icinga2.initd
+++ b/net-analyzer/icinga2/files/icinga2.initd
@@ -75,5 +75,5 @@ reload() {
return 1
fi
ebegin "Reloading icinga2"
- start-stop-daemon --signal HUP "$ICINGA2_PID_FILE"
+ start-stop-daemon --signal HUP --pidfile "$ICINGA2_PID_FILE"
}
diff --git a/net-analyzer/icinga2/icinga2-2.3.2.ebuild b/net-analyzer/icinga2/icinga2-2.3.2.ebuild
index b1bc70002462..e792798068ec 100644
--- a/net-analyzer/icinga2/icinga2-2.3.2.ebuild
+++ b/net-analyzer/icinga2/icinga2-2.3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga2/icinga2-2.3.2.ebuild,v 1.1 2015/03/13 20:46:49 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/icinga2/icinga2-2.3.2.ebuild,v 1.2 2015/03/13 21:09:51 prometheanfire Exp $
EAPI=5
inherit depend.apache eutils cmake-utils toolchain-funcs user versionator systemd
@@ -131,6 +131,7 @@ src_install() {
fowners icinga:icinga /etc/icinga2
fowners icinga:icinga /var/lib/icinga2
fowners icinga:icinga /var/spool/icinga2
+ fowners icinga:icinga /var/spool/icinga2/perfdata
fowners icinga:icingacmd /var/log/icinga2
fperms ug+rwX,o-rwx /etc/icinga2