summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-06-01 14:00:14 +0000
committerAchim Gottinger <achim@gentoo.org>2001-06-01 14:00:14 +0000
commit357a1b39d2aa6d172a908d805edab80d716fb7ee (patch)
tree0a62bacc29615a8ea4c7e1c1e17ca85df2cb0c66 /net-analyzer/ucd-snmp
parentnew TODO comments (extensive) (diff)
downloadgentoo-2-357a1b39d2aa6d172a908d805edab80d716fb7ee.tar.gz
gentoo-2-357a1b39d2aa6d172a908d805edab80d716fb7ee.tar.bz2
gentoo-2-357a1b39d2aa6d172a908d805edab80d716fb7ee.zip
*** empty log message ***
Diffstat (limited to 'net-analyzer/ucd-snmp')
-rw-r--r--net-analyzer/ucd-snmp/ucd-snmp-4.1.2.ebuild39
1 files changed, 28 insertions, 11 deletions
diff --git a/net-analyzer/ucd-snmp/ucd-snmp-4.1.2.ebuild b/net-analyzer/ucd-snmp/ucd-snmp-4.1.2.ebuild
index 179abb869ff3..5d2b74d4d434 100644
--- a/net-analyzer/ucd-snmp/ucd-snmp-4.1.2.ebuild
+++ b/net-analyzer/ucd-snmp/ucd-snmp-4.1.2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Jerry Alexandratos <jerry@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ucd-snmp/ucd-snmp-4.1.2.ebuild,v 1.2 2000/11/08 08:44:48 jerry Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ucd-snmp/ucd-snmp-4.1.2.ebuild,v 1.3 2001/06/01 14:00:14 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -9,25 +9,42 @@ DESCRIPTION="Software for generating and retrieving SNMP data"
SRC_URI="http://download.sourceforge.net/net-snmp/${A}"
HOMEPAGE="http://net-snmp.sourceforge.net/"
-DEPEND=">=sys-libs/glibc-2.1.3
+DEPEND="virtual/glibc <sys-libs/db-2
>=sys-libs/zlib-1.1.3
- >=dev-libs/openssl-0.9.6
- >=sys-apps/tcp-wrappers-7.6
- >=sys-devel/perl-5.6.0"
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )"
+
+DEPEND="virtual/glibc <sys-libs/db-2
+ ssl? ( >=dev-libs/openssl-0.9.6 )
+ >=sys-libs/zlib-1.1.3"
src_compile() {
- cd ${S}
- try ./configure --prefix=/usr --host=${CHOST} \
- --with-openssl --with-libwrap --with-zlib
+ local myconf
+ if [ "`use ssl`" ] ; then
+ myconf="--with-openssl=/usr"
+ else
+ myconf="--enable-internal-md5 --with-openssl=no"
+ fi
+ if [ "`use tcpd`" ] ; then
+ myconf="--with-libwrap"
+ fi
+ try ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} \
+ $myconf --with-zlib --enable-shared --enable-ipv6 \
+ --with-sys-contact=\"root\@Unknown\" \
+ --with-sys-location="Unknown" \
+ --with-logfile=/var/log/snmpd.log \
+ --with-persistent-directory=/var/lib/ucd-snmp
+
try make
}
src_install () {
try make prefix=${D}/usr exec_prefix=${D}/usr \
- persistentdir=${D}/var/ucd-snmp install
+ mandir=${D}/usr/share/man \
+ persistentdir=${D}/var/lib/ucd-snmp install
- dodir /etc/rc.d/init.d/
- cp ${O}/files/snmpd ${D}/etc/rc.d/init.d/snmpd
+ dodir /etc/rc.d/init.d
+ cp ${FILESDIR}/snmpd ${D}/etc/rc.d/init.d/snmpd
}
pkg_config() {