summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-12-17 14:22:46 +0000
committerJeroen Roovers <jer@gentoo.org>2011-12-17 14:22:46 +0000
commit9606715ccdf6ade3fb15aa82430fec748cc26212 (patch)
tree84a82785608ab29523b16344701b2d74dd32b339 /net-analyzer/tcpdump
parentAdd patch for correct linking with USE=vala, thanks Attila Tóth finding the ... (diff)
downloadgentoo-2-9606715ccdf6ade3fb15aa82430fec748cc26212.tar.gz
gentoo-2-9606715ccdf6ade3fb15aa82430fec748cc26212.tar.bz2
gentoo-2-9606715ccdf6ade3fb15aa82430fec748cc26212.zip
Fix building with USE=-ipv6 thanks to Andrey Grozin, patch by Andrew Savchenko (bug #395031). Clean up inherit.
(Portage version: 2.2.0_alpha81/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/tcpdump')
-rw-r--r--net-analyzer/tcpdump/ChangeLog7
-rw-r--r--net-analyzer/tcpdump/files/tcpdump-4.2.0-ipv6.patch35
-rw-r--r--net-analyzer/tcpdump/tcpdump-4.2.0.ebuild5
3 files changed, 44 insertions, 3 deletions
diff --git a/net-analyzer/tcpdump/ChangeLog b/net-analyzer/tcpdump/ChangeLog
index 76348560efbd..d4aa10471fec 100644
--- a/net-analyzer/tcpdump/ChangeLog
+++ b/net-analyzer/tcpdump/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/tcpdump
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpdump/ChangeLog,v 1.147 2011/12/16 17:35:10 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpdump/ChangeLog,v 1.148 2011/12/17 14:22:46 jer Exp $
+
+ 17 Dec 2011; Jeroen Roovers <jer@gentoo.org> tcpdump-4.2.0.ebuild,
+ +files/tcpdump-4.2.0-ipv6.patch:
+ Fix building with USE=-ipv6 thanks to Andrey Grozin, patch by Andrew
+ Savchenko (bug #395031). Clean up inherit.
*tcpdump-4.2.0 (16 Dec 2011)
diff --git a/net-analyzer/tcpdump/files/tcpdump-4.2.0-ipv6.patch b/net-analyzer/tcpdump/files/tcpdump-4.2.0-ipv6.patch
new file mode 100644
index 000000000000..ba47b5daec1f
--- /dev/null
+++ b/net-analyzer/tcpdump/files/tcpdump-4.2.0-ipv6.patch
@@ -0,0 +1,35 @@
+Fix compiling with USE=-ipv6 (bug #395031).
+https://bugs.gentoo.org/395031
+
+--- a/tcpdump-4.2.0/print-babel.c
++++ b/tcpdump-4.2.0/print-babel.c
+@@ -115,10 +115,14 @@
+ format_prefix(const u_char *prefix, unsigned char plen)
+ {
+ static char buf[50];
++#ifdef INET6
+ if(plen >= 96 && memcmp(prefix, v4prefix, 12) == 0)
++#endif
+ snprintf(buf, 50, "%s/%u", ipaddr_string(prefix + 12), plen - 96);
++#ifdef INET6
+ else
+ snprintf(buf, 50, "%s/%u", ip6addr_string(prefix), plen);
++#endif
+ buf[49] = '\0';
+ return buf;
+ }
+@@ -126,10 +130,14 @@
+ static const char *
+ format_address(const u_char *prefix)
+ {
++#ifdef INET6
+ if(memcmp(prefix, v4prefix, 12) == 0)
++#endif
+ return ipaddr_string(prefix + 12);
++#ifdef INET6
+ else
+ return ip6addr_string(prefix);
++#endif
+ }
+
+ static int
diff --git a/net-analyzer/tcpdump/tcpdump-4.2.0.ebuild b/net-analyzer/tcpdump/tcpdump-4.2.0.ebuild
index 15191edd00dc..5c07ac352e93 100644
--- a/net-analyzer/tcpdump/tcpdump-4.2.0.ebuild
+++ b/net-analyzer/tcpdump/tcpdump-4.2.0.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpdump/tcpdump-4.2.0.ebuild,v 1.1 2011/12/16 17:35:10 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/tcpdump/tcpdump-4.2.0.ebuild,v 1.2 2011/12/17 14:22:46 jer Exp $
EAPI="4"
-inherit flag-o-matic toolchain-funcs eutils
+inherit eutils flag-o-matic
DESCRIPTION="A Tool for network monitoring and data acquisition"
HOMEPAGE="http://www.tcpdump.org/"
@@ -48,6 +48,7 @@ src_prepare() {
# http://sourceforge.net/tracker/?func=detail&aid=3444149&group_id=53066&atid=469573
# bug #393085
cp "${FILESDIR}"/${P}-ppi.h "${S}/ppi.h" || die
+ epatch "${FILESDIR}"/${P}-ipv6.patch
}
src_configure() {