summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2006-10-14 21:06:36 +0000
committerPeter Volkov <pva@gentoo.org>2006-10-14 21:06:36 +0000
commite036130f2aa221951d2149cda7d9ed1bfec6e0ae (patch)
tree741b9bdf226d767d0394f1db9c5c06af244021fd /net-analyzer/sussen
parentarm/sh love (diff)
downloadgentoo-2-e036130f2aa221951d2149cda7d9ed1bfec6e0ae.tar.gz
gentoo-2-e036130f2aa221951d2149cda7d9ed1bfec6e0ae.tar.bz2
gentoo-2-e036130f2aa221951d2149cda7d9ed1bfec6e0ae.zip
Version bump. Thank upstream dev Loren Bandiera for report.
(Portage version: 2.1.1)
Diffstat (limited to 'net-analyzer/sussen')
-rw-r--r--net-analyzer/sussen/ChangeLog7
-rw-r--r--net-analyzer/sussen/files/digest-sussen-0.303
-rw-r--r--net-analyzer/sussen/sussen-0.30.ebuild101
3 files changed, 110 insertions, 1 deletions
diff --git a/net-analyzer/sussen/ChangeLog b/net-analyzer/sussen/ChangeLog
index 59390c7a4157..c52105e2fd8b 100644
--- a/net-analyzer/sussen/ChangeLog
+++ b/net-analyzer/sussen/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/sussen
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sussen/ChangeLog,v 1.31 2006/09/11 09:21:27 pva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sussen/ChangeLog,v 1.32 2006/10/14 21:06:35 pva Exp $
+
+*sussen-0.30 (14 Oct 2006)
+
+ 14 Oct 2006; Peter Volkov <pva@gentoo.org> +sussen-0.30.ebuild:
+ Version bump. Thank upstream dev Loren Bandiera for report.
11 Sep 2006; Peter Volkov <pva@gentoo.org> sussen-0.29.ebuild:
Added -j1 to emake and thus fixed bug #147103 reported by Graham Murray:
diff --git a/net-analyzer/sussen/files/digest-sussen-0.30 b/net-analyzer/sussen/files/digest-sussen-0.30
new file mode 100644
index 000000000000..17adac0c6256
--- /dev/null
+++ b/net-analyzer/sussen/files/digest-sussen-0.30
@@ -0,0 +1,3 @@
+MD5 4d54cb3f698756c2e6b7d7218423023e sussen-0.30.tar.gz 926084
+RMD160 33f48ba98f3eeed2d56f7e7db8b605372bd7655f sussen-0.30.tar.gz 926084
+SHA256 a0917672b50ee03e70bb1d4024b82ec501ad3771986739de4d3eee4b6c42d827 sussen-0.30.tar.gz 926084
diff --git a/net-analyzer/sussen/sussen-0.30.ebuild b/net-analyzer/sussen/sussen-0.30.ebuild
new file mode 100644
index 000000000000..b43bed41a7aa
--- /dev/null
+++ b/net-analyzer/sussen/sussen-0.30.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/sussen/sussen-0.30.ebuild,v 1.1 2006/10/14 21:06:35 pva Exp $
+
+inherit eutils gnome2 mono
+
+DESCRIPTION="Sussen is a tool that checks for vulnerabilities and configuration issues on computer systems"
+HOMEPAGE="http://dev.mmgsecurity.com/projects/sussen/"
+SRC_URI="http://dev.mmgsecurity.com/downloads/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+# web interface now optional, but does not work.
+#IUSE="doc dbus gnome web"
+IUSE="doc dbus gnome"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+
+RDEPEND=">=dev-lang/mono-1.1
+ gnome? ( >=dev-dotnet/gtk-sharp-2.4
+ >=dev-dotnet/gnome-sharp-2.4
+ >=dev-dotnet/gconf-sharp-2.4
+ >=dev-dotnet/glade-sharp-2.4
+ gnome-base/gnome-panel
+ dbus? ( sys-apps/dbus ) )"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/monodoc-1.1.8 )
+ app-arch/rpm
+ >=dev-util/intltool-0.34.2"
+
+DOCS="AUTHORS ChangeLog README TODO"
+
+pkg_setup() {
+ if use dbus ; then
+ if use gnome; then
+ built_with_use sys-apps/dbus mono || die \
+ "${PN} requires dbus build with mono support. Please, reemerge dbus with USE=\"mono\""
+ else
+ ewarn "dbus is only available and make sense when gnome is enabled."
+ ewarn "If you really want dbus support, please, add gnome to your USE flags."
+ ebeep 5
+ fi
+ fi
+ use gnome || { elog "You do not have gnome in your USE flags.";
+ elog "applet and editor will not be built." ; }
+}
+
+# src_unpack, pkg_postinst, pkg_postrm are exported in gnome2.eclass. But since
+# we have gnome2 support depends on USE let's call gnome2.eclass internal
+# functions only when USE="gnome".
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ use gnome && gnome2_omf_fix
+}
+
+src_compile () {
+ # Put all asp pages in /usr/share/$PF dir instead of /usr/share/sussen
+ sed -i -e \
+ "s:wwwdir = \$(datadir)/doc/sussen/www/asp:wwwdir = \$(datadir)/doc/${PF}/www/asp:" \
+ www/asp/Makefile.in || die "sed failed."
+
+ # $(use_enable web yes)
+ econf ${myconf} \
+ --enable-web=no \
+ $(use_enable dbus) \
+ $(use_enable gnome) || die "./configure failed."
+
+ emake -j1 || die "Compilation failed"
+}
+
+src_install () {
+ make DESTDIR=${D} install || die "Installation failed"
+
+ dodoc ${DOCS}
+
+ if use gnome ; then
+ elog "sussen-applet is a GNOME applet. You can not run it directly from"
+ elog "the command line. Use GNOME panel to invoke it."
+ elog "You can also run it with the --tray-icon command line option."
+ echo
+ ewarn "sussen-editor is still work in progress. Just basic functionality is"
+ ewarn "working."
+ echo
+ ewarn "Beginning with sussen-0.24 default location for oval definitions changed."
+ ewarn "If you had previous versions installed, please, run the following"
+ ewarn "commands to clean outdated locations for each user that run sussen:"
+ ewarn
+ ewarn "gconftool-2 --unset /apps/sussen-applet/oval_xml_directory"
+ ewarn "gconftool-2 --unset /apps/sussen-applet/oval_download_directory"
+ echo
+ fi
+}
+
+pkg_postinst() {
+ use gnome && gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ use gnome && gnome2_pkg_postrm
+}