summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrea Barisani <lcars@gentoo.org>2007-08-27 13:41:52 +0000
committerAndrea Barisani <lcars@gentoo.org>2007-08-27 13:41:52 +0000
commit74ec952fada768ee260cc473da8ed92c248f2c4b (patch)
tree230a8b1ca9933674f133e22d075c9fce4febe79e /net-analyzer/scapy
parentalpha stable wrt #188838 (diff)
downloadgentoo-2-74ec952fada768ee260cc473da8ed92c248f2c4b.tar.gz
gentoo-2-74ec952fada768ee260cc473da8ed92c248f2c4b.tar.bz2
gentoo-2-74ec952fada768ee260cc473da8ed92c248f2c4b.zip
version bump
(Portage version: 2.1.2.12)
Diffstat (limited to 'net-analyzer/scapy')
-rw-r--r--net-analyzer/scapy/ChangeLog7
-rw-r--r--net-analyzer/scapy/files/digest-scapy-1.1.13
-rw-r--r--net-analyzer/scapy/scapy-1.1.1.ebuild55
3 files changed, 64 insertions, 1 deletions
diff --git a/net-analyzer/scapy/ChangeLog b/net-analyzer/scapy/ChangeLog
index 20b720ab9c57..5436e759e4a1 100644
--- a/net-analyzer/scapy/ChangeLog
+++ b/net-analyzer/scapy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/scapy
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/scapy/ChangeLog,v 1.11 2007/02/20 00:29:05 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/scapy/ChangeLog,v 1.12 2007/08/27 13:41:52 lcars Exp $
+
+*scapy-1.1.1 (27 Aug 2007)
+
+ 27 Aug 2007; Andrea Barisani <lcars@gentoo.org> +scapy-1.1.1.ebuild:
+ Version bump.
20 Feb 2007; Markus Ullmann <jokey@gentoo.org> ChangeLog:
Redigest for Manifest2
diff --git a/net-analyzer/scapy/files/digest-scapy-1.1.1 b/net-analyzer/scapy/files/digest-scapy-1.1.1
new file mode 100644
index 000000000000..7e7e374b0880
--- /dev/null
+++ b/net-analyzer/scapy/files/digest-scapy-1.1.1
@@ -0,0 +1,3 @@
+MD5 8ac720a1bea4304797c713ef1ed063f1 scapy-1.1.1.tar.gz 147401
+RMD160 20bdb1ea59a05f452a515e438e230e1d85b81016 scapy-1.1.1.tar.gz 147401
+SHA256 2a11ba05f34b2978af3add623a641e0340d39322b4ca2bd26baae743c78de956 scapy-1.1.1.tar.gz 147401
diff --git a/net-analyzer/scapy/scapy-1.1.1.ebuild b/net-analyzer/scapy/scapy-1.1.1.ebuild
new file mode 100644
index 000000000000..2eaf120e8a72
--- /dev/null
+++ b/net-analyzer/scapy/scapy-1.1.1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/scapy/scapy-1.1.1.ebuild,v 1.1 2007/08/27 13:41:52 lcars Exp $
+
+inherit python multilib
+
+DESCRIPTION="A Python interactive packet manipulation program for mastering the network"
+HOMEPAGE="http://www.secdev.org/projects/scapy/"
+SRC_URI="http://www.secdev.org/projects/scapy/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnuplot pyx crypt graphviz imagemagick visual"
+
+DEPEND="virtual/python"
+RDEPEND="net-analyzer/tcpdump
+ gnuplot? ( dev-python/gnuplot-py )
+ pyx? ( dev-python/pyx )
+ crypt? ( dev-python/pycrypto )
+ graphviz? ( media-gfx/graphviz )
+ imagemagick? ( media-gfx/imagemagick )
+ visual? ( dev-python/visual )"
+
+src_install() {
+ exeinto /usr/bin
+ newexe scapy.py scapy
+
+ # also install scapy as a importable python module
+ python_version
+ insinto /usr/$(get_libdir)/python${PYVER}/site-packages
+ doins scapy.py
+
+ insinto /etc
+ doins ${FILESDIR}/ethertypes
+ dodoc AUTHORS COPYING README changelog.txt
+ doman scapy.1.*
+ }
+
+pkg_postinst() {
+ python_mod_optimize
+
+ einfo ""
+ einfo "- Check http://www.secdev.org/projects/scapy/ for additional info"
+ einfo ""
+ einfo "- To subscribe to the mailing-list, send a mail to scapy.ml-subscribe(at)secdev.org"
+ einfo "- To send a mail to the mailing-list: scapy.ml(at)secdev.org"
+ einfo "- Web archive : http://news.gmane.org/gmane.comp.security.scapy.general"
+ einfo "- NNTP, RSS, etc : http://gmane.org/info.php?group=gmane.comp.security.scapy.general"
+ einfo ""
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}