summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-07-12 16:00:52 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-07-12 16:00:52 +0000
commit4f30826c4b4081de3310fc8c3ab000ea9a0595d3 (patch)
treeba98b6bb3e7a7f07b5108e6375fa12889cdb27d4 /net-analyzer/postal
parentFixed bug #278897 (build failure on ghc-6.10+) (diff)
downloadgentoo-2-4f30826c4b4081de3310fc8c3ab000ea9a0595d3.tar.gz
gentoo-2-4f30826c4b4081de3310fc8c3ab000ea9a0595d3.tar.bz2
gentoo-2-4f30826c4b4081de3310fc8c3ab000ea9a0595d3.zip
Fix building with OpenSSL >= 1.0.0 wrt #327937 by Diego E. Pettenò.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/postal')
-rw-r--r--net-analyzer/postal/ChangeLog8
-rw-r--r--net-analyzer/postal/files/05_postal-0.70-openssl-1.patch30
-rw-r--r--net-analyzer/postal/postal-0.70.ebuild5
3 files changed, 39 insertions, 4 deletions
diff --git a/net-analyzer/postal/ChangeLog b/net-analyzer/postal/ChangeLog
index b1789c92da0e..b4edf6393dcf 100644
--- a/net-analyzer/postal/ChangeLog
+++ b/net-analyzer/postal/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/postal
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/postal/ChangeLog,v 1.6 2008/06/15 12:23:26 dertobi123 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/postal/ChangeLog,v 1.7 2010/07/12 16:00:52 ssuominen Exp $
+
+ 12 Jul 2010; Samuli Suominen <ssuominen@gentoo.org> postal-0.70.ebuild,
+ +files/05_postal-0.70-openssl-1.patch:
+ Fix building with OpenSSL >= 1.0.0 wrt #327937 by Diego E. Pettenò.
*postal-0.70 (15 Jun 2008)
diff --git a/net-analyzer/postal/files/05_postal-0.70-openssl-1.patch b/net-analyzer/postal/files/05_postal-0.70-openssl-1.patch
new file mode 100644
index 000000000000..5b5c054ac98c
--- /dev/null
+++ b/net-analyzer/postal/files/05_postal-0.70-openssl-1.patch
@@ -0,0 +1,30 @@
+http://bugs.gentoo.org/327937
+
+--- basictcp.h
++++ basictcp.h
+@@ -89,7 +89,11 @@
+
+ #ifdef USE_SSL
+ #ifdef USE_OPENSSL
++ #if OPENSSL_VERSION_NUMBER >= 0x10000000L
++ const SSL_METHOD *m_sslMeth;
++ #else
+ SSL_METHOD *m_sslMeth;
++ #endif
+ SSL_CTX* m_sslCtx;
+ SSL *m_ssl;
+ #else
+--- tcp.h
++++ tcp.h
+@@ -100,7 +100,11 @@
+
+ #ifdef USE_SSL
+ #ifdef USE_OPENSSL
++ #if OPENSSL_VERSION_NUMBER >= 0x10000000L
++ const SSL_METHOD *m_sslMeth;
++ #else
+ SSL_METHOD *m_sslMeth;
++ #endif
+ SSL_CTX* m_sslCtx;
+ SSL *m_ssl;
+ #else
diff --git a/net-analyzer/postal/postal-0.70.ebuild b/net-analyzer/postal/postal-0.70.ebuild
index 7584f981e647..0451bd2b0828 100644
--- a/net-analyzer/postal/postal-0.70.ebuild
+++ b/net-analyzer/postal/postal-0.70.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/postal/postal-0.70.ebuild,v 1.1 2008/06/15 12:23:26 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/postal/postal-0.70.ebuild,v 1.2 2010/07/12 16:00:52 ssuominen Exp $
inherit autotools eutils
@@ -32,6 +32,7 @@ src_unpack() {
epatch "${FILESDIR}/02_${P}-nossl.patch"
epatch "${FILESDIR}/03_${P}-c++0x-integrated.patch"
epatch "${FILESDIR}/04_${P}-warnings.patch"
+ epatch "${FILESDIR}/05_${P}-openssl-1.patch"
eautoreconf
}