summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCédric Krier <cedk@gentoo.org>2007-01-15 22:00:38 +0000
committerCédric Krier <cedk@gentoo.org>2007-01-15 22:00:38 +0000
commitdfa9c69a5aca1f419e8ce2e5cfa4430e63e0455e (patch)
tree0bd4ee8a480556d4616de625ebef455feebd9e5c /net-analyzer/pmacct
parentCleanup. (diff)
downloadgentoo-2-dfa9c69a5aca1f419e8ce2e5cfa4430e63e0455e.tar.gz
gentoo-2-dfa9c69a5aca1f419e8ce2e5cfa4430e63e0455e.tar.bz2
gentoo-2-dfa9c69a5aca1f419e8ce2e5cfa4430e63e0455e.zip
Add sqlite3 flag for bug #144520
(Portage version: 2.1.1-r2)
Diffstat (limited to 'net-analyzer/pmacct')
-rw-r--r--net-analyzer/pmacct/ChangeLog9
-rw-r--r--net-analyzer/pmacct/files/digest-pmacct-0.11.2-r13
-rw-r--r--net-analyzer/pmacct/pmacct-0.11.2-r1.ebuild56
3 files changed, 66 insertions, 2 deletions
diff --git a/net-analyzer/pmacct/ChangeLog b/net-analyzer/pmacct/ChangeLog
index b94d9e530bde..6643328f8cad 100644
--- a/net-analyzer/pmacct/ChangeLog
+++ b/net-analyzer/pmacct/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/pmacct
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/ChangeLog,v 1.44 2006/12/02 15:33:25 vanquirius Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/ChangeLog,v 1.45 2007/01/15 22:00:38 cedk Exp $
+
+*pmacct-0.11.2-r1 (15 Jan 2007)
+
+ 15 Jan 2007; Cedric Krier <cedk@gentoo.org> +pmacct-0.11.2-r1.ebuild:
+ Add sqlite3 flag for bug #144520
*pmacct-0.11.2 (02 Dec 2006)
diff --git a/net-analyzer/pmacct/files/digest-pmacct-0.11.2-r1 b/net-analyzer/pmacct/files/digest-pmacct-0.11.2-r1
new file mode 100644
index 000000000000..d1b51d272306
--- /dev/null
+++ b/net-analyzer/pmacct/files/digest-pmacct-0.11.2-r1
@@ -0,0 +1,3 @@
+MD5 90a16305fce4ebcfdce255cc1b256b1f pmacct-0.11.2.tar.gz 411711
+RMD160 99bead4c09b060854bff72b18ac7150097e78643 pmacct-0.11.2.tar.gz 411711
+SHA256 6d8346944c987a2ec9e6b29cbbc2a886007a2535b9d506051ef6afe96faac625 pmacct-0.11.2.tar.gz 411711
diff --git a/net-analyzer/pmacct/pmacct-0.11.2-r1.ebuild b/net-analyzer/pmacct/pmacct-0.11.2-r1.ebuild
new file mode 100644
index 000000000000..0f44be69904b
--- /dev/null
+++ b/net-analyzer/pmacct/pmacct-0.11.2-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/pmacct/pmacct-0.11.2-r1.ebuild,v 1.1 2007/01/15 22:00:38 cedk Exp $
+
+DESCRIPTION="A network tool to gather ip traffic informations"
+HOMEPAGE="http://www.pmacct.net/"
+SRC_URI="http://www.pmacct.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="64bit debug ipv6 mmap mysql postgres sqlite3"
+
+RDEPEND="net-libs/libpcap
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql )
+ sqlite3? ( =dev-db/sqlite-3* )"
+DEPEND="${RDEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i "s|\(CFLAGS=\).*$|\1\"${CFLAGS}\"|g" configure || die "sed failed"
+}
+
+src_compile() {
+ econf \
+ $(use_enable mysql) \
+ $(use_enable postgres pgsql) \
+ $(use_enable mmap) \
+ $(use_enable ipv6) \
+ $(use_enable debug) \
+ $(use_enable 64bit) \
+ $(use_enable sqlite3) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc README EXAMPLES KNOWN-BUGS CONFIG-KEYS FAQS ChangeLog docs/SIGNALS \
+ docs/PLUGINS docs/INTERNALS TODO TOOLS || die "dodoc failed"
+
+ for dirname in examples sql; do
+ docinto ${dirname}
+ dodoc ${dirname}/* || die "dodoc ${dirname} failed"
+ done
+
+ newinitd "${FILESDIR}"/pmacctd-init.d pmacctd || die "newinitd failed"
+ newconfd "${FILESDIR}"/pmacctd-conf.d pmacctd || die "newconfd failed"
+
+ insinto /etc
+ newins "${S}"/examples/pmacctd-imt.conf.example pmacctd.conf.example || \
+ die "newins failed"
+}