summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaik Schreiber <blizzy@gentoo.org>2002-07-11 13:36:19 +0000
committerMaik Schreiber <blizzy@gentoo.org>2002-07-11 13:36:19 +0000
commite6faf20b732b982b0c45315df9a671527a35d910 (patch)
tree7499fa6f105ee5a683b62d9812a90326ffa02aac /net-analyzer/ntop
parentapplied tcp-wrappers patch, closes bugs #4774, #4772 and #4832 (diff)
downloadgentoo-2-e6faf20b732b982b0c45315df9a671527a35d910.tar.gz
gentoo-2-e6faf20b732b982b0c45315df9a671527a35d910.tar.bz2
gentoo-2-e6faf20b732b982b0c45315df9a671527a35d910.zip
removed ntop-2.0.99_rc2 and ntop-2.0.99_rc2-r1 due to b0rkenness
Diffstat (limited to 'net-analyzer/ntop')
-rw-r--r--net-analyzer/ntop/ntop-2.0.99_rc2-r1.ebuild96
-rw-r--r--net-analyzer/ntop/ntop-2.0.99_rc2.ebuild89
2 files changed, 0 insertions, 185 deletions
diff --git a/net-analyzer/ntop/ntop-2.0.99_rc2-r1.ebuild b/net-analyzer/ntop/ntop-2.0.99_rc2-r1.ebuild
deleted file mode 100644
index b0411d96272f..000000000000
--- a/net-analyzer/ntop/ntop-2.0.99_rc2-r1.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-2.0.99_rc2-r1.ebuild,v 1.1 2002/07/09 15:41:28 blizzy Exp $
-
-A=ntop-2.0.99-rc2.tgz
-S=${WORKDIR}/RC2/ntop
-
-DESCRIPTION="ntop is a unix tool that shows network usage like top"
-SRC_URI="http://luca.ntop.org/${A}"
-HOMEPAGE="http://www.ntop.org/ntop.html"
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="*"
-
-DEPEND="virtual/glibc sys-devel/gcc
- >=sys-libs/gdbm-1.8.0
- >=net-libs/libpcap-0.5.2
- ssl? ( >=dev-libs/openssl-0.9.6 )
- mysql? ( dev-db/mysql )
- readline? ( >=sys-libs/readline-4.1 )
- >=sys-apps/tcp-wrappers-7.6"
-# tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
-# Disabling tcp-wrappers seems to be b0rken (see bug #4678),
-# so I made this a requirement for now. --blizzy
-
-RDEPEND="${DEPEND}"
-
-src_compile() {
- local myconf
- if [ -z "`use ssl`" ] ; then
- myconf="--disable-ssl"
- else
- cp configure configure.orig
- sed -e "s:/usr/local/ssl:/usr:" configure.orig > configure
- export CFLAGS="$CFLAGS -I/usr/include/openssl"
- fi
-
- use mysql || myconf="${myconf} --disable-mysql"
- use readline || myconf="${myconf} --disable-readline"
-# see above --blizzy
-# use tcpd || myconf="${myconf} --enable-tcpwrap"
- myconf="${myconf} --enable-tcpwrap"
-
- # ntop 2.0 ships with its own version of gdchart... gdchart should
- # get its own package but ntop should be built with the version it
- # shipped with just in case future versions are incompatible -- blocke
-
- # compile gdchart
- cd ../gdchart0.94c
- ./configure || die "gdchart configure problem"
-
- # subtree #1
- cd gd-1.8.3/libpng-1.2.1
- make -f scripts/makefile.linux || die "libpng compile problem"
-
- # subtree #2
- cd ../../zlib-1.1.4/
- ./configure || die "zlib configure problem"
- make || die "zlib compile problem"
-
- # gdchart make
- cd ../
- make || die "gdchart compile problem"
-
- # now ntop itself...
- cd ../ntop
- econf ${myconf} || die "configure problem"
- make || die "compile problem"
-}
-
-src_install () {
- # slight issue with man file installation
- mv Makefile Makefile.orig
- sed 's/man_MANS = ntop.8 intop\/intop.1//g' Makefile.orig > Makefile
-
- make \
- prefix=${D}/usr \
- sysconfdir=/${D}/etc \
- mandir=${D}/usr/share/man \
- datadir=${D}/usr/share \
- DATAFILE_DIR=${D}/usr/share/ntop \
- CONFIGFILE_DIR=${D}/etc/ntop \
- install || die "install problem"
-
- # fixme: bad handling of plugins (in /usr/lib with unsuggestive names)
- # (don't know if there is a clean way to handle it)
-
- doman ntop-rules.8 ntop.8
-
- dodoc AUTHORS CONTENTS COPYING ChangeLog MANIFESTO NEWS
- dodoc PORTING README SUPPORT_NTOP.txt THANKS
-
- dohtml ntop.html
-
- dodir /var/lib/ntop
-}
diff --git a/net-analyzer/ntop/ntop-2.0.99_rc2.ebuild b/net-analyzer/ntop/ntop-2.0.99_rc2.ebuild
deleted file mode 100644
index 1e3db2ae4aec..000000000000
--- a/net-analyzer/ntop/ntop-2.0.99_rc2.ebuild
+++ /dev/null
@@ -1,89 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ntop/ntop-2.0.99_rc2.ebuild,v 1.2 2002/07/11 06:30:45 drobbins Exp $
-
-A=ntop-2.0.99-rc2.tgz
-S=${WORKDIR}/RC2/ntop
-DESCRIPTION="ntop is a unix tool that shows network usage like top"
-SRC_URI="http://luca.ntop.org/${A}"
-HOMEPAGE="http://www.ntop.org/ntop.html"
-DEPEND="virtual/glibc sys-devel/gcc
- >=sys-libs/gdbm-1.8.0
- >=net-libs/libpcap-0.5.2
- ssl? ( >=dev-libs/openssl-0.9.6 )
- mysql? ( dev-db/mysql )
- tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
- readline? ( >=sys-libs/readline-4.1 )"
-
-RDEPEND="${DEPEND}"
-
-src_compile() {
-
- local myconf
- if [ -z "`use ssl`" ] ; then
- myconf="--disable-ssl"
- else
- cp configure configure.orig
- sed -e "s:/usr/local/ssl:/usr:" configure.orig > configure
- export CFLAGS="$CFLAGS -I/usr/include/openssl"
- fi
-
- use mysql || myconf="${myconf} --disable-mysql"
- use readline || myconf="${myconf} --disable-readline"
- use tcpd || myconf="${myconf} --enable-tcpwrap"
-
- # ntop 2.0 ships with its own version of gdchart... gdchart should
- # get its own package but ntop should be built with the version it
- # shipped with just in case future versions are incompatible -- blocke
-
- # compile gdchart
- cd ../gdchart0.94c
- ./configure || die
-
- # subtree #1
- cd gd-1.8.3/libpng-1.2.1
- make -f scripts/makefile.linux || die
-
- # subtree #2
- cd ../../zlib-1.1.4/
- ./configure || die
- make || die
-
- # gdchart make
- cd ../
- make || die
-
- # now ntop itself...
- cd ../ntop
- econf ${myconf} || die
- make || die
-
-}
-
-src_install () {
-
- # slight issue with man file installation
- mv Makefile Makefile.orig
- sed 's/man_MANS = ntop.8 intop\/intop.1//g' Makefile.orig > Makefile
-
- make \
- prefix=${D}/usr \
- sysconfdir=/${D}/etc \
- mandir=${D}/usr/share/man \
- datadir=${D}/usr/share \
- DATAFILE_DIR=${D}/usr/share/ntop \
- CONFIGFILE_DIR=${D}/etc/ntop \
- install || die
-
- # fixme: bad handling of plugins (in /usr/lib with unsuggestive names)
- # (don't know if there is a clean way to handle it)
-
- doman ntop-rules.8 ntop.8
-
- dodoc AUTHORS CONTENTS COPYING ChangeLog INSTALL MANIFESTO NEWS
- dodoc PORTING README SUPPORT_NTOP.txt THANKS
-
- dohtml ntop.html
-
- dodir /var/lib/ntop
-}