summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2006-03-11 18:36:01 +0000
committerMichael Januszewski <spock@gentoo.org>2006-03-11 18:36:01 +0000
commit31c59b840b3dd759ebe719eb3ec70ff38061c3b4 (patch)
tree0b9f556b628cff2612c0ac05c76cf09dca7796bf /net-analyzer/nmap
parent2.2.6 version bump for bug 124991. It should fix glibc 2.4 support. Thanks to... (diff)
downloadgentoo-2-31c59b840b3dd759ebe719eb3ec70ff38061c3b4.tar.gz
gentoo-2-31c59b840b3dd759ebe719eb3ec70ff38061c3b4.tar.bz2
gentoo-2-31c59b840b3dd759ebe719eb3ec70ff38061c3b4.zip
Added a patch to avoid stripping during install.
(Portage version: 2.1_pre5-r4)
Diffstat (limited to 'net-analyzer/nmap')
-rw-r--r--net-analyzer/nmap/ChangeLog6
-rw-r--r--net-analyzer/nmap/files/nmap-4.01-nostrip.patch22
-rw-r--r--net-analyzer/nmap/nmap-4.01.ebuild3
3 files changed, 29 insertions, 2 deletions
diff --git a/net-analyzer/nmap/ChangeLog b/net-analyzer/nmap/ChangeLog
index 0525f9517a9d..5a7331f3789b 100644
--- a/net-analyzer/nmap/ChangeLog
+++ b/net-analyzer/nmap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/nmap
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.110 2006/02/14 22:08:41 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/ChangeLog,v 1.111 2006/03/11 18:36:01 spock Exp $
+
+ 11 Mar 2006; Michał Januszewski <spock@gentoo.org>
+ +files/nmap-4.01-nostrip.patch, nmap-4.01.ebuild:
+ Added a patch to avoid stripping during install (bug #125547).
*nmap-4.01 (14 Feb 2006)
diff --git a/net-analyzer/nmap/files/nmap-4.01-nostrip.patch b/net-analyzer/nmap/files/nmap-4.01-nostrip.patch
new file mode 100644
index 000000000000..c8894fa881d0
--- /dev/null
+++ b/net-analyzer/nmap/files/nmap-4.01-nostrip.patch
@@ -0,0 +1,22 @@
+Index: nmap-4.01/Makefile.in
+===================================================================
+--- nmap-4.01.orig/Makefile.in
++++ nmap-4.01/Makefile.in
+@@ -144,7 +144,7 @@ depend:
+
+ install-nmap: $(TARGET)
+ $(SHTOOL) mkdir -f -p -m 755 $(DESTDIR)$(bindir) $(DESTDIR)$(mandir)/man1 $(DESTDIR)$(nmapdatadir)
+- $(INSTALL) -c -m 755 -s nmap $(DESTDIR)$(bindir)/nmap
++ $(INSTALL) -c -m 755 nmap $(DESTDIR)$(bindir)/nmap
+ $(INSTALL) -c -m 644 docs/$(TARGET).1 $(DESTDIR)$(mandir)/man1/$(TARGET).1
+ $(INSTALL) -c -m 644 docs/nmap.xsl $(DESTDIR)$(nmapdatadir)/
+ $(INSTALL) -c -m 644 docs/nmap.dtd $(DESTDIR)$(nmapdatadir)/
+@@ -158,7 +158,7 @@ install-nmap: $(TARGET)
+ install-nmapfe: $(TARGETNMAPFE)
+ $(SHTOOL) mkdir -f -p -m 755 $(DESTDIR)$(bindir) $(DESTDIR)$(mandir)/man1 $(DESTDIR)$(nmapdatadir) $(DESTDIR)$(deskdir)
+ @echo "If the next command fails -- you cannot use the X front end"
+- -test -f nmapfe/nmapfe && $(INSTALL) -c -m 755 -s nmapfe/nmapfe $(DESTDIR)$(bindir)/nmapfe && rm -f $(DESTDIR)$(bindir)/xnmap && $(SHTOOL) mkln -f -s $(DESTDIR)$(bindir)/nmapfe $(DESTDIR)$(bindir)/xnmap && $(INSTALL) -c -m 644 nmapfe.desktop $(DESTDIR)$(deskdir)/nmapfe.desktop && $(INSTALL) -c -m 644 docs/nmapfe.1 $(DESTDIR)$(mandir)/man1/nmapfe.1 && $(INSTALL) -c -m 644 docs/xnmap.1 $(DESTDIR)$(mandir)/man1/xnmap.1
++ -test -f nmapfe/nmapfe && $(INSTALL) -c -m 755 nmapfe/nmapfe $(DESTDIR)$(bindir)/nmapfe && rm -f $(DESTDIR)$(bindir)/xnmap && $(SHTOOL) mkln -f -s $(DESTDIR)$(bindir)/nmapfe $(DESTDIR)$(bindir)/xnmap && $(INSTALL) -c -m 644 nmapfe.desktop $(DESTDIR)$(deskdir)/nmapfe.desktop && $(INSTALL) -c -m 644 docs/nmapfe.1 $(DESTDIR)$(mandir)/man1/nmapfe.1 && $(INSTALL) -c -m 644 docs/xnmap.1 $(DESTDIR)$(mandir)/man1/xnmap.1
+
+ install: install-nmap $(INSTALLNMAPFE)
+
diff --git a/net-analyzer/nmap/nmap-4.01.ebuild b/net-analyzer/nmap/nmap-4.01.ebuild
index 7012ec48eb53..04f907caaafe 100644
--- a/net-analyzer/nmap/nmap-4.01.ebuild
+++ b/net-analyzer/nmap/nmap-4.01.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-4.01.ebuild,v 1.1 2006/02/14 22:08:41 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nmap/nmap-4.01.ebuild,v 1.2 2006/03/11 18:36:01 spock Exp $
inherit eutils flag-o-matic
@@ -24,6 +24,7 @@ src_unpack() {
sed 's:Icon=icon-network:Icon=nmap-logo-64.png:' -i nmapfe.desktop
echo ";" >> nmapfe.desktop
epatch ${FILESDIR}/nmap-shtool-nls.patch
+ epatch ${FILESDIR}/nmap-4.01-nostrip.patch
}
src_compile() {