summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2005-03-13 20:51:10 +0000
committerMichael Cummings <mcummings@gentoo.org>2005-03-13 20:51:10 +0000
commitaeac0a02ec8542a47929a1e60717131870e85177 (patch)
tree574fbbf9a4fe27dad0f187945e791762be88c4f3 /net-analyzer/nikto/nikto-1.34-r1.ebuild
parentRevision bump, which includes ppc64 patch (diff)
downloadgentoo-2-aeac0a02ec8542a47929a1e60717131870e85177.tar.gz
gentoo-2-aeac0a02ec8542a47929a1e60717131870e85177.tar.bz2
gentoo-2-aeac0a02ec8542a47929a1e60717131870e85177.zip
bug 70465
(Portage version: 2.0.51.19)
Diffstat (limited to 'net-analyzer/nikto/nikto-1.34-r1.ebuild')
-rw-r--r--net-analyzer/nikto/nikto-1.34-r1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-analyzer/nikto/nikto-1.34-r1.ebuild b/net-analyzer/nikto/nikto-1.34-r1.ebuild
new file mode 100644
index 000000000000..8dbb5ecfebcb
--- /dev/null
+++ b/net-analyzer/nikto/nikto-1.34-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/nikto/nikto-1.34-r1.ebuild,v 1.1 2005/03/13 20:51:10 mcummings Exp $
+
+DESCRIPTION="Web Server vulnerability scanner."
+HOMEPAGE="http://www.cirt.net/code/nikto.shtml"
+SRC_URI="http://www.cirt.net/source/nikto/ARCHIVE/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc"
+RDEPEND="dev-lang/perl
+ >=net-analyzer/nmap-3.00
+ ssl? ( dev-libs/openssl )"
+IUSE="ssl"
+
+src_compile() {
+ sed -i -e 's:config.txt:nikto.conf:' \
+ -i -e 's:\$CFG{configfile}="nikto.conf":\$CFG{configfile}="/etc/nikto/nikto.conf":' \
+ nikto.pl
+
+ mv config.txt nikto.conf
+
+ sed -i -e 's:^#NMAP:NMAP:' \
+ -i -e 's:^PROXYHOST:#PROXYHOST:' \
+ -i -e 's:^PROXYPORT:#PROXYPORT:' \
+ -i -e 's:^PROXYUSER:#PROXYUSER:' \
+ -i -e 's:^PROXYPASS:#PROXYPASS:' \
+ -i -e 's:# PLUGINDIR=/usr/local/nikto/plugins:PLUGINDIR=/usr/share/nikto/plugins:' \
+ nikto.conf
+}
+
+src_install() {
+ insinto /etc/nikto
+ doins nikto.conf
+
+ dodir /usr/bin
+ dobin nikto.pl
+ dosym /usr/bin/nikto.pl /usr/bin/nikto
+
+ dodir /usr/share/nikto/plugins
+ insinto /usr/share/nikto/plugins
+ doins plugins/*
+
+ cd docs
+ dodoc CHANGES.txt LICENSE.txt README_plugins.txt nikto_usage.txt
+ dohtml nikto_usage.html
+}