summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-16 21:00:16 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-16 21:00:16 +0000
commit89b4bc3b2140bbca6e6656d6403ad72cd51e8777 (patch)
tree1b33931378470013e1117119adfe8b38b982bd56 /net-analyzer/fragroute
parentwhitespace (diff)
downloadgentoo-2-89b4bc3b2140bbca6e6656d6403ad72cd51e8777.tar.gz
gentoo-2-89b4bc3b2140bbca6e6656d6403ad72cd51e8777.tar.bz2
gentoo-2-89b4bc3b2140bbca6e6656d6403ad72cd51e8777.zip
Fixed compilation agianst newer libevent, #295877
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'net-analyzer/fragroute')
-rw-r--r--net-analyzer/fragroute/ChangeLog8
-rw-r--r--net-analyzer/fragroute/files/1.2-libevent.patch20
-rw-r--r--net-analyzer/fragroute/fragroute-1.2-r1.ebuild35
3 files changed, 62 insertions, 1 deletions
diff --git a/net-analyzer/fragroute/ChangeLog b/net-analyzer/fragroute/ChangeLog
index bb526026efd0..d9b6a41819ca 100644
--- a/net-analyzer/fragroute/ChangeLog
+++ b/net-analyzer/fragroute/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/fragroute
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fragroute/ChangeLog,v 1.16 2010/01/15 19:52:41 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fragroute/ChangeLog,v 1.17 2010/02/16 21:00:15 jlec Exp $
+
+*fragroute-1.2-r1 (16 Feb 2010)
+
+ 16 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +files/1.2-libevent.patch, +fragroute-1.2-r1.ebuild:
+ Fixed compilation agianst newer libevent, #295877
15 Jan 2010; Ulrich Mueller <ulm@gentoo.org> fragroute-1.2.ebuild:
LICENSE is identical with BSD, bug 301123.
diff --git a/net-analyzer/fragroute/files/1.2-libevent.patch b/net-analyzer/fragroute/files/1.2-libevent.patch
new file mode 100644
index 000000000000..64a30baebeb1
--- /dev/null
+++ b/net-analyzer/fragroute/files/1.2-libevent.patch
@@ -0,0 +1,20 @@
+diff --git a/fragroute.c b/fragroute.c
+index dc07ce3..29d1007 100644
+--- a/fragroute.c
++++ b/fragroute.c
+@@ -148,7 +148,6 @@ static void
+ fragroute_signal(int sig)
+ {
+ warnx("exiting on signal %d", sig);
+- event_gotsig++;
+ }
+ #endif
+
+@@ -178,7 +177,6 @@ fragroute_init(const char *dst)
+ pkt_init(128);
+
+ event_init();
+- event_sigcb = fragroute_close;
+
+ if ((ctx.arp = arp_open()) == NULL ||
+ (ctx.intf = intf_open()) == NULL ||
diff --git a/net-analyzer/fragroute/fragroute-1.2-r1.ebuild b/net-analyzer/fragroute/fragroute-1.2-r1.ebuild
new file mode 100644
index 000000000000..d9941b4f3bb4
--- /dev/null
+++ b/net-analyzer/fragroute/fragroute-1.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/fragroute/fragroute-1.2-r1.ebuild,v 1.1 2010/02/16 21:00:15 jlec Exp $
+
+EAPI="3"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Testing of network intrusion detection systems, firewalls and TCP/IP stacks"
+HOMEPAGE="http://www.monkey.org/~dugsong/fragroute/"
+SRC_URI="http://www.monkey.org/~dugsong/fragroute/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-libs/libevent-0.6
+ net-libs/libpcap
+ >=dev-libs/libdnet-1.4"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-libevent.patch
+ tc-export CC
+}
+
+src_configure() {
+ econf --with-libevent="${EPREFIX}"/usr --with-libdnet="${EPREFIX}"/usr
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc README || die
+}