summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-04-11 02:19:27 +0000
committerTim Harder <radhermit@gentoo.org>2014-04-11 02:19:27 +0000
commit6df0ac873fd37e81c4984fb3c140242ef068b12b (patch)
tree7a2fe5340dd1afa30da8c0591d0da0104694d465 /net-analyzer/flowgrind
parentVersion bump. (diff)
downloadgentoo-2-6df0ac873fd37e81c4984fb3c140242ef068b12b.tar.gz
gentoo-2-6df0ac873fd37e81c4984fb3c140242ef068b12b.tar.bz2
gentoo-2-6df0ac873fd37e81c4984fb3c140242ef068b12b.zip
Version bump.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'net-analyzer/flowgrind')
-rw-r--r--net-analyzer/flowgrind/ChangeLog9
-rw-r--r--net-analyzer/flowgrind/flowgrind-0.7.ebuild26
2 files changed, 33 insertions, 2 deletions
diff --git a/net-analyzer/flowgrind/ChangeLog b/net-analyzer/flowgrind/ChangeLog
index 39387e50ad66..3fb6593a8980 100644
--- a/net-analyzer/flowgrind/ChangeLog
+++ b/net-analyzer/flowgrind/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/flowgrind
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/flowgrind/ChangeLog,v 1.8 2013/07/10 16:37:49 jer Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/flowgrind/ChangeLog,v 1.9 2014/04/11 02:19:27 radhermit Exp $
+
+*flowgrind-0.7 (11 Apr 2014)
+
+ 11 Apr 2014; Tim Harder <radhermit@gentoo.org> +flowgrind-0.7.ebuild:
+ Version bump.
10 Jul 2013; Jeroen Roovers <jer@gentoo.org> -flowgrind-0.5.8.ebuild,
-flowgrind-0.6.0.ebuild:
diff --git a/net-analyzer/flowgrind/flowgrind-0.7.ebuild b/net-analyzer/flowgrind/flowgrind-0.7.ebuild
new file mode 100644
index 000000000000..df7a58923d89
--- /dev/null
+++ b/net-analyzer/flowgrind/flowgrind-0.7.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/flowgrind/flowgrind-0.7.ebuild,v 1.1 2014/04/11 02:19:27 radhermit Exp $
+
+EAPI=5
+
+DESCRIPTION="Network performance measurement tool"
+HOMEPAGE="http://flowgrind.net/ https://github.com/flowgrind/flowgrind/"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug gsl pcap"
+
+RDEPEND="dev-libs/xmlrpc-c[abyss,curl]
+ gsl? ( sci-libs/gsl )
+ pcap? ( net-libs/libpcap )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable gsl) \
+ $(use_enable pcap)
+}