summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-02-26 15:23:03 +0000
committerJeroen Roovers <jer@gentoo.org>2013-02-26 15:23:03 +0000
commita115883f25ba0dbed861e9ecdbd779f2db625856 (patch)
tree01ec39be5ea38b5cbe1322a96910971c436de892 /net-analyzer/flow-tools
parentEnable multilib. (diff)
downloadgentoo-2-a115883f25ba0dbed861e9ecdbd779f2db625856.tar.gz
gentoo-2-a115883f25ba0dbed861e9ecdbd779f2db625856.tar.bz2
gentoo-2-a115883f25ba0dbed861e9ecdbd779f2db625856.zip
Replace deprecated start-stop-daemon option (bug #458942 by Reuben Farrelly).
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-analyzer/flow-tools')
-rw-r--r--net-analyzer/flow-tools/ChangeLog6
-rwxr-xr-xnet-analyzer/flow-tools/files/flowcapture.initd4
-rw-r--r--net-analyzer/flow-tools/flow-tools-0.68.5.1-r1.ebuild70
3 files changed, 7 insertions, 73 deletions
diff --git a/net-analyzer/flow-tools/ChangeLog b/net-analyzer/flow-tools/ChangeLog
index 936275929beb..b70f5cca72c1 100644
--- a/net-analyzer/flow-tools/ChangeLog
+++ b/net-analyzer/flow-tools/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/flow-tools
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/flow-tools/ChangeLog,v 1.64 2013/01/31 23:11:03 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/flow-tools/ChangeLog,v 1.65 2013/02/26 15:23:03 jer Exp $
+
+ 26 Feb 2013; Jeroen Roovers <jer@gentoo.org> -flow-tools-0.68.5.1-r1.ebuild,
+ files/flowcapture.initd:
+ Replace deprecated start-stop-daemon option (bug #458942 by Reuben Farrelly).
31 Jan 2013; Agostino Sarubbo <ago@gentoo.org> flow-tools-0.68.5.1-r2.ebuild:
Stable for ppc, wrt bug #454004
diff --git a/net-analyzer/flow-tools/files/flowcapture.initd b/net-analyzer/flow-tools/files/flowcapture.initd
index 924331fe5b6a..9a2c1a6df044 100755
--- a/net-analyzer/flow-tools/files/flowcapture.initd
+++ b/net-analyzer/flow-tools/files/flowcapture.initd
@@ -1,5 +1,5 @@
#!/sbin/runscript
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
depend() {
@@ -8,7 +8,7 @@ depend() {
start() {
ebegin "Starting flow-capture"
- start-stop-daemon --start -c ${USER} --exec /usr/bin/flow-capture \
+ start-stop-daemon --start --user ${USER} --exec /usr/bin/flow-capture \
--pidfile ${PIDFILE}.${PORT} \
-- ${FLOW_OPTS} >/dev/null 2>&1
eend $?
diff --git a/net-analyzer/flow-tools/flow-tools-0.68.5.1-r1.ebuild b/net-analyzer/flow-tools/flow-tools-0.68.5.1-r1.ebuild
deleted file mode 100644
index 7ff1f946dde0..000000000000
--- a/net-analyzer/flow-tools/flow-tools-0.68.5.1-r1.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/flow-tools/flow-tools-0.68.5.1-r1.ebuild,v 1.6 2012/11/21 04:08:34 jer Exp $
-
-EAPI=4
-inherit user
-
-DESCRIPTION="library and programs to collect, send, process, and generate reports from NetFlow data"
-HOMEPAGE="http://code.google.com/p/flow-tools/"
-SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.bz2"
-
-LICENSE="BSD GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE="debug mysql postgres ssl static-libs"
-
-RDEPEND="sys-apps/tcp-wrappers
- sys-libs/zlib
- mysql? ( virtual/mysql )
- postgres? ( dev-db/postgresql-base )
- ssl? ( dev-libs/openssl )"
-
-DEPEND="${RDEPEND}
- sys-devel/flex
- sys-devel/bison"
-
-DOCS=( ChangeLog README SECURITY TODO )
-
-pkg_setup() {
- enewgroup flows
- enewuser flows -1 -1 /var/lib/flows flows
-}
-
-src_configure() {
- local myconf="--sysconfdir=/etc/flow-tools"
- use mysql && myconf="${myconf} --with-mysql"
- if use postgres; then
- myconf="${myconf} --with-postgresql=yes"
- else
- myconf="${myconf} --with-postgresql=no"
- fi
- use ssl && myconf="${myconf} --with-openssl"
- econf ${myconf} $(use_enable static-libs static)
-}
-
-src_install() {
- default
-
- keepdir /var/lib/flows
- keepdir /var/lib/flows/bin
- exeinto /var/lib/flows/bin
- doexe "${FILESDIR}"/linkme
- keepdir /var/run/flows
-
- newinitd "${FILESDIR}/flowcapture.initd" flowcapture
- newconfd "${FILESDIR}/flowcapture.confd" flowcapture
-
- if ! use static-libs; then
- rm -f "${D}"/usr/lib*/libft.la || die
- fi
-}
-
-pkg_postinst() {
- chown flows:flows /var/run/flows
- chown flows:flows /var/lib/flows
- chown flows:flows /var/lib/flows/bin
- chmod 0755 /var/run/flows
- chmod 0755 /var/lib/flows
- chmod 0755 /var/lib/flows/bin
-}