summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-12-27 17:32:24 +0000
committerJeroen Roovers <jer@gentoo.org>2010-12-27 17:32:24 +0000
commitd0409e86c85c678dbf461a7d52ed36ec932e290e (patch)
tree098b6b4aba0165324390ddb5f1f335e2207dd141 /net-analyzer/ethloop/ethloop-10-r3.ebuild
parentVersion bump #349871 by Panagiotis Christopoulos. (diff)
downloadgentoo-2-d0409e86c85c678dbf461a7d52ed36ec932e290e.tar.gz
gentoo-2-d0409e86c85c678dbf461a7d52ed36ec932e290e.tar.bz2
gentoo-2-d0409e86c85c678dbf461a7d52ed36ec932e290e.zip
Really really really fix recv call (bug #336755).
(Portage version: 2.2.0_alpha10/cvs/Linux i686)
Diffstat (limited to 'net-analyzer/ethloop/ethloop-10-r3.ebuild')
-rw-r--r--net-analyzer/ethloop/ethloop-10-r3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-analyzer/ethloop/ethloop-10-r3.ebuild b/net-analyzer/ethloop/ethloop-10-r3.ebuild
new file mode 100644
index 000000000000..54b381c958c5
--- /dev/null
+++ b/net-analyzer/ethloop/ethloop-10-r3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/ethloop/ethloop-10-r3.ebuild,v 1.1 2010/12/27 17:32:24 jer Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Local simulator for testing Linux QoS disciplines"
+HOMEPAGE="http://luxik.cdi.cz/~devik/qos/ethloop/"
+SRC_URI="http://luxik.cdi.cz/~devik/qos/ethloop/ethloop10.tgz"
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc45.patch
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dosbin ethloop
+}