summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOtavio Rodolfo Piske <angusyoung@gentoo.org>2005-01-25 15:15:35 +0000
committerOtavio Rodolfo Piske <angusyoung@gentoo.org>2005-01-25 15:15:35 +0000
commit634bd1f2a4b3b97251d57998117c3fde14c14d08 (patch)
tree7402829526182bd4bdffdbf005b12611ec1f6536 /net-analyzer/echoping
parentfixed .so installing (bug #79412) and merged suggestions of Martin Wienold <m... (diff)
downloadgentoo-2-634bd1f2a4b3b97251d57998117c3fde14c14d08.tar.gz
gentoo-2-634bd1f2a4b3b97251d57998117c3fde14c14d08.tar.bz2
gentoo-2-634bd1f2a4b3b97251d57998117c3fde14c14d08.zip
Initial release of echoping, thus closing bug #71388
(Portage version: 2.0.51-r15)
Diffstat (limited to 'net-analyzer/echoping')
-rw-r--r--net-analyzer/echoping/ChangeLog11
-rw-r--r--net-analyzer/echoping/Manifest3
-rw-r--r--net-analyzer/echoping/echoping-5.2.0.ebuild53
-rw-r--r--net-analyzer/echoping/files/digest-echoping-5.2.01
-rw-r--r--net-analyzer/echoping/files/maxtoread-5.2.0.patch12
-rw-r--r--net-analyzer/echoping/metadata.xml9
6 files changed, 89 insertions, 0 deletions
diff --git a/net-analyzer/echoping/ChangeLog b/net-analyzer/echoping/ChangeLog
new file mode 100644
index 000000000000..08497101b881
--- /dev/null
+++ b/net-analyzer/echoping/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for net-analyzer/echoping
+# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/echoping/ChangeLog,v 1.1 2005/01/25 15:15:35 angusyoung Exp $
+
+*echoping-5.2.0 (25 Jan 2005)
+
+ 25 Jan 2005; Otavio R. Piske <angusyoung@gentoo.org>
+ +files/maxtoread-5.2.0.patch, +echoping-5.2.0.ebuild:
+ Initial release. Thanks to Gudleik Rasch <gudleik@rastamatra.org> for
+ submitting the ebuild.
+
diff --git a/net-analyzer/echoping/Manifest b/net-analyzer/echoping/Manifest
new file mode 100644
index 000000000000..fadded409f86
--- /dev/null
+++ b/net-analyzer/echoping/Manifest
@@ -0,0 +1,3 @@
+MD5 7049d1f62e7f86c771ff8393c740edd3 echoping-5.2.0.ebuild 891
+MD5 79b796b1e50040a7252760c11a8b7e35 .echoping-5.2.0.ebuild.swp 12288
+MD5 4783578f5986c067408a04d82e5ed589 files/digest-echoping-5.2.0 66
diff --git a/net-analyzer/echoping/echoping-5.2.0.ebuild b/net-analyzer/echoping/echoping-5.2.0.ebuild
new file mode 100644
index 000000000000..41a0a3d24fa5
--- /dev/null
+++ b/net-analyzer/echoping/echoping-5.2.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/echoping/echoping-5.2.0.ebuild,v 1.1 2005/01/25 15:15:35 angusyoung Exp $
+
+inherit eutils
+
+DESCRIPTION="echoping is a small program to test performances of remote hosts with TCP 'echo' packets"
+HOMEPAGE="http://echoping.sourceforge.net/"
+SRC_URI="mirror://sourceforge/echoping/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="gnutls http icp idn priority smtp ssl tos"
+
+# Add suport to libidn
+DEPEND="gnutls? ( >=net-libs/gnutls-1.0.17 )
+ ssl? ( >=dev-libs/openssl-0.9.7d )
+ idn? ( net-dns/libidn )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ if ! use http ; then
+ # This patch defines maxtoread eventhough http is not
+ # enabled. This avoids an error in readline.c:56.
+ epatch ${FILESDIR}/maxtoread-${PV}.patch
+ fi
+}
+
+src_compile() {
+ econf \
+ --disable-ttcp \
+ `use_with gnutls` \
+ `use_enable http` \
+ `use_enable icp` \
+ `use_with idn libidn` \
+ `use_enable icp` \
+ `use_enable smtp` \
+ `use_enable tos` \
+ `use_enable priority` \
+ `use_with ssl` || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die
+
+ # They are not installed by einstall
+ dodoc README AUTHORS ChangeLog COPYING DETAILS NEWS TODO
+}
diff --git a/net-analyzer/echoping/files/digest-echoping-5.2.0 b/net-analyzer/echoping/files/digest-echoping-5.2.0
new file mode 100644
index 000000000000..45f38a6f17e4
--- /dev/null
+++ b/net-analyzer/echoping/files/digest-echoping-5.2.0
@@ -0,0 +1 @@
+MD5 aef46a1d09a1083e99eb5e18e9184af2 echoping-5.2.0.tar.gz 120911
diff --git a/net-analyzer/echoping/files/maxtoread-5.2.0.patch b/net-analyzer/echoping/files/maxtoread-5.2.0.patch
new file mode 100644
index 000000000000..154ceafae848
--- /dev/null
+++ b/net-analyzer/echoping/files/maxtoread-5.2.0.patch
@@ -0,0 +1,12 @@
+--- echoping.h.orig 2005-01-25 12:57:52.144117296 -0200
++++ echoping.h 2005-01-25 12:58:11.392191144 -0200
+@@ -11,9 +11,7 @@
+ #define DEFLINE 256
+ #define MAXLINE 65535
+ #define UDPMAX 65535
+-#ifdef HTTP
+ #define MAXTOREAD 150000
+-#endif
+ #ifdef SMTP
+ #define MAXSMTP 1024
+ #define MAXSMTPLINES 30
diff --git a/net-analyzer/echoping/metadata.xml b/net-analyzer/echoping/metadata.xml
new file mode 100644
index 000000000000..e788d53e1163
--- /dev/null
+++ b/net-analyzer/echoping/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+<maintainer>
+ <email>angusyoung@gentoo.org</email>
+ <name>Otavio R. Piske</name>
+</maintainer>
+</pkgmetadata>