summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEldad Zack <eldad@gentoo.org>2004-08-23 10:02:16 +0000
committerEldad Zack <eldad@gentoo.org>2004-08-23 10:02:16 +0000
commit892ef7f7a086fa37a7f299010f2970ee61a2745e (patch)
treefa43283f6c6d113aa07c4d473d485f743b96ccf1 /net-analyzer/cacti
parentmark x86 (Manifest recommit) (diff)
downloadgentoo-2-892ef7f7a086fa37a7f299010f2970ee61a2745e.tar.gz
gentoo-2-892ef7f7a086fa37a7f299010f2970ee61a2745e.tar.bz2
gentoo-2-892ef7f7a086fa37a7f299010f2970ee61a2745e.zip
Migrated ebuild from webapp-apache.eclass to use the webapp.eclass. Closes bug 52596
Diffstat (limited to 'net-analyzer/cacti')
-rw-r--r--net-analyzer/cacti/ChangeLog8
-rw-r--r--net-analyzer/cacti/Manifest12
-rw-r--r--net-analyzer/cacti/cacti-0.8.5a-r2.ebuild122
-rw-r--r--net-analyzer/cacti/files/digest-cacti-0.8.5a-r21
4 files changed, 132 insertions, 11 deletions
diff --git a/net-analyzer/cacti/ChangeLog b/net-analyzer/cacti/ChangeLog
index 75da3a9c3c43..88a0b8e614f9 100644
--- a/net-analyzer/cacti/ChangeLog
+++ b/net-analyzer/cacti/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-analyzer/cacti
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.29 2004/08/17 14:36:48 eldad Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.30 2004/08/23 10:02:16 eldad Exp $
+
+*cacti-0.8.5a-r2 (23 Aug 2004)
+
+ 23 Aug 2004; Eldad Zack <eldad@gentoo.org> +cacti-0.8.5a-r2.ebuild:
+ Migrated ebuild from webapp-apache.eclass to use the webapp.eclass.
+ Closes bug #52596.
17 Aug 2004; Eldad Zack <eldad@gentoo.org> cacti-0.8.5a-r1.ebuild:
Moved include/config.php to include/config-sample.php, so we won't overwrite
diff --git a/net-analyzer/cacti/Manifest b/net-analyzer/cacti/Manifest
index 80d2ec200c9e..2b99e76aeef5 100644
--- a/net-analyzer/cacti/Manifest
+++ b/net-analyzer/cacti/Manifest
@@ -1,17 +1,9 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
MD5 3c5429026810fd126265aac06c4cdd93 cacti-0.8.5a-r1.ebuild 4654
MD5 37f166bdab6b6aea120532c1f9fb87c4 cacti-0.8.5a.ebuild 4440
MD5 f8627b49731a4bdfa31c39f589ae9e28 ChangeLog 3719
MD5 9683bb7323c40d69b48d54ad0eb169ed metadata.xml 221
+MD5 bbaa230a40ab95ac72f21d9138a4a676 cacti-0.8.5a-r2.ebuild 4221
MD5 44637d48edf68b76a472c70817449cd6 files/digest-cacti-0.8.5a 64
MD5 9921205d0e13d5948104d5de2e58d3ee files/cacti-0.8.5a-sql-injection.patch 625
MD5 44637d48edf68b76a472c70817449cd6 files/digest-cacti-0.8.5a-r1 64
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.4 (GNU/Linux)
-
-iD8DBQFBIhikT+MN7JbqCpMRAnzuAJ9wOqcTpF0pswvDhuSinQK3cKY0XwCeKF3T
-Vg0mgJ1U959lcuqWitKAvk8=
-=nDK2
------END PGP SIGNATURE-----
+MD5 44637d48edf68b76a472c70817449cd6 files/digest-cacti-0.8.5a-r2 64
diff --git a/net-analyzer/cacti/cacti-0.8.5a-r2.ebuild b/net-analyzer/cacti/cacti-0.8.5a-r2.ebuild
new file mode 100644
index 000000000000..28aa18ece305
--- /dev/null
+++ b/net-analyzer/cacti/cacti-0.8.5a-r2.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.5a-r2.ebuild,v 1.1 2004/08/23 10:02:16 eldad Exp $
+
+inherit eutils webapp
+
+DESCRIPTION="Cacti is a complete frontend to rrdtool"
+HOMEPAGE="http://www.raxnet.net/products/cacti/"
+SRC_URI="http://www.raxnet.net/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+IUSE="snmp mysql"
+
+DEPEND=""
+
+# TODO: RDEPEND Not just apache... but there's no virtual/webserver (yet)
+
+RDEPEND="net-www/apache
+ snmp? ( virtual/snmp )
+ net-analyzer/rrdtool
+ mysql? ( dev-db/mysql )
+ dev-php/php
+ dev-php/mod_php"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/cacti-0.8.5a-sql-injection.patch
+}
+
+src_install() {
+ webapp_src_preinst
+
+ dodoc LICENSE
+ rm LICENSE README
+
+ dodoc docs/{CHANGELOG,CONTRIB,INSTALL,README,REQUIREMENTS,UPGRADE}
+ rm -rf docs
+ rm -rf cactid
+
+ #Don't overwrite old config
+ mv include/config.php include/config-sample.php
+
+ edos2unix `find -type f -name '*.php'`
+
+ dodir ${D}${MY_HTDOCSDIR}
+ cp -r . ${D}${MY_HTDOCSDIR}
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ # check to see if we have a previous version installed
+ ver_installed="$(ls -d /var/db/pkg/net-analyzer/cacti* | sed 's:.*cacti-::')"
+ if [[ ${ver_installed} != ${PV} ]]
+ then
+ einfo
+ einfo "Before cacti works you must upgrade the cacti database:"
+ einfo "1. Backup the old cacti database:"
+ einfo " shell> mysqlhotcopy --suffix=_old cacti"
+ einfo "2. Drop the old cacti database:"
+ einfo " shell> mysqladmin -p drop cacti"
+ einfo "3. Create the new cacti database"
+ einfo " shell> mysqladmin --user=root create cacti"
+ einfo "4. Import the default cacti database:"
+ einfo " shell> mysql cacti < ${HTTPD_ROOT}${PN}/cacti.sql"
+ einfo "5. Edit ${HTTPD_ROOT}${PN}/include/config.php."
+ einfo " + Modify the MySQL user, password and database for your"
+ einfo " cacti configuration."
+ einfo " \$database_default = \"cacti\";"
+ einfo " \$database_hostname = \"localhost\";"
+ einfo " \$database_username = \"cactiuser\";"
+ einfo " \$database_password = \"cacti\";"
+ einfo "6. Add this line to your /etc/crontab file:"
+ einfo " */5 * * * * ${HTTPD_USER} php ${HTTPD_ROOT}${PN}/cmd.php > /dev/null 2>&1"
+ einfo "7. Point your web browser to: http://your-server/cacti/"
+ einfo " Select \"Upgrade\"."
+ einfo " Make sure to fill in all of the path variables carefully and"
+ einfo " correctly on the following screen."
+ einfo
+ einfo "FINALLY, you must have these settings in your php.ini:"
+ einfo " register_globals = On"
+ einfo " register_argc_argv = On"
+ einfo
+ einfo "Test your upgraded installation. When all is fine you can"
+ einfo "drop the cacti_old database like so:"
+ einfo " shell> mysqladmin -p drop cacti_old"
+ einfo
+ else
+ einfo
+ einfo "Before cacti works you must:"
+ einfo "1. Create the new cacti database"
+ einfo " shell> mysqladmin --user=root create cacti"
+ einfo "2. Import the default cacti database:"
+ einfo " shell> mysql cacti < ${HTTPD_ROOT}${PN}/cacti.sql"
+ einfo "3. Optional: Create a MySQL username and password for cacti."
+ einfo " shell> mysql --user=root mysql"
+ einfo " mysql> GRANT ALL ON cacti.* TO cactiuser@localhost IDENTIFIED BY 'somepassword';"
+ einfo " mysql> flush privileges;"
+ einfo "4. Copy ${HTTPD_ROOT}${PN}/include/config-sample.php to config.php."
+ einfo " + Modify the MySQL user, password and database for your"
+ einfo " cacti configuration."
+ einfo " \$database_default = \"cacti\";"
+ einfo " \$database_hostname = \"localhost\";"
+ einfo " \$database_username = \"cactiuser\";"
+ einfo " \$database_password = \"cacti\";"
+ einfo "5. Add this line to your /etc/crontab file:"
+ einfo " */5 * * * * ${HTTPD_USER} php ${HTTPD_ROOT}${PN}/cmd.php > /dev/null 2>&1"
+ einfo "6. Point your web browser to: http://your-server/cacti/"
+ einfo " Make sure to fill in all of the path variables carefully and"
+ einfo " correctly on the following screen."
+ einfo
+ einfo "FINALLY, you must have these settings in your php.ini:"
+ einfo " register_globals = On"
+ einfo " register_argc_argv = On"
+ einfo
+ fi
+
+ webapp_pkg_postinst
+}
diff --git a/net-analyzer/cacti/files/digest-cacti-0.8.5a-r2 b/net-analyzer/cacti/files/digest-cacti-0.8.5a-r2
new file mode 100644
index 000000000000..7a5183477ccd
--- /dev/null
+++ b/net-analyzer/cacti/files/digest-cacti-0.8.5a-r2
@@ -0,0 +1 @@
+MD5 2b9ef4194664d65b86cdcc9a0f126609 cacti-0.8.5a.tar.gz 986785