summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-08-06 23:27:33 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-08-06 23:27:33 +0000
commitedb69cdd93a88e906a375cc96d0baad23e632965 (patch)
treec619bfa32e9768f4cc56503edc097d68e9f8ebc2 /media-video
parentremove old (diff)
downloadgentoo-2-edb69cdd93a88e906a375cc96d0baad23e632965.tar.gz
gentoo-2-edb69cdd93a88e906a375cc96d0baad23e632965.tar.bz2
gentoo-2-edb69cdd93a88e906a375cc96d0baad23e632965.zip
fix build with gcc 4.3
(Portage version: 2.2_rc6/cvs/Linux 2.6.26-gentoo x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/dvbcut/ChangeLog6
-rw-r--r--media-video/dvbcut/dvbcut-0.5.4-r1.ebuild3
-rw-r--r--media-video/dvbcut/files/dvbcut-0.5.4-gcc43.patch24
3 files changed, 31 insertions, 2 deletions
diff --git a/media-video/dvbcut/ChangeLog b/media-video/dvbcut/ChangeLog
index 49796c225405..40f1a57324a2 100644
--- a/media-video/dvbcut/ChangeLog
+++ b/media-video/dvbcut/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/dvbcut
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/dvbcut/ChangeLog,v 1.12 2008/08/06 23:23:17 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvbcut/ChangeLog,v 1.13 2008/08/06 23:27:32 aballier Exp $
+
+ 06 Aug 2008; Alexis Ballier <aballier@gentoo.org>
+ +files/dvbcut-0.5.4-gcc43.patch, dvbcut-0.5.4-r1.ebuild:
+ fix build with gcc 4.3
06 Aug 2008; Alexis Ballier <aballier@gentoo.org> -dvbcut-0.5.4.ebuild:
remove old
diff --git a/media-video/dvbcut/dvbcut-0.5.4-r1.ebuild b/media-video/dvbcut/dvbcut-0.5.4-r1.ebuild
index 89afdea5ab2d..06bf4daccff1 100644
--- a/media-video/dvbcut/dvbcut-0.5.4-r1.ebuild
+++ b/media-video/dvbcut/dvbcut-0.5.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/dvbcut/dvbcut-0.5.4-r1.ebuild,v 1.4 2008/07/27 21:55:26 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvbcut/dvbcut-0.5.4-r1.ebuild,v 1.5 2008/08/06 23:27:32 aballier Exp $
EAPI=1
@@ -39,6 +39,7 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}/${PN}-0.5.3-ffmpeg-compat.patch"
epatch "${FILESDIR}/${P}-gcc42.patch"
+ epatch "${FILESDIR}/${P}-gcc43.patch"
epatch "${FILESDIR}/${P}-ffmpeg-compat2.patch"
epatch "${FILESDIR}/${P}-ffmpeg-compat3.patch"
epatch "${FILESDIR}/${P}-avformat-api-changes.patch"
diff --git a/media-video/dvbcut/files/dvbcut-0.5.4-gcc43.patch b/media-video/dvbcut/files/dvbcut-0.5.4-gcc43.patch
new file mode 100644
index 000000000000..7bf06bb7fcd9
--- /dev/null
+++ b/media-video/dvbcut/files/dvbcut-0.5.4-gcc43.patch
@@ -0,0 +1,24 @@
+Index: dvbcut-0.5.4/src/mpegmuxer.cpp
+===================================================================
+--- dvbcut-0.5.4.orig/src/mpegmuxer.cpp
++++ dvbcut-0.5.4/src/mpegmuxer.cpp
+@@ -16,6 +16,7 @@
+ Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+
++#include <cstdlib>
+ #include <string.h>
+ #include <strings.h>
+ #include <unistd.h>
+Index: dvbcut-0.5.4/src/mpgfile.cpp
+===================================================================
+--- dvbcut-0.5.4.orig/src/mpgfile.cpp
++++ dvbcut-0.5.4/src/mpgfile.cpp
+@@ -16,6 +16,7 @@
+ Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 USA
+ */
+
++#include <cstdlib>
+ #include <string.h>
+ #include <stdint.h>
+ #include <errno.h>