summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDror Levin <spatz@gentoo.org>2010-03-20 20:27:25 +0000
committerDror Levin <spatz@gentoo.org>2010-03-20 20:27:25 +0000
commitd85f8bce73ea460b978304202c8b579ace6f9f95 (patch)
tree5f71169066ba07667cc0981019bc1f04a6247867 /media-video
parentFix buffer overflow during save. Bug #310379 (diff)
downloadgentoo-2-d85f8bce73ea460b978304202c8b579ace6f9f95.tar.gz
gentoo-2-d85f8bce73ea460b978304202c8b579ace6f9f95.tar.bz2
gentoo-2-d85f8bce73ea460b978304202c8b579ace6f9f95.zip
Version bump, bug 304025. Updated usage of python eclass and also dep on >=pygtk-2.16. Remove old.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/devede/ChangeLog9
-rw-r--r--media-video/devede/devede-3.16.6.ebuild (renamed from media-video/devede/devede-3.11b.ebuild)19
-rw-r--r--media-video/devede/devede-3.6.ebuild44
3 files changed, 22 insertions, 50 deletions
diff --git a/media-video/devede/ChangeLog b/media-video/devede/ChangeLog
index 10450e1f548b..5f72bc036c2d 100644
--- a/media-video/devede/ChangeLog
+++ b/media-video/devede/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/devede
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/devede/ChangeLog,v 1.25 2010/01/07 14:23:14 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/devede/ChangeLog,v 1.26 2010/03/20 20:27:25 spatz Exp $
+
+*devede-3.16.6 (20 Mar 2010)
+
+ 20 Mar 2010; Dror Levin <spatz@gentoo.org> -devede-3.6.ebuild,
+ -devede-3.11b.ebuild, +devede-3.16.6.ebuild:
+ Version bump, bug 304025. Updated usage of python eclass and also dep on
+ >=pygtk-2.16. Remove old.
*devede-3.15.2 (07 Jan 2010)
diff --git a/media-video/devede/devede-3.11b.ebuild b/media-video/devede/devede-3.16.6.ebuild
index a4396eb594d3..774ab65ed5d0 100644
--- a/media-video/devede/devede-3.11b.ebuild
+++ b/media-video/devede/devede-3.16.6.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/devede/devede-3.11b.ebuild,v 1.1 2008/09/08 04:47:43 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/devede/devede-3.16.6.ebuild,v 1.1 2010/03/20 20:27:25 spatz Exp $
-NEED_PYTHON=2.4
+EAPI=2
+PYTHON_DEPEND=2
inherit multilib python
@@ -15,8 +16,8 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="psyco"
-RDEPEND=">=x11-libs/gtk+-2.6
- dev-python/pygtk
+RDEPEND=">=x11-libs/gtk+-2.16
+ >=dev-python/pygtk-2.16
>=media-video/mplayer-1.0_rc1
media-video/dvdauthor
media-video/vcdimager
@@ -26,6 +27,14 @@ DEPEND=""
S=${WORKDIR}/${P%*b}
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ python_convert_shebangs -r 2 .
+}
+
src_install() {
./install.sh prefix="/usr" libdir="/usr/$(get_libdir)" \
pkgdocdir="/usr/share/doc/${PF}" DESTDIR="${D}" \
diff --git a/media-video/devede/devede-3.6.ebuild b/media-video/devede/devede-3.6.ebuild
deleted file mode 100644
index 71a4da323456..000000000000
--- a/media-video/devede/devede-3.6.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/devede/devede-3.6.ebuild,v 1.4 2008/05/29 17:27:21 hawking Exp $
-
-NEED_PYTHON=2.4
-
-inherit multilib python
-
-DESCRIPTION="DVD Video Creator"
-HOMEPAGE="http://www.rastersoft.com/programas/devede.html"
-SRC_URI="http://www.rastersoft.com/descargas/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc psyco"
-
-RDEPEND=">=x11-libs/gtk+-2.6
- dev-python/pygtk
- >=media-video/mplayer-1.0_rc1
- media-video/dvdauthor
- media-video/vcdimager
- psyco? ( dev-python/psyco )
- virtual/cdrtools"
-DEPEND=""
-
-src_install() {
- ./install.sh prefix="/usr" libdir="/usr/$(get_libdir)" \
- DESTDIR="${D}" || die "install.sh failed."
- rm -rf "${D}"/usr/share/doc/devede
- use doc && dohtml docs/*
-}
-
-pkg_postinst() {
- python_mod_optimize /usr/$(get_libdir)/${PN}
- elog "To create DIVX/MPEG4 files, be sure that MPlayer is compiled with LAME support."
- elog "In this case you want to check for both the encode and mp3 USE flags."
- elog "To change the font used to render the subtitles, choose a TrueType font you like"
- elog "and copy it in \$HOME/.spumux directory, renaming it to devedesans.ttf."
-}
-
-pkg_postrm() {
- python_mod_cleanup /usr/$(get_libdir)/${PN}
-}