summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-07-26 21:30:52 +0000
committerMichał Górny <mgorny@gentoo.org>2015-07-26 21:30:52 +0000
commit963033e25bf4cdaccc39ea480dc64c2ac2c70d94 (patch)
treeaf03603429e7ff4e903e559c59e53989c9d33d24 /media-video
parentRevert pypy support because of broken deps (diff)
downloadgentoo-2-963033e25bf4cdaccc39ea480dc64c2ac2c70d94.tar.gz
gentoo-2-963033e25bf4cdaccc39ea480dc64c2ac2c70d94.tar.bz2
gentoo-2-963033e25bf4cdaccc39ea480dc64c2ac2c70d94.zip
Version bump. Update homepage and switch to cmake. https://github.com/gentoo/gentoo-portage-rsync-mirror/pull/175 by a17r.
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/ffmpegthumbnailer/ChangeLog14
-rw-r--r--media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.10.ebuild53
-rw-r--r--media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-config-summary.patch23
-rw-r--r--media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-installdirs.patch47
-rw-r--r--media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-set-locale.patch46
5 files changed, 181 insertions, 2 deletions
diff --git a/media-video/ffmpegthumbnailer/ChangeLog b/media-video/ffmpegthumbnailer/ChangeLog
index 18620d132139..d514bbaed022 100644
--- a/media-video/ffmpegthumbnailer/ChangeLog
+++ b/media-video/ffmpegthumbnailer/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for media-video/ffmpegthumbnailer
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ChangeLog,v 1.151 2013/04/05 20:39:09 ssuominen Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ChangeLog,v 1.152 2015/07/26 21:30:52 mgorny Exp $
+
+*ffmpegthumbnailer-2.0.10 (26 Jul 2015)
+
+ 26 Jul 2015; Michał Górny <mgorny@gentoo.org>
+ +ffmpegthumbnailer-2.0.10.ebuild,
+ +files/ffmpegthumbnailer-2.0.10-config-summary.patch,
+ +files/ffmpegthumbnailer-2.0.10-installdirs.patch,
+ +files/ffmpegthumbnailer-2.0.10-set-locale.patch:
+ Version bump. Update homepage and switch to cmake. https://github.com/gentoo
+ /gentoo-portage-rsync-mirror/pull/175 by a17r.
05 Apr 2013; Samuli Suominen <ssuominen@gentoo.org>
ffmpegthumbnailer-2.0.8.ebuild:
diff --git a/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.10.ebuild b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.10.ebuild
new file mode 100644
index 000000000000..cc1d00558cd9
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.10.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/ffmpegthumbnailer/ffmpegthumbnailer-2.0.10.ebuild,v 1.1 2015/07/26 21:30:52 mgorny Exp $
+
+EAPI=5
+
+inherit cmake-utils
+
+DESCRIPTION="Lightweight video thumbnailer that can be used by file managers"
+HOMEPAGE="https://github.com/dirkvdb/ffmpegthumbnailer"
+SRC_URI="https://github.com/dirkvdb/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="gnome gtk jpeg libav png test"
+
+RDEPEND="
+ gtk? ( dev-libs/glib:2= )
+ jpeg? ( virtual/jpeg:0= )
+ !libav? ( >=media-video/ffmpeg-2.7:0= )
+ libav? ( >=media-video/libav-11:0= )
+ png? ( media-libs/libpng:0= )
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+REQUIRED_USE="gnome? ( gtk )"
+
+PATCHES=(
+ "${FILESDIR}/${P}-config-summary.patch"
+ "${FILESDIR}/${P}-installdirs.patch"
+ "${FILESDIR}/${P}-set-locale.patch"
+)
+
+DOCS=( AUTHORS ChangeLog README.md )
+
+src_prepare() {
+ rm -rf out* || die
+
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_GIO=$(usex gtk)
+ -DENABLE_TESTS=$(usex test)
+ -DENABLE_THUMBNAILER=$(usex gnome)
+ -DHAVE_JPEG=$(usex jpeg)
+ -DHAVE_PNG=$(usex png)
+ )
+ cmake-utils_src_configure
+}
diff --git a/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-config-summary.patch b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-config-summary.patch
new file mode 100644
index 000000000000..608494559217
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-config-summary.patch
@@ -0,0 +1,23 @@
+From 9c2a5fe997a6d8b00bef49eabb7bc49840882ec6 Mon Sep 17 00:00:00 2001
+From: Dirk Vanden Boer <dirk.vdb@gmail.com>
+Date: Wed, 29 Apr 2015 20:19:58 +0200
+Subject: [PATCH] Fixed configuration summary
+
+---
+ .travis.yml | 1 +
+ CMakeLists.txt | 2 +-
+ 2 files changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 22803d9..6b6e515 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -239,7 +239,7 @@ ELSE ()
+ MESSAGE(STATUS "register thumbnailer : disabled")
+ ENDIF ()
+
+-IF (ENABLE_UNITTEST)
++IF (ENABLE_TESTS)
+ MESSAGE(STATUS "unittests : enabled")
+ ELSE ()
+ MESSAGE(STATUS "unittests : disabled")
diff --git a/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-installdirs.patch b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-installdirs.patch
new file mode 100644
index 000000000000..33a96b85735d
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-installdirs.patch
@@ -0,0 +1,47 @@
+From 621274d694dee1f8c92f5db99a5cff98e82c6bd4 Mon Sep 17 00:00:00 2001
+From: Dirk Vanden Boer <dirk.vdb@gmail.com>
+Date: Sat, 2 May 2015 09:33:34 +0200
+Subject: [PATCH] Use proper gnu installation dirs (Thanks to Vallimar)
+
+---
+ CMakeLists.txt | 15 ++++++++-------
+ ChangeLog | 1 +
+ 2 files changed, 9 insertions(+), 7 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 6b6e515..badb7cf 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -25,6 +25,7 @@ ENDIF ()
+
+ PROJECT(${PACKAGE})
+ INCLUDE(CPack)
++INCLUDE(GNUInstallDirs)
+
+ SET(CMAKE_EXPORT_COMPILE_COMMANDS 1)
+ SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=c++11")
+@@ -189,17 +190,17 @@ ELSE ()
+ ENDIF ()
+
+ INSTALL(TARGETS ffmpegthumbnailer ${STATIC_LIB} ${SHARED_LIB}
+- LIBRARY DESTINATION ${CMAKE_INSTALL_PREFIX}/lib
+- RUNTIME DESTINATION ${CMAKE_INSTALL_PREFIX}/bin
+- ARCHIVE DESTINATION ${CMAKE_INSTALL_PREFIX}/lib
+- PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_PREFIX}/include/libffmpegthumbnailer
++ LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
++ ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR}
++ PUBLIC_HEADER DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}/libffmpegthumbnailer
+ )
+
+-INSTALL(FILES man/ffmpegthumbnailer.1 DESTINATION ${CMAKE_INSTALL_PREFIX}/man/man1)
+-INSTALL(FILES ${CMAKE_BINARY_DIR}/libffmpegthumbnailer.pc DESTINATION ${CMAKE_INSTALL_PREFIX}/lib/pkgconfig)
++INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/man/ffmpegthumbnailer.1 DESTINATION ${CMAKE_INSTALL_MANDIR}/man1)
++INSTALL(FILES ${CMAKE_BINARY_DIR}/libffmpegthumbnailer.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+
+ IF (ENABLE_THUMBNAILER)
+- INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/dist/ffmpegthumbnailer.thumbnailer DESTINATION ${CMAKE_INSTALL_PREFIX}/share/thumbnailers)
++ INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/dist/ffmpegthumbnailer.thumbnailer DESTINATION ${CMAKE_INSTALL_DATADIR}/thumbnailers)
+ ENDIF ()
+
+ CONFIGURE_FILE(${CMAKE_SOURCE_DIR}/config.h.in ${CMAKE_BINARY_DIR}/config.h)
diff --git a/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-set-locale.patch b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-set-locale.patch
new file mode 100644
index 000000000000..b1a198a93a1e
--- /dev/null
+++ b/media-video/ffmpegthumbnailer/files/ffmpegthumbnailer-2.0.10-set-locale.patch
@@ -0,0 +1,46 @@
+From 718f1b1147fe7e9138e2d503ed151e589d643772 Mon Sep 17 00:00:00 2001
+From: Dirk Vanden Boer <dirk.vdb@gmail.com>
+Date: Sat, 18 Jul 2015 10:24:28 +0200
+Subject: [PATCH] Set locale to the user specified locale
+
+---
+ main.cpp | 5 ++---
+ test/testrunner.cpp | 7 ++-----
+ 2 files changed, 4 insertions(+), 8 deletions(-)
+
+diff --git a/main.cpp b/main.cpp
+index 6cb6c55..7cb7089 100644
+--- a/main.cpp
++++ b/main.cpp
+@@ -54,10 +54,9 @@ int main(int argc, char** argv)
+ string outputFile;
+ string imageFormat;
+
+- if (!setlocale(LC_CTYPE, "en_US.UTF-8"))
++ if (!std::setlocale(LC_CTYPE, ""))
+ {
+- std::cerr << "Locale not specified. Check LANG, LC_CTYPE, LC_ALL" << std::endl;
+- return 1;
++ std::cerr << "Failed to set locale" << std::endl;
+ }
+
+ while ((option = getopt (argc, argv, "i:o:s:t:q:c:afwhvp")) != -1)
+diff --git a/test/testrunner.cpp b/test/testrunner.cpp
+index 7023d25..20a4903 100644
+--- a/test/testrunner.cpp
++++ b/test/testrunner.cpp
+@@ -4,12 +4,9 @@
+ #include <gtest/gtest.h>
+
+ int main(int argc, char **argv) {
+- std::cout << "Running ffmpegthumbnailer tests" << std::endl;
+-
+- if (!setlocale(LC_CTYPE, "en_US.UTF-8"))
++ if (!std::setlocale(LC_CTYPE, ""))
+ {
+- std::cerr << "Locale not specified. Check LANG, LC_CTYPE, LC_ALL" << std::endl;
+- return 1;
++ std::cerr << "Failed to set locale" << std::endl;
+ }
+
+ testing::InitGoogleTest(&argc, argv);