summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-01-03 12:22:14 +0000
committerMichał Górny <mgorny@gentoo.org>2015-01-03 12:22:14 +0000
commit5f437471c75a20ad9083aaf2a0d289277849d2a2 (patch)
treea7afef866a1f75fcedaf87edfa45458c3c937157 /media-video
parentNew snapshot of trunk. (diff)
downloadgentoo-2-5f437471c75a20ad9083aaf2a0d289277849d2a2.tar.gz
gentoo-2-5f437471c75a20ad9083aaf2a0d289277849d2a2.tar.bz2
gentoo-2-5f437471c75a20ad9083aaf2a0d289277849d2a2.zip
Use python-any-r1 for waf.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'media-video')
-rw-r--r--media-video/mpv/ChangeLog9
-rw-r--r--media-video/mpv/mpv-0.3.10.ebuild12
-rw-r--r--media-video/mpv/mpv-0.3.11.ebuild12
-rw-r--r--media-video/mpv/mpv-0.6.2.ebuild12
-rw-r--r--media-video/mpv/mpv-0.7.1.ebuild12
-rw-r--r--media-video/mpv/mpv-0.7.2.ebuild12
-rw-r--r--media-video/mpv/mpv-9999.ebuild12
7 files changed, 61 insertions, 20 deletions
diff --git a/media-video/mpv/ChangeLog b/media-video/mpv/ChangeLog
index baa2068df888..06445712357a 100644
--- a/media-video/mpv/ChangeLog
+++ b/media-video/mpv/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-video/mpv
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mpv/ChangeLog,v 1.110 2014/12/29 14:15:58 dlan Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/mpv/ChangeLog,v 1.111 2015/01/03 12:22:14 mgorny Exp $
+
+ 03 Jan 2015; Michał Górny <mgorny@gentoo.org> mpv-0.3.10.ebuild,
+ mpv-0.3.11.ebuild, mpv-0.6.2.ebuild, mpv-0.7.1.ebuild, mpv-0.7.2.ebuild,
+ mpv-9999.ebuild:
+ Use python-any-r1 for waf.
*mpv-0.7.2 (29 Dec 2014)
diff --git a/media-video/mpv/mpv-0.3.10.ebuild b/media-video/mpv/mpv-0.3.10.ebuild
index d6501c2da94e..272e0c1552c4 100644
--- a/media-video/mpv/mpv-0.3.10.ebuild
+++ b/media-video/mpv/mpv-0.3.10.ebuild
@@ -1,12 +1,15 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mpv/mpv-0.3.10.ebuild,v 1.8 2014/11/02 12:07:03 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mpv/mpv-0.3.10.ebuild,v 1.9 2015/01/03 12:22:14 mgorny Exp $
EAPI=5
EGIT_REPO_URI="https://github.com/mpv-player/mpv.git"
-inherit eutils waf-utils pax-utils fdo-mime gnome2-utils
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE='threads(+)'
+
+inherit eutils python-any-r1 waf-utils pax-utils fdo-mime gnome2-utils
[[ ${PV} == *9999* ]] && inherit git-r3
WAF_V="1.7.15"
@@ -117,6 +120,7 @@ RDEPEND+="
)
"
DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
virtual/pkgconfig
>=dev-lang/perl-5.8
dev-python/docutils
@@ -147,6 +151,8 @@ pkg_setup() {
einfo "For additional format support you need to enable the support on your"
einfo "libavcodec/libavformat provider:"
einfo " media-video/libav or media-video/ffmpeg"
+
+ python-any-r1_pkg_setup
}
src_unpack() {
diff --git a/media-video/mpv/mpv-0.3.11.ebuild b/media-video/mpv/mpv-0.3.11.ebuild
index 1f00b837cb49..2168cdd780ed 100644
--- a/media-video/mpv/mpv-0.3.11.ebuild
+++ b/media-video/mpv/mpv-0.3.11.ebuild
@@ -1,12 +1,15 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mpv/mpv-0.3.11.ebuild,v 1.2 2014/11/02 12:07:03 swift Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mpv/mpv-0.3.11.ebuild,v 1.3 2015/01/03 12:22:14 mgorny Exp $
EAPI=5
EGIT_REPO_URI="https://github.com/mpv-player/mpv.git"
-inherit eutils waf-utils pax-utils fdo-mime gnome2-utils
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE='threads(+)'
+
+inherit eutils python-any-r1 waf-utils pax-utils fdo-mime gnome2-utils
[[ ${PV} == *9999* ]] && inherit git-r3
WAF_V="1.7.15"
@@ -117,6 +120,7 @@ RDEPEND+="
)
"
DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
virtual/pkgconfig
>=dev-lang/perl-5.8
dev-python/docutils
@@ -147,6 +151,8 @@ pkg_setup() {
einfo "For additional format support you need to enable the support on your"
einfo "libavcodec/libavformat provider:"
einfo " media-video/libav or media-video/ffmpeg"
+
+ python-any-r1_pkg_setup
}
src_unpack() {
diff --git a/media-video/mpv/mpv-0.6.2.ebuild b/media-video/mpv/mpv-0.6.2.ebuild
index 6d34ce1a33e9..82bdecce0b3c 100644
--- a/media-video/mpv/mpv-0.6.2.ebuild
+++ b/media-video/mpv/mpv-0.6.2.ebuild
@@ -1,12 +1,15 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mpv/mpv-0.6.2.ebuild,v 1.1 2014/11/14 22:46:27 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mpv/mpv-0.6.2.ebuild,v 1.2 2015/01/03 12:22:14 mgorny Exp $
EAPI=5
EGIT_REPO_URI="https://github.com/mpv-player/mpv.git"
-inherit eutils waf-utils pax-utils fdo-mime gnome2-utils
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE='threads(+)'
+
+inherit eutils python-any-r1 waf-utils pax-utils fdo-mime gnome2-utils
[[ ${PV} == *9999* ]] && inherit git-r3
WAF_V="1.7.16"
@@ -115,6 +118,7 @@ RDEPEND+="
)
"
DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
virtual/pkgconfig
>=dev-lang/perl-5.8
dev-python/docutils
@@ -139,6 +143,8 @@ pkg_setup() {
einfo "For additional format support you need to enable the support on your"
einfo "libavcodec/libavformat provider:"
einfo " media-video/libav or media-video/ffmpeg"
+
+ python-any-r1_pkg_setup
}
src_unpack() {
diff --git a/media-video/mpv/mpv-0.7.1.ebuild b/media-video/mpv/mpv-0.7.1.ebuild
index 040b8cd73568..514def1a7324 100644
--- a/media-video/mpv/mpv-0.7.1.ebuild
+++ b/media-video/mpv/mpv-0.7.1.ebuild
@@ -1,12 +1,15 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mpv/mpv-0.7.1.ebuild,v 1.1 2014/12/05 19:26:41 maksbotan Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mpv/mpv-0.7.1.ebuild,v 1.2 2015/01/03 12:22:14 mgorny Exp $
EAPI=5
EGIT_REPO_URI="https://github.com/mpv-player/mpv.git"
-inherit eutils waf-utils pax-utils fdo-mime gnome2-utils
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE='threads(+)'
+
+inherit eutils python-any-r1 waf-utils pax-utils fdo-mime gnome2-utils
[[ ${PV} == *9999* ]] && inherit git-r3
WAF_V="1.8.1"
@@ -113,6 +116,7 @@ RDEPEND="
)
"
DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
virtual/pkgconfig
>=dev-lang/perl-5.8
dev-python/docutils
@@ -137,6 +141,8 @@ pkg_setup() {
einfo "For additional format support you need to enable the support on your"
einfo "libavcodec/libavformat provider:"
einfo " media-video/libav or media-video/ffmpeg"
+
+ python-any-r1_pkg_setup
}
src_unpack() {
diff --git a/media-video/mpv/mpv-0.7.2.ebuild b/media-video/mpv/mpv-0.7.2.ebuild
index e9a4d61861e4..8283af53d3e3 100644
--- a/media-video/mpv/mpv-0.7.2.ebuild
+++ b/media-video/mpv/mpv-0.7.2.ebuild
@@ -1,12 +1,15 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mpv/mpv-0.7.2.ebuild,v 1.1 2014/12/29 14:15:58 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mpv/mpv-0.7.2.ebuild,v 1.2 2015/01/03 12:22:14 mgorny Exp $
EAPI=5
EGIT_REPO_URI="https://github.com/mpv-player/mpv.git"
-inherit eutils waf-utils pax-utils fdo-mime gnome2-utils
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE='threads(+)'
+
+inherit eutils python-any-r1 waf-utils pax-utils fdo-mime gnome2-utils
[[ ${PV} == *9999* ]] && inherit git-r3
WAF_V="1.8.1"
@@ -113,6 +116,7 @@ RDEPEND="
)
"
DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
virtual/pkgconfig
>=dev-lang/perl-5.8
dev-python/docutils
@@ -137,6 +141,8 @@ pkg_setup() {
einfo "For additional format support you need to enable the support on your"
einfo "libavcodec/libavformat provider:"
einfo " media-video/libav or media-video/ffmpeg"
+
+ python-any-r1_pkg_setup
}
src_unpack() {
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index 6706ef057174..7b82b16d2e47 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -1,12 +1,15 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/mpv/mpv-9999.ebuild,v 1.62 2014/12/29 14:15:58 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/mpv/mpv-9999.ebuild,v 1.63 2015/01/03 12:22:14 mgorny Exp $
EAPI=5
EGIT_REPO_URI="https://github.com/mpv-player/mpv.git"
-inherit eutils waf-utils pax-utils fdo-mime gnome2-utils
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE='threads(+)'
+
+inherit eutils python-any-r1 waf-utils pax-utils fdo-mime gnome2-utils
[[ ${PV} == *9999* ]] && inherit git-r3
WAF_V="1.8.4"
@@ -107,6 +110,7 @@ RDEPEND="
)
"
DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
virtual/pkgconfig
>=dev-lang/perl-5.8
dev-python/docutils
@@ -131,6 +135,8 @@ pkg_setup() {
einfo "For additional format support you need to enable the support on your"
einfo "libavcodec/libavformat provider:"
einfo " media-video/libav or media-video/ffmpeg"
+
+ python-any-r1_pkg_setup
}
src_unpack() {